diff options
Diffstat (limited to 'meta/packages/patch/patch-2.5.9/install.patch')
-rw-r--r-- | meta/packages/patch/patch-2.5.9/install.patch | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/packages/patch/patch-2.5.9/install.patch b/meta/packages/patch/patch-2.5.9/install.patch new file mode 100644 index 0000000000..c959189f37 --- /dev/null +++ b/meta/packages/patch/patch-2.5.9/install.patch | |||
@@ -0,0 +1,41 @@ | |||
1 | Index: patch-2.5.4/Makefile.in | ||
2 | =================================================================== | ||
3 | --- patch-2.5.4.orig/Makefile.in 2005-03-09 07:23:54.779311824 -0500 | ||
4 | +++ patch-2.5.4/Makefile.in 2005-03-09 07:26:09.616813408 -0500 | ||
5 | @@ -43,10 +43,11 @@ | ||
6 | PACKAGE_NAME = @PACKAGE_NAME@ | ||
7 | PACKAGE_VERSION = @PACKAGE_VERSION@ | ||
8 | |||
9 | +DESTDIR = | ||
10 | prefix = @prefix@ | ||
11 | exec_prefix = @exec_prefix@ | ||
12 | |||
13 | -bindir = $(exec_prefix)/bin | ||
14 | +bindir = @bindir@ | ||
15 | |||
16 | # Where to put the manual pages. | ||
17 | mandir = @mandir@ | ||
18 | @@ -112,18 +113,18 @@ | ||
19 | $(CC) -o $@ $(CFLAGS) $(LDFLAGS) $(OBJS) $(LIBS) | ||
20 | |||
21 | install:: all installdirs | ||
22 | - $(INSTALL_PROGRAM) patch$(EXEEXT) $(bindir)/$(patch_name)$(EXEEXT) | ||
23 | - -$(INSTALL_DATA) $(srcdir)/patch.man $(man1dir)/$(patch_name)$(man1ext) | ||
24 | + $(INSTALL_PROGRAM) patch$(EXEEXT) $(DESTDIR)$(bindir)/$(patch_name)$(EXEEXT) | ||
25 | + -$(INSTALL_DATA) $(srcdir)/patch.man $(DESTDIR)$(man1dir)/$(patch_name)$(man1ext) | ||
26 | |||
27 | installdirs:: | ||
28 | - $(SHELL) $(srcdir)/mkinstalldirs $(bindir) $(man1dir) | ||
29 | + $(SHELL) $(srcdir)/mkinstalldirs $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir) | ||
30 | |||
31 | install-strip:: | ||
32 | $(MAKE) INSTALL_PROGRAM='$(INSTALL_PROGRAM) -s' install | ||
33 | |||
34 | uninstall:: | ||
35 | - rm -f $(bindir)/$(patch_name)$(EXEEXT) | ||
36 | - rm -f $(man1dir)/$(patch_name)$(man1ext) | ||
37 | + rm -f $(DESTDIR)$(bindir)/$(patch_name)$(EXEEXT) | ||
38 | + rm -f $(DESTDIR)$(man1dir)/$(patch_name)$(man1ext) | ||
39 | |||
40 | Makefile: Makefile.in $(CONFIG_STATUS) | ||
41 | $(SHELL) $(CONFIG_STATUS) | ||