diff options
Diffstat (limited to 'meta/packages/pango')
-rw-r--r-- | meta/packages/pango/files/gtk-doc.patch | 59 | ||||
-rw-r--r-- | meta/packages/pango/files/no-tests.patch | 15 | ||||
-rw-r--r-- | meta/packages/pango/pango_1.10.0.bb | 49 | ||||
-rw-r--r-- | meta/packages/pango/pango_1.12.0.bb | 49 | ||||
-rw-r--r-- | meta/packages/pango/pango_1.13.3.bb | 49 | ||||
-rw-r--r-- | meta/packages/pango/pango_1.9.1.bb | 49 |
6 files changed, 270 insertions, 0 deletions
diff --git a/meta/packages/pango/files/gtk-doc.patch b/meta/packages/pango/files/gtk-doc.patch new file mode 100644 index 0000000000..bee5fe6310 --- /dev/null +++ b/meta/packages/pango/files/gtk-doc.patch | |||
@@ -0,0 +1,59 @@ | |||
1 | --- pango/acinclude.m4.old 2004-05-08 11:31:48.000000000 +0100 | ||
2 | +++ pango/acinclude.m4 2004-05-08 11:31:58.000000000 +0100 | ||
3 | @@ -55,3 +55,56 @@ | ||
4 | ]) | ||
5 | |||
6 | |||
7 | +dnl -*- mode: autoconf -*- | ||
8 | + | ||
9 | +# serial 1 | ||
10 | + | ||
11 | +dnl Usage: | ||
12 | +dnl GTK_DOC_CHECK([minimum-gtk-doc-version]) | ||
13 | +AC_DEFUN([GTK_DOC_CHECK], | ||
14 | +[ | ||
15 | + AC_BEFORE([AC_PROG_LIBTOOL],[$0])dnl setup libtool first | ||
16 | + AC_BEFORE([AM_PROG_LIBTOOL],[$0])dnl setup libtool first | ||
17 | + dnl for overriding the documentation installation directory | ||
18 | + AC_ARG_WITH(html-dir, | ||
19 | + AC_HELP_STRING([--with-html-dir=PATH], [path to installed docs]),, | ||
20 | + [with_html_dir='${datadir}/gtk-doc/html']) | ||
21 | + HTML_DIR="$with_html_dir" | ||
22 | + AC_SUBST(HTML_DIR) | ||
23 | + | ||
24 | + dnl enable/disable documentation building | ||
25 | + AC_ARG_ENABLE(gtk-doc, | ||
26 | + AC_HELP_STRING([--enable-gtk-doc], | ||
27 | + [use gtk-doc to build documentation [default=no]]),, | ||
28 | + enable_gtk_doc=no) | ||
29 | + | ||
30 | + have_gtk_doc=no | ||
31 | + if test -z "$PKG_CONFIG"; then | ||
32 | + AC_PATH_PROG(PKG_CONFIG, pkg-config, no) | ||
33 | + fi | ||
34 | + if test "$PKG_CONFIG" != "no" && $PKG_CONFIG --exists gtk-doc; then | ||
35 | + have_gtk_doc=yes | ||
36 | + fi | ||
37 | + | ||
38 | + dnl do we want to do a version check? | ||
39 | +ifelse([$1],[],, | ||
40 | + [gtk_doc_min_version=$1 | ||
41 | + if test "$have_gtk_doc" = yes; then | ||
42 | + AC_MSG_CHECKING([gtk-doc version >= $gtk_doc_min_version]) | ||
43 | + if $PKG_CONFIG --atleast-version $gtk_doc_min_version gtk-doc; then | ||
44 | + AC_MSG_RESULT(yes) | ||
45 | + else | ||
46 | + AC_MSG_RESULT(no) | ||
47 | + have_gtk_doc=no | ||
48 | + fi | ||
49 | + fi | ||
50 | +]) | ||
51 | + if test x$enable_gtk_doc = xyes; then | ||
52 | + if test "$have_gtk_doc" != yes; then | ||
53 | + enable_gtk_doc=no | ||
54 | + fi | ||
55 | + fi | ||
56 | + | ||
57 | + AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes) | ||
58 | + AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, test -n "$LIBTOOL") | ||
59 | +]) | ||
diff --git a/meta/packages/pango/files/no-tests.patch b/meta/packages/pango/files/no-tests.patch new file mode 100644 index 0000000000..b382126129 --- /dev/null +++ b/meta/packages/pango/files/no-tests.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher | ||
4 | # | ||
5 | |||
6 | --- pango-1.2.5/Makefile.am~no-tests 2003-01-30 22:43:47.000000000 +0100 | ||
7 | +++ pango-1.2.5/Makefile.am 2004-03-11 11:31:25.000000000 +0100 | ||
8 | @@ -1,6 +1,6 @@ | ||
9 | ## Process this file with automake to create Makefile.in. | ||
10 | |||
11 | -SUBDIRS= pango modules examples docs tools tests | ||
12 | +SUBDIRS= pango modules examples docs tools | ||
13 | |||
14 | EXTRA_DIST = \ | ||
15 | pango.pc.in \ | ||
diff --git a/meta/packages/pango/pango_1.10.0.bb b/meta/packages/pango/pango_1.10.0.bb new file mode 100644 index 0000000000..869b146d56 --- /dev/null +++ b/meta/packages/pango/pango_1.10.0.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | LICENSE = "LGPL" | ||
2 | SECTION = "x11/libs" | ||
3 | # Xt needed to keep autoconf's check for X11 happy | ||
4 | DEPENDS = "glib-2.0 fontconfig freetype zlib libx11 libxft libxt gtk-doc cairo" | ||
5 | DESCRIPTION = "The goal of the Pango project is to provide an \ | ||
6 | Open Source framework for the layout and rendering of \ | ||
7 | internationalized text." | ||
8 | PR = "r0" | ||
9 | |||
10 | # seems to go wrong with default cflags | ||
11 | FULL_OPTIMIZATION_arm = "-O2" | ||
12 | |||
13 | SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.8/pango-${PV}.tar.bz2 \ | ||
14 | file://no-tests.patch;patch=1" | ||
15 | |||
16 | inherit autotools pkgconfig | ||
17 | |||
18 | EXTRA_OECONF = "--disable-glibtest \ | ||
19 | --enable-explicit-deps=no \ | ||
20 | --disable-debug" | ||
21 | |||
22 | FILES_${PN} = "/etc ${bindir} ${libdir}/libpango*.so.*" | ||
23 | |||
24 | LIBV = "1.4.0" | ||
25 | |||
26 | do_stage () { | ||
27 | for lib in pango pangox pangoft2 pangoxft pangocairo; do | ||
28 | oe_libinstall -so -C pango lib$lib-1.0 ${STAGING_LIBDIR}/ | ||
29 | done | ||
30 | install -d ${STAGING_INCDIR}/pango | ||
31 | install -m 0644 ${S}/pango/pango*.h ${STAGING_INCDIR}/pango/ | ||
32 | } | ||
33 | |||
34 | postinst_prologue() { | ||
35 | if [ "x$D" != "x" ]; then | ||
36 | exit 1 | ||
37 | fi | ||
38 | |||
39 | } | ||
40 | |||
41 | PACKAGES_DYNAMIC = "pango-module-*" | ||
42 | |||
43 | python populate_packages_prepend () { | ||
44 | prologue = bb.data.getVar("postinst_prologue", d, 1) | ||
45 | |||
46 | modules_root = bb.data.expand('${libdir}/pango/${LIBV}/modules', d) | ||
47 | |||
48 | do_split_packages(d, modules_root, '^pango-(.*)\.so$', 'pango-module-%s', 'Pango module %s', prologue + 'pango-querymodules > /etc/pango/pango.modules') | ||
49 | } | ||
diff --git a/meta/packages/pango/pango_1.12.0.bb b/meta/packages/pango/pango_1.12.0.bb new file mode 100644 index 0000000000..e06e659b7b --- /dev/null +++ b/meta/packages/pango/pango_1.12.0.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | LICENSE = "LGPL" | ||
2 | SECTION = "x11/libs" | ||
3 | # Xt needed to keep autoconf's check for X11 happy | ||
4 | DEPENDS = "glib-2.0 fontconfig freetype zlib libx11 libxft libxt gtk-doc cairo" | ||
5 | DESCRIPTION = "The goal of the Pango project is to provide an \ | ||
6 | Open Source framework for the layout and rendering of \ | ||
7 | internationalized text." | ||
8 | PR = "r0" | ||
9 | |||
10 | # seems to go wrong with default cflags | ||
11 | FULL_OPTIMIZATION_arm = "-O2" | ||
12 | |||
13 | SRC_URI = "http://download.gnome.org/sources/pango/1.12/pango-${PV}.tar.bz2 \ | ||
14 | file://no-tests.patch;patch=1" | ||
15 | |||
16 | inherit autotools pkgconfig | ||
17 | |||
18 | EXTRA_OECONF = "--disable-glibtest \ | ||
19 | --enable-explicit-deps=no \ | ||
20 | --disable-debug" | ||
21 | |||
22 | FILES_${PN} = "/etc ${bindir} ${libdir}/libpango*.so.*" | ||
23 | |||
24 | LIBV = "1.5.0" | ||
25 | |||
26 | do_stage () { | ||
27 | for lib in pango pangox pangoft2 pangoxft pangocairo; do | ||
28 | oe_libinstall -so -C pango lib$lib-1.0 ${STAGING_LIBDIR}/ | ||
29 | done | ||
30 | install -d ${STAGING_INCDIR}/pango | ||
31 | install -m 0644 ${S}/pango/pango*.h ${STAGING_INCDIR}/pango/ | ||
32 | } | ||
33 | |||
34 | postinst_prologue() { | ||
35 | if [ "x$D" != "x" ]; then | ||
36 | exit 1 | ||
37 | fi | ||
38 | |||
39 | } | ||
40 | |||
41 | PACKAGES_DYNAMIC = "pango-module-*" | ||
42 | |||
43 | python populate_packages_prepend () { | ||
44 | prologue = bb.data.getVar("postinst_prologue", d, 1) | ||
45 | |||
46 | modules_root = bb.data.expand('${libdir}/pango/${LIBV}/modules', d) | ||
47 | |||
48 | do_split_packages(d, modules_root, '^pango-(.*)\.so$', 'pango-module-%s', 'Pango module %s', prologue + 'pango-querymodules > /etc/pango/pango.modules') | ||
49 | } | ||
diff --git a/meta/packages/pango/pango_1.13.3.bb b/meta/packages/pango/pango_1.13.3.bb new file mode 100644 index 0000000000..de6346b1cb --- /dev/null +++ b/meta/packages/pango/pango_1.13.3.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | LICENSE = "LGPL" | ||
2 | SECTION = "x11/libs" | ||
3 | # Xt needed to keep autoconf's check for X11 happy | ||
4 | DEPENDS = "glib-2.0 fontconfig freetype zlib libx11 libxft libxt gtk-doc cairo" | ||
5 | DESCRIPTION = "The goal of the Pango project is to provide an \ | ||
6 | Open Source framework for the layout and rendering of \ | ||
7 | internationalized text." | ||
8 | PR = "r0" | ||
9 | |||
10 | # seems to go wrong with default cflags | ||
11 | FULL_OPTIMIZATION_arm = "-O2" | ||
12 | |||
13 | SRC_URI = "http://download.gnome.org/sources/pango/1.13/pango-${PV}.tar.bz2 \ | ||
14 | file://no-tests.patch;patch=1" | ||
15 | |||
16 | inherit autotools pkgconfig | ||
17 | |||
18 | EXTRA_OECONF = "--disable-glibtest \ | ||
19 | --enable-explicit-deps=no \ | ||
20 | --disable-debug" | ||
21 | |||
22 | FILES_${PN} = "/etc ${bindir} ${libdir}/libpango*.so.*" | ||
23 | |||
24 | LIBV = "1.5.0" | ||
25 | |||
26 | do_stage () { | ||
27 | for lib in pango pangox pangoft2 pangoxft pangocairo; do | ||
28 | oe_libinstall -so -C pango lib$lib-1.0 ${STAGING_LIBDIR}/ | ||
29 | done | ||
30 | install -d ${STAGING_INCDIR}/pango | ||
31 | install -m 0644 ${S}/pango/pango*.h ${STAGING_INCDIR}/pango/ | ||
32 | } | ||
33 | |||
34 | postinst_prologue() { | ||
35 | if [ "x$D" != "x" ]; then | ||
36 | exit 1 | ||
37 | fi | ||
38 | |||
39 | } | ||
40 | |||
41 | PACKAGES_DYNAMIC = "pango-module-*" | ||
42 | |||
43 | python populate_packages_prepend () { | ||
44 | prologue = bb.data.getVar("postinst_prologue", d, 1) | ||
45 | |||
46 | modules_root = bb.data.expand('${libdir}/pango/${LIBV}/modules', d) | ||
47 | |||
48 | do_split_packages(d, modules_root, '^pango-(.*)\.so$', 'pango-module-%s', 'Pango module %s', prologue + 'pango-querymodules > /etc/pango/pango.modules') | ||
49 | } | ||
diff --git a/meta/packages/pango/pango_1.9.1.bb b/meta/packages/pango/pango_1.9.1.bb new file mode 100644 index 0000000000..db01079fe1 --- /dev/null +++ b/meta/packages/pango/pango_1.9.1.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | LICENSE = "LGPL" | ||
2 | SECTION = "x11/libs" | ||
3 | # Xt needed to keep autoconf's check for X11 happy | ||
4 | DEPENDS = "glib-2.0 fontconfig freetype zlib libx11 libxft libxt gtk-doc" | ||
5 | DESCRIPTION = "The goal of the Pango project is to provide an \ | ||
6 | Open Source framework for the layout and rendering of \ | ||
7 | internationalized text." | ||
8 | PR = "r0" | ||
9 | |||
10 | # seems to go wrong with default cflags | ||
11 | FULL_OPTIMIZATION_arm = "-O2" | ||
12 | |||
13 | SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.7/pango-${PV}.tar.bz2 \ | ||
14 | file://no-tests.patch;patch=1" | ||
15 | |||
16 | inherit autotools pkgconfig | ||
17 | |||
18 | EXTRA_OECONF = "--disable-glibtest \ | ||
19 | --enable-explicit-deps=no \ | ||
20 | --disable-debug" | ||
21 | |||
22 | FILES_${PN} = "/etc ${bindir} ${libdir}/libpango*.so.*" | ||
23 | |||
24 | LIBV = "1.4.0" | ||
25 | |||
26 | do_stage () { | ||
27 | for lib in pango pangox pangoft2 pangoxft; do | ||
28 | oe_libinstall -so -C pango lib$lib-1.0 ${STAGING_LIBDIR}/ | ||
29 | done | ||
30 | install -d ${STAGING_INCDIR}/pango | ||
31 | install -m 0644 ${S}/pango/pango*.h ${STAGING_INCDIR}/pango/ | ||
32 | } | ||
33 | |||
34 | postinst_prologue() { | ||
35 | if [ "x$D" != "x" ]; then | ||
36 | exit 1 | ||
37 | fi | ||
38 | |||
39 | } | ||
40 | |||
41 | PACKAGES_DYNAMIC = "pango-module-*" | ||
42 | |||
43 | python populate_packages_prepend () { | ||
44 | prologue = bb.data.getVar("postinst_prologue", d, 1) | ||
45 | |||
46 | modules_root = bb.data.expand('${libdir}/pango/${LIBV}/modules', d) | ||
47 | |||
48 | do_split_packages(d, modules_root, '^pango-(.*)\.so$', 'pango-module-%s', 'Pango module %s', prologue + 'pango-querymodules > /etc/pango/pango.modules') | ||
49 | } | ||