diff options
Diffstat (limited to 'meta/packages/oprofile/oprofile_cvs.bb')
-rw-r--r-- | meta/packages/oprofile/oprofile_cvs.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/packages/oprofile/oprofile_cvs.bb b/meta/packages/oprofile/oprofile_cvs.bb new file mode 100644 index 0000000000..73ded09a16 --- /dev/null +++ b/meta/packages/oprofile/oprofile_cvs.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | PV = "0.9.1+cvs${SRCDATE}" | ||
2 | SECTION = "devel" | ||
3 | DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \ | ||
4 | of profiling all running code at low overhead." | ||
5 | LICENSE = "GPL" | ||
6 | MAINTAINER = "Chris Larson <kergoth@handhelds.org>" | ||
7 | DEPENDS = "popt binutils" | ||
8 | |||
9 | SRC_URI = "cvs://anonymous@oprofile.cvs.sourceforge.net/cvsroot/oprofile;module=oprofile \ | ||
10 | file://no_arm_mapping_syms.patch;patch=1 \ | ||
11 | file://acinclude.m4" | ||
12 | S = "${WORKDIR}/oprofile" | ||
13 | |||
14 | inherit autotools | ||
15 | |||
16 | # NOTE: this disables the build of the kernel modules. | ||
17 | # Should add the oprofile kernel modules, for those with 2.4 | ||
18 | # kernels, as a seperate .oe file. | ||
19 | EXTRA_OECONF = "--with-kernel-support \ | ||
20 | --without-x \ | ||
21 | --disable-werror " | ||
22 | |||
23 | do_configure () { | ||
24 | cp ${WORKDIR}/acinclude.m4 ${S}/ | ||
25 | autotools_do_configure | ||
26 | } | ||
27 | # Available config options | ||
28 | # --enable-abi enable abi portability code (default is disabled) | ||
29 | # --enable-pch enable precompiled header (default is disabled) | ||
30 | # --enable-gcov enable option for gcov coverage testing (default is disabled) | ||
31 | # --disable-werror disable -Werror flag (default is enabled for non-release) | ||
32 | # --disable-optimization disable optimization flags (default is enabled) | ||
33 | # --with-kernel-support Use 2.6 kernel (no kernel source tree required) | ||
34 | # --with-linux=dir Path to Linux source tree | ||
35 | # --with-module-dir=dir Path to module installation directory | ||
36 | # --with-extra-includes=DIR add extra include paths | ||
37 | # --with-extra-libs=DIR add extra library paths | ||
38 | # --with-x use the X Window System | ||
39 | # --with-qt-dir where the root of Qt is installed | ||
40 | # --with-qt-includes where the Qt includes are. | ||
41 | # --with-qt-libraries where the Qt library is installed. | ||