summaryrefslogtreecommitdiffstats
path: root/meta/packages/oprofile/oprofile_0.9.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/oprofile/oprofile_0.9.4.bb')
-rw-r--r--meta/packages/oprofile/oprofile_0.9.4.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/packages/oprofile/oprofile_0.9.4.bb b/meta/packages/oprofile/oprofile_0.9.4.bb
new file mode 100644
index 0000000000..38f27c78d9
--- /dev/null
+++ b/meta/packages/oprofile/oprofile_0.9.4.bb
@@ -0,0 +1,22 @@
1SECTION = "devel"
2DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
3of profiling all running code at low overhead."
4LICENSE = "GPL"
5DEPENDS = "popt binutils"
6RDEPENDS = "binutils-symlinks"
7RRECOMMENDS = "kernel-vmlinux"
8PR = "r0"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
11 file://opstart.patch;patch=1 \
12 file://acinclude.m4"
13S = "${WORKDIR}/oprofile-${PV}"
14
15inherit autotools
16
17EXTRA_OECONF = "--with-kernel-support --without-x"
18
19do_configure () {
20 cp ${WORKDIR}/acinclude.m4 ${S}/
21 autotools_do_configure
22}