summaryrefslogtreecommitdiffstats
path: root/meta/packages/oprofile/oprofile_0.9.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/oprofile/oprofile_0.9.1.bb')
-rw-r--r--meta/packages/oprofile/oprofile_0.9.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/packages/oprofile/oprofile_0.9.1.bb b/meta/packages/oprofile/oprofile_0.9.1.bb
new file mode 100644
index 0000000000..1cbb05d418
--- /dev/null
+++ b/meta/packages/oprofile/oprofile_0.9.1.bb
@@ -0,0 +1,39 @@
1SECTION = "devel"
2DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
3of profiling all running code at low overhead."
4LICENSE = "GPL"
5MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
6DEPENDS = "popt binutils"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
9 file://no_arm_mapping_syms.patch;patch=1 \
10 file://acinclude.m4"
11S = "${WORKDIR}/oprofile-${PV}"
12
13inherit autotools
14
15# NOTE: this disables the build of the kernel modules.
16# Should add the oprofile kernel modules, for those with 2.4
17# kernels, as a seperate .oe file.
18EXTRA_OECONF = "--with-kernel-support \
19 --without-x"
20
21do_configure () {
22 cp ${WORKDIR}/acinclude.m4 ${S}/
23 autotools_do_configure
24}
25# Available config options
26# --enable-abi enable abi portability code (default is disabled)
27# --enable-pch enable precompiled header (default is disabled)
28# --enable-gcov enable option for gcov coverage testing (default is disabled)
29# --disable-werror disable -Werror flag (default is enabled for non-release)
30# --disable-optimization disable optimization flags (default is enabled)
31# --with-kernel-support Use 2.6 kernel (no kernel source tree required)
32# --with-linux=dir Path to Linux source tree
33# --with-module-dir=dir Path to module installation directory
34# --with-extra-includes=DIR add extra include paths
35# --with-extra-libs=DIR add extra library paths
36# --with-x use the X Window System
37# --with-qt-dir where the root of Qt is installed
38# --with-qt-includes where the Qt includes are.
39# --with-qt-libraries where the Qt library is installed.