summaryrefslogtreecommitdiffstats
path: root/meta/packages/oprofile/oprofile_0.9.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/oprofile/oprofile_0.9.1.bb')
-rw-r--r--meta/packages/oprofile/oprofile_0.9.1.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta/packages/oprofile/oprofile_0.9.1.bb b/meta/packages/oprofile/oprofile_0.9.1.bb
deleted file mode 100644
index 991c7bfc99..0000000000
--- a/meta/packages/oprofile/oprofile_0.9.1.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1SECTION = "devel"
2DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
3of profiling all running code at low overhead."
4LICENSE = "GPL"
5DEPENDS = "popt binutils"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
8 file://no_arm_mapping_syms.patch;patch=1 \
9 file://acinclude.m4"
10S = "${WORKDIR}/oprofile-${PV}"
11
12inherit autotools
13
14# NOTE: this disables the build of the kernel modules.
15# Should add the oprofile kernel modules, for those with 2.4
16# kernels, as a seperate .oe file.
17EXTRA_OECONF = "--with-kernel-support \
18 --without-x"
19
20do_configure () {
21 cp ${WORKDIR}/acinclude.m4 ${S}/
22 autotools_do_configure
23}
24# Available config options
25# --enable-abi enable abi portability code (default is disabled)
26# --enable-pch enable precompiled header (default is disabled)
27# --enable-gcov enable option for gcov coverage testing (default is disabled)
28# --disable-werror disable -Werror flag (default is enabled for non-release)
29# --disable-optimization disable optimization flags (default is enabled)
30# --with-kernel-support Use 2.6 kernel (no kernel source tree required)
31# --with-linux=dir Path to Linux source tree
32# --with-module-dir=dir Path to module installation directory
33# --with-extra-includes=DIR add extra include paths
34# --with-extra-libs=DIR add extra library paths
35# --with-x use the X Window System
36# --with-qt-dir where the root of Qt is installed
37# --with-qt-includes where the Qt includes are.
38# --with-qt-libraries where the Qt library is installed.