summaryrefslogtreecommitdiffstats
path: root/meta/packages/openswan/openswan-2.2.0/openswan-2.2.0-gentoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/openswan/openswan-2.2.0/openswan-2.2.0-gentoo.patch')
-rw-r--r--meta/packages/openswan/openswan-2.2.0/openswan-2.2.0-gentoo.patch382
1 files changed, 382 insertions, 0 deletions
diff --git a/meta/packages/openswan/openswan-2.2.0/openswan-2.2.0-gentoo.patch b/meta/packages/openswan/openswan-2.2.0/openswan-2.2.0-gentoo.patch
new file mode 100644
index 0000000000..9ccc80cacf
--- /dev/null
+++ b/meta/packages/openswan/openswan-2.2.0/openswan-2.2.0-gentoo.patch
@@ -0,0 +1,382 @@
1diff -Naupr openswan-2.2.0/Makefile.inc openswan-2.2.0-gentoo/Makefile.inc
2--- openswan-2.2.0/Makefile.inc 2004-07-19 21:06:32.000000000 -0500
3+++ openswan-2.2.0-gentoo/Makefile.inc 2004-09-17 21:31:29.810687485 -0500
4@@ -64,7 +64,7 @@ POLICYLIB=${OPENSWANSRCDIR}/lib/libipsec
5 DESTDIR?=
6
7 # "local" part of tree, used in building other pathnames
8-INC_USRLOCAL=/usr/local
9+INC_USRLOCAL=/usr
10
11 # PUBDIR is where the "ipsec" command goes; beware, many things define PATH
12 # settings which are assumed to include it (or at least, to include *some*
13@@ -98,7 +98,7 @@ MANTREE=$(DESTDIR)$(INC_USRLOCAL)/$(INC_
14 MANPLACES=man3 man5 man8
15
16 # where configuration files go
17-FINALCONFFILE?=/etc/ipsec.conf
18+FINALCONFFILE?=/etc/ipsec/ipsec.conf
19 CONFFILE=$(DESTDIR)$(FINALCONFFILE)
20
21 FINALCONFDIR?=/etc
22@@ -109,10 +109,10 @@ CONFDDIR=$(DESTDIR)$(FINALCONFDDIR)
23
24 # sample configuration files go into
25 INC_DOCDIR?=share/doc
26-FINALEXAMPLECONFDIR=${INC_USRLOCAL}/${INC_DOCDIR}/openswan
27+FINALEXAMPLECONFDIR=${INC_USRLOCAL}/${INC_DOCDIR}/openswan-2.2.0
28 EXAMPLECONFDIR=${DESTDIR}${FINALEXAMPLECONFDIR}
29
30-FINALDOCDIR?=${INC_USRLOCAL}/${INC_DOCDIR}/openswan
31+FINALDOCDIR?=${INC_USRLOCAL}/${INC_DOCDIR}/openswan-2.2.0
32 DOCDIR=${DESTDIR}${FINALDOCDIR}
33
34 # where per-conn pluto logs go
35@@ -243,7 +243,7 @@ RH_KERNELSRC?=/usr/src/linux-2.4
36 # installed one in RH 7.2, won't work - you wind up depending upon
37 # openssl.
38
39-BIND9STATICLIBDIR?=/usr/local/lib
40+BIND9STATICLIBDIR?=/usr/lib
41
42 # if you install elsewere, you may need to point the include files to it.
43 #BIND9STATICLIBDIR?=/sandel/lib
44diff -Naupr openswan-2.2.0/lib/libdes/Makefile openswan-2.2.0-gentoo/lib/libdes/Makefile
45--- openswan-2.2.0/lib/libdes/Makefile 2004-04-03 13:44:41.000000000 -0600
46+++ openswan-2.2.0-gentoo/lib/libdes/Makefile 2004-09-17 21:31:29.810687485 -0500
47@@ -60,7 +60,7 @@ MAKE=make -f Makefile
48 # normally overridden by FreeS/WAN Makefiles anyway
49 CFLAG= -O3 -fomit-frame-pointer -I${KLIPSD}/include -I${SRCDIR}
50
51-CFLAGS=$(OPTS) $(CFLAG)
52+CFLAGS=$(OPTS) $(CFLAG) $(USERCOMPILE)
53 CPP=$(CC) -E
54
55 # Assember version of des_encrypt*().
56diff -Naupr openswan-2.2.0/linux/crypto/ciphers/des/asm/crypt586.pl openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/crypt586.pl
57--- openswan-2.2.0/linux/crypto/ciphers/des/asm/crypt586.pl 2002-04-24 02:36:37.000000000 -0500
58+++ openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/crypt586.pl 2004-09-17 21:31:29.811687312 -0500
59@@ -1,4 +1,4 @@
60-#!/usr/local/bin/perl
61+#!/usr/bin/perl
62 #
63 # The inner loop instruction sequence and the IP/FP modifications are from
64 # Svend Olaf Mikkelsen <svolaf@inet.uni-c.dk>
65diff -Naupr openswan-2.2.0/linux/crypto/ciphers/des/asm/des-586.pl openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/des-586.pl
66--- openswan-2.2.0/linux/crypto/ciphers/des/asm/des-586.pl 2002-04-24 02:36:37.000000000 -0500
67+++ openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/des-586.pl 2004-09-17 21:31:29.811687312 -0500
68@@ -1,4 +1,4 @@
69-#!/usr/local/bin/perl
70+#!/usr/bin/perl
71 #
72 # The inner loop instruction sequence and the IP/FP modifications are from
73 # Svend Olaf Mikkelsen <svolaf@inet.uni-c.dk>
74diff -Naupr openswan-2.2.0/linux/crypto/ciphers/des/asm/des686.pl openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/des686.pl
75--- openswan-2.2.0/linux/crypto/ciphers/des/asm/des686.pl 2002-04-24 02:36:37.000000000 -0500
76+++ openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/des686.pl 2004-09-17 21:31:29.812687139 -0500
77@@ -1,4 +1,4 @@
78-#!/usr/local/bin/perl
79+#!/usr/bin/perl
80
81 $prog="des686.pl";
82
83diff -Naupr openswan-2.2.0/linux/crypto/ciphers/des/asm/desboth.pl openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/desboth.pl
84--- openswan-2.2.0/linux/crypto/ciphers/des/asm/desboth.pl 2002-04-24 02:36:37.000000000 -0500
85+++ openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/desboth.pl 2004-09-17 21:31:29.812687139 -0500
86@@ -1,4 +1,4 @@
87-#!/usr/local/bin/perl
88+#!/usr/bin/perl
89
90 $L="edi";
91 $R="esi";
92diff -Naupr openswan-2.2.0/linux/crypto/ciphers/des/asm/perlasm/cbc.pl openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/perlasm/cbc.pl
93--- openswan-2.2.0/linux/crypto/ciphers/des/asm/perlasm/cbc.pl 2002-04-24 02:36:37.000000000 -0500
94+++ openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/perlasm/cbc.pl 2004-09-17 21:31:29.812687139 -0500
95@@ -1,4 +1,4 @@
96-#!/usr/local/bin/perl
97+#!/usr/bin/perl
98
99 # void des_ncbc_encrypt(input, output, length, schedule, ivec, enc)
100 # des_cblock (*input);
101diff -Naupr openswan-2.2.0/linux/crypto/ciphers/des/asm/perlasm/x86asm.pl openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/perlasm/x86asm.pl
102--- openswan-2.2.0/linux/crypto/ciphers/des/asm/perlasm/x86asm.pl 2002-04-24 02:36:37.000000000 -0500
103+++ openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/perlasm/x86asm.pl 2004-09-17 21:31:29.813686966 -0500
104@@ -1,4 +1,4 @@
105-#!/usr/local/bin/perl
106+#!/usr/bin/perl
107
108 # require 'x86asm.pl';
109 # &asm_init("cpp","des-586.pl");
110diff -Naupr openswan-2.2.0/linux/crypto/ciphers/des/asm/perlasm/x86ms.pl openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/perlasm/x86ms.pl
111--- openswan-2.2.0/linux/crypto/ciphers/des/asm/perlasm/x86ms.pl 2002-04-24 02:36:37.000000000 -0500
112+++ openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/perlasm/x86ms.pl 2004-09-17 21:31:29.813686966 -0500
113@@ -1,4 +1,4 @@
114-#!/usr/local/bin/perl
115+#!/usr/bin/perl
116
117 package x86ms;
118
119diff -Naupr openswan-2.2.0/linux/crypto/ciphers/des/asm/perlasm/x86unix.pl openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/perlasm/x86unix.pl
120--- openswan-2.2.0/linux/crypto/ciphers/des/asm/perlasm/x86unix.pl 2002-04-24 02:36:37.000000000 -0500
121+++ openswan-2.2.0-gentoo/linux/crypto/ciphers/des/asm/perlasm/x86unix.pl 2004-09-17 21:31:29.814686793 -0500
122@@ -1,4 +1,4 @@
123-#!/usr/local/bin/perl
124+#!/usr/bin/perl
125
126 package x86unix;
127
128diff -Naupr openswan-2.2.0/programs/_include/_include.in openswan-2.2.0-gentoo/programs/_include/_include.in
129--- openswan-2.2.0/programs/_include/_include.in 2003-01-06 15:44:04.000000000 -0600
130+++ openswan-2.2.0-gentoo/programs/_include/_include.in 2004-09-17 21:31:29.814686793 -0500
131@@ -47,10 +47,10 @@ for f
132 do
133 if test ! -r "$f"
134 then
135- if test ! "$f" = "/etc/ipsec.conf"
136+ if test ! "$f" = "/etc/ipsec/ipsec.conf"
137 then
138 echo "#:cannot open configuration file \'$f\'"
139- if test "$f" = "/etc/ipsec.secrets"
140+ if test "$f" = "/etc/ipsec/ipsec.secrets"
141 then
142 echo "#:Your secrets file will be created when you start FreeS/WAN for the first time."
143 fi
144diff -Naupr openswan-2.2.0/programs/barf/barf.in openswan-2.2.0-gentoo/programs/barf/barf.in
145--- openswan-2.2.0/programs/barf/barf.in 2004-06-07 20:02:11.000000000 -0500
146+++ openswan-2.2.0-gentoo/programs/barf/barf.in 2004-09-17 21:31:29.815686620 -0500
147@@ -16,7 +16,7 @@
148
149 LOGS=${LOGS-/var/log}
150 CONFS=${IPSEC_CONFS-/etc}
151-CONFDDIR=${IPSEC_CONFDDIR-/etc/ipsec.d}
152+CONFDDIR=${IPSEC_CONFDDIR-/etc/ipsec/ipsec.d}
153 me="ipsec barf"
154
155 # kludge to produce no barf output mentioning policygroups if none are present.
156@@ -229,13 +229,13 @@ then
157 done
158 fi
159 _________________________ ipsec/ls-libdir
160-ls -l ${IPSEC_LIBDIR-/usr/local/lib/ipsec}
161+ls -l ${IPSEC_LIBDIR-/usr/lib/ipsec}
162 _________________________ ipsec/ls-execdir
163-ls -l ${IPSEC_EXECDIR-/usr/local/libexec/ipsec}
164+ls -l ${IPSEC_EXECDIR-/usr/libexec/ipsec}
165 _________________________ ipsec/updowns
166-for f in `ls ${IPSEC_EXECDIR-/usr/local/libexec/ipsec} | egrep updown`
167+for f in `ls ${IPSEC_EXECDIR-/usr/libexec/ipsec} | egrep updown`
168 do
169- cat ${IPSEC_EXECDIR-/usr/local/libexec/ipsec}/$f
170+ cat ${IPSEC_EXECDIR-/usr/libexec/ipsec}/$f
171 done
172 _________________________ proc/net/dev
173 cat /proc/net/dev
174diff -Naupr openswan-2.2.0/programs/eroute/eroute.5 openswan-2.2.0-gentoo/programs/eroute/eroute.5
175--- openswan-2.2.0/programs/eroute/eroute.5 2003-10-30 20:32:27.000000000 -0600
176+++ openswan-2.2.0-gentoo/programs/eroute/eroute.5 2004-09-17 21:31:29.815686620 -0500
177@@ -223,7 +223,7 @@ Parameters Index of
178 in hexadecimal using Authentication Header protocol (51,
179 IPPROTO_AH) with no identies defined for either end.
180 .SH FILES
181-/proc/net/ipsec_eroute, /usr/local/bin/ipsec
182+/proc/net/ipsec_eroute, /usr/bin/ipsec
183 .SH "SEE ALSO"
184 ipsec(8), ipsec_manual(8), ipsec_tncfg(5), ipsec_spi(5),
185 ipsec_spigrp(5), ipsec_klipsdebug(5), ipsec_eroute(8), ipsec_version(5),
186diff -Naupr openswan-2.2.0/programs/eroute/eroute.8 openswan-2.2.0-gentoo/programs/eroute/eroute.8
187--- openswan-2.2.0/programs/eroute/eroute.8 2003-10-30 20:32:27.000000000 -0600
188+++ openswan-2.2.0-gentoo/programs/eroute/eroute.8 2004-09-17 21:31:29.816686447 -0500
189@@ -308,7 +308,7 @@ will be in clear text.
190 .br
191 .LP
192 .SH FILES
193-/proc/net/ipsec_eroute, /usr/local/bin/ipsec
194+/proc/net/ipsec_eroute, /usr/bin/ipsec
195 .SH "SEE ALSO"
196 ipsec(8), ipsec_manual(8), ipsec_tncfg(8), ipsec_spi(8),
197 ipsec_spigrp(8), ipsec_klipsdebug(8), ipsec_eroute(5)
198diff -Naupr openswan-2.2.0/programs/ipsec/ipsec.8 openswan-2.2.0-gentoo/programs/ipsec/ipsec.8
199--- openswan-2.2.0/programs/ipsec/ipsec.8 2003-02-27 10:51:54.000000000 -0600
200+++ openswan-2.2.0-gentoo/programs/ipsec/ipsec.8 2004-09-17 21:31:29.816686447 -0500
201@@ -81,7 +81,7 @@ reports where
202 .I ipsec
203 thinks the IPsec configuration files are stored.
204 .SH FILES
205-/usr/local/lib/ipsec usual utilities directory
206+/usr/lib/ipsec usual utilities directory
207 .SH ENVIRONMENT
208 .PP
209 The following environment variables control where FreeS/WAN finds its
210diff -Naupr openswan-2.2.0/programs/klipsdebug/klipsdebug.5 openswan-2.2.0-gentoo/programs/klipsdebug/klipsdebug.5
211--- openswan-2.2.0/programs/klipsdebug/klipsdebug.5 2002-04-24 02:35:38.000000000 -0500
212+++ openswan-2.2.0-gentoo/programs/klipsdebug/klipsdebug.5 2004-09-17 21:31:29.817686275 -0500
213@@ -103,7 +103,7 @@ full
214 sockets debugging has been set and everything else is not set.
215 .LP
216 .SH FILES
217-/proc/net/ipsec_klipsdebug, /usr/local/bin/ipsec
218+/proc/net/ipsec_klipsdebug, /usr/bin/ipsec
219 .SH "SEE ALSO"
220 ipsec(8), ipsec_manual(8), ipsec_tncfg(8), ipsec_eroute(8),
221 ipsec_spi(8), ipsec_spigrp(8), ipsec_klipsdebug(5), ipsec_version(5),
222diff -Naupr openswan-2.2.0/programs/klipsdebug/klipsdebug.8 openswan-2.2.0-gentoo/programs/klipsdebug/klipsdebug.8
223--- openswan-2.2.0/programs/klipsdebug/klipsdebug.8 2002-04-24 02:35:39.000000000 -0500
224+++ openswan-2.2.0-gentoo/programs/klipsdebug/klipsdebug.8 2004-09-17 21:31:29.817686275 -0500
225@@ -117,7 +117,7 @@ turns off only the
226 debugging messages.
227 .LP
228 .SH FILES
229-/proc/net/ipsec_klipsdebug, /usr/local/bin/ipsec
230+/proc/net/ipsec_klipsdebug, /usr/bin/ipsec
231 .SH "SEE ALSO"
232 ipsec(8), ipsec_manual(8), ipsec_tncfg(8), ipsec_eroute(8),
233 ipsec_spi(8), ipsec_spigrp(8), ipsec_klipsdebug(5)
234diff -Naupr openswan-2.2.0/programs/lwdnsq/lwdnsq.xml.in openswan-2.2.0-gentoo/programs/lwdnsq/lwdnsq.xml.in
235--- openswan-2.2.0/programs/lwdnsq/lwdnsq.xml.in 2004-04-03 19:50:56.000000000 -0600
236+++ openswan-2.2.0-gentoo/programs/lwdnsq/lwdnsq.xml.in 2004-09-17 21:31:29.817686275 -0500
237@@ -430,7 +430,7 @@ information.
238 <refsect1><title>Special IPSECKEY processing</title>
239
240 <programlisting>
241-/etc/ipsec.d/lwdnsq.conf
242+/etc/ipsec/ipsec.d/lwdnsq.conf
243 </programlisting>
244
245 </refsect1>
246diff -Naupr openswan-2.2.0/programs/mailkey/mailkey.in openswan-2.2.0-gentoo/programs/mailkey/mailkey.in
247--- openswan-2.2.0/programs/mailkey/mailkey.in 2003-06-30 00:34:22.000000000 -0500
248+++ openswan-2.2.0-gentoo/programs/mailkey/mailkey.in 2004-09-17 21:31:29.818686102 -0500
249@@ -60,7 +60,7 @@ with the following error:
250
251 "$test1st"
252
253-Common concerns: This account must be able to read /etc/ipsec.secrets.
254+Common concerns: This account must be able to read /etc/ipsec/ipsec.secrets.
255 If you haven't generated your key yet, please run 'ipsec newhostkey'."
256 exit 0
257 }
258diff -Naupr openswan-2.2.0/programs/pluto/Makefile openswan-2.2.0-gentoo/programs/pluto/Makefile
259--- openswan-2.2.0/programs/pluto/Makefile 2004-07-19 21:05:23.000000000 -0500
260+++ openswan-2.2.0-gentoo/programs/pluto/Makefile 2004-09-17 21:31:29.819685929 -0500
261@@ -224,7 +224,7 @@ CPPFLAGS = $(HDRDIRS) $(DEFINES) \
262 -DPOLICYGROUPSDIR=\"${FINALCONFDDIR}/policies\" \
263 -DPERPEERLOGDIR=\"${FINALLOGDIR}/pluto/peer\"
264
265-ALLFLAGS = $(CPPFLAGS) $(CFLAGS)
266+ALLFLAGS = $(CPPFLAGS) $(CFLAGS) $(USERCOMPILE)
267
268 # libefence is a free memory allocation debugger
269 # Solaris 2 needs -lsocket -lnsl
270diff -Naupr openswan-2.2.0/programs/setup/Makefile openswan-2.2.0-gentoo/programs/setup/Makefile
271--- openswan-2.2.0/programs/setup/Makefile 2004-04-03 13:44:48.000000000 -0600
272+++ openswan-2.2.0-gentoo/programs/setup/Makefile 2004-09-17 21:31:29.819685929 -0500
273@@ -33,25 +33,10 @@ install:: setup
274 @rm -f $(BINDIR)/setup
275 @$(INSTALL) $(INSTBINFLAGS) setup $(RCDIR)/ipsec
276 @ln -s $(FINALRCDIR)/ipsec $(BINDIR)/setup
277- -@for i in 0 1 2 3 4 5 6; do mkdir -p $(RCDIR)/../rc$$i.d; done
278- -@cd $(RCDIR)/../rc0.d && ln -f -s ../init.d/ipsec K76ipsec
279- -@cd $(RCDIR)/../rc1.d && ln -f -s ../init.d/ipsec K76ipsec
280- -@cd $(RCDIR)/../rc2.d && ln -f -s ../init.d/ipsec S47ipsec
281- -@cd $(RCDIR)/../rc3.d && ln -f -s ../init.d/ipsec S47ipsec
282- -@cd $(RCDIR)/../rc4.d && ln -f -s ../init.d/ipsec S47ipsec
283- -@cd $(RCDIR)/../rc5.d && ln -f -s ../init.d/ipsec S47ipsec
284- -@cd $(RCDIR)/../rc6.d && ln -f -s ../init.d/ipsec K76ipsec
285
286 install_file_list::
287 @echo $(RCDIR)/ipsec
288 @echo $(BINDIR)/setup
289- @echo $(RCDIR)/../rc0.d/K76ipsec
290- @echo $(RCDIR)/../rc1.d/K76ipsec
291- @echo $(RCDIR)/../rc2.d/S47ipsec
292- @echo $(RCDIR)/../rc3.d/S47ipsec
293- @echo $(RCDIR)/../rc4.d/S47ipsec
294- @echo $(RCDIR)/../rc5.d/S47ipsec
295- @echo $(RCDIR)/../rc6.d/K76ipsec
296
297 clean::
298 @rm -f setup
299diff -Naupr openswan-2.2.0/programs/showhostkey/showhostkey.in openswan-2.2.0-gentoo/programs/showhostkey/showhostkey.in
300--- openswan-2.2.0/programs/showhostkey/showhostkey.in 2004-03-24 15:08:22.000000000 -0600
301+++ openswan-2.2.0-gentoo/programs/showhostkey/showhostkey.in 2004-09-17 21:31:29.820685756 -0500
302@@ -18,7 +18,7 @@ me="ipsec showhostkey"
303 usage="Usage: $me [--file secrets] [--left] [--right] [--txt gateway] [--id id]
304 [--dhclient]"
305
306-file=/etc/ipsec.secrets
307+file=/etc/ipsec/ipsec.secrets
308 fmt=""
309 gw=
310 id=
311diff -Naupr openswan-2.2.0/programs/spi/spi.5 openswan-2.2.0-gentoo/programs/spi/spi.5
312--- openswan-2.2.0/programs/spi/spi.5 2002-04-24 02:35:39.000000000 -0500
313+++ openswan-2.2.0-gentoo/programs/spi/spi.5 2004-09-17 21:31:29.820685756 -0500
314@@ -162,7 +162,7 @@ since 1 of 8 bits is a parity bit), has
315 3858 seconds ago and has been idle for 23 seconds.
316 .LP
317 .SH FILES
318-/proc/net/ipsec_spi, /usr/local/bin/ipsec
319+/proc/net/ipsec_spi, /usr/bin/ipsec
320 .SH "SEE ALSO"
321 ipsec(8), ipsec_manual(8), ipsec_tncfg(5), ipsec_eroute(5),
322 ipsec_spigrp(5), ipsec_klipsdebug(5), ipsec_spi(8), ipsec_version(5),
323diff -Naupr openswan-2.2.0/programs/spi/spi.8 openswan-2.2.0-gentoo/programs/spi/spi.8
324--- openswan-2.2.0/programs/spi/spi.8 2002-04-24 02:35:40.000000000 -0500
325+++ openswan-2.2.0-gentoo/programs/spi/spi.8 2004-09-17 21:31:29.820685756 -0500
326@@ -461,7 +461,7 @@ and protocol
327 (4).
328 .LP
329 .SH FILES
330-/proc/net/ipsec_spi, /usr/local/bin/ipsec
331+/proc/net/ipsec_spi, /usr/bin/ipsec
332 .SH "SEE ALSO"
333 ipsec(8), ipsec_manual(8), ipsec_tncfg(8), ipsec_eroute(8),
334 ipsec_spigrp(8), ipsec_klipsdebug(8), ipsec_spi(5)
335diff -Naupr openswan-2.2.0/programs/spigrp/spigrp.5 openswan-2.2.0-gentoo/programs/spigrp/spigrp.5
336--- openswan-2.2.0/programs/spigrp/spigrp.5 2002-04-24 02:35:40.000000000 -0500
337+++ openswan-2.2.0-gentoo/programs/spigrp/spigrp.5 2004-09-17 21:31:29.821685583 -0500
338@@ -77,7 +77,7 @@ be an incoming or outgoing group, depend
339 machine.
340 .LP
341 .SH FILES
342-/proc/net/ipsec_spigrp, /usr/local/bin/ipsec
343+/proc/net/ipsec_spigrp, /usr/bin/ipsec
344 .SH "SEE ALSO"
345 ipsec(8), ipsec_manual(8), ipsec_tncfg(5), ipsec_eroute(5),
346 ipsec_spi(5), ipsec_klipsdebug(5), ipsec_spigrp(8), ipsec_version(5),
347diff -Naupr openswan-2.2.0/programs/spigrp/spigrp.8 openswan-2.2.0-gentoo/programs/spigrp/spigrp.8
348--- openswan-2.2.0/programs/spigrp/spigrp.8 2002-04-24 02:35:41.000000000 -0500
349+++ openswan-2.2.0-gentoo/programs/spigrp/spigrp.8 2004-09-17 21:31:29.821685583 -0500
350@@ -128,7 +128,7 @@ and finally an AH header to authenticate
351 .BR 0x236 .
352 .LP
353 .SH FILES
354-/proc/net/ipsec_spigrp, /usr/local/bin/ipsec
355+/proc/net/ipsec_spigrp, /usr/bin/ipsec
356 .SH "SEE ALSO"
357 ipsec(8), ipsec_manual(8), ipsec_tncfg(8), ipsec_eroute(8),
358 ipsec_spi(8), ipsec_klipsdebug(8), ipsec_spigrp(5)
359diff -Naupr openswan-2.2.0/programs/tncfg/tncfg.5 openswan-2.2.0-gentoo/programs/tncfg/tncfg.5
360--- openswan-2.2.0/programs/tncfg/tncfg.5 2002-04-24 02:35:41.000000000 -0500
361+++ openswan-2.2.0-gentoo/programs/tncfg/tncfg.5 2004-09-17 21:31:29.821685583 -0500
362@@ -75,7 +75,7 @@ shows that virtual device
363 is not connected to any physical device.
364 .LP
365 .SH "FILES"
366-/proc/net/ipsec_tncfg, /usr/local/bin/ipsec
367+/proc/net/ipsec_tncfg, /usr/bin/ipsec
368 .SH "SEE ALSO"
369 ipsec(8), ipsec_manual(8), ipsec_eroute(5), ipsec_spi(5),
370 ipsec_spigrp(5), ipsec_klipsdebug(5), ipsec_tncfg(8), ipsec_version(5),
371diff -Naupr openswan-2.2.0/programs/tncfg/tncfg.8 openswan-2.2.0-gentoo/programs/tncfg/tncfg.8
372--- openswan-2.2.0/programs/tncfg/tncfg.8 2002-04-24 02:35:41.000000000 -0500
373+++ openswan-2.2.0-gentoo/programs/tncfg/tncfg.8 2004-09-17 21:31:29.822685410 -0500
374@@ -76,7 +76,7 @@ virtual device to the
375 physical device.
376 .LP
377 .SH "FILES"
378-/proc/net/ipsec_tncfg, /usr/local/bin/ipsec
379+/proc/net/ipsec_tncfg, /usr/bin/ipsec
380 .SH "SEE ALSO"
381 ipsec(8), ipsec_manual(8), ipsec_eroute(8), ipsec_spi(8),
382 ipsec_spigrp(8), ipsec_klipsdebug(8), ipsec_tncfg(5)