diff options
Diffstat (limited to 'meta/packages/openssl/openssl-0.9.8o/shared-libs.patch')
-rw-r--r-- | meta/packages/openssl/openssl-0.9.8o/shared-libs.patch | 48 |
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/packages/openssl/openssl-0.9.8o/shared-libs.patch b/meta/packages/openssl/openssl-0.9.8o/shared-libs.patch new file mode 100644 index 0000000000..10d9146dc9 --- /dev/null +++ b/meta/packages/openssl/openssl-0.9.8o/shared-libs.patch | |||
@@ -0,0 +1,48 @@ | |||
1 | diff --git a/Makefile.org b/Makefile.org | ||
2 | index e87d623..25ff367 100644 | ||
3 | --- a/Makefile.org | ||
4 | +++ b/Makefile.org | ||
5 | @@ -355,7 +355,7 @@ libcrypto$(SHLIB_EXT): libcrypto.a $(SHARED_FIPS) | ||
6 | @if [ "$(SHLIB_TARGET)" != "" ]; then \ | ||
7 | if [ "$(FIPSCANLIB)" = "libfips" ]; then \ | ||
8 | $(ARD) libcrypto.a fipscanister.o ; \ | ||
9 | - $(MAKE) SHLIBDIRS='crypto' SHLIBDEPS='-lfips' build-shared; \ | ||
10 | + $(MAKE) -e SHLIBDIRS='crypto' SHLIBDEPS='-lfips' build-shared; \ | ||
11 | $(AR) libcrypto.a fips/fipscanister.o ; \ | ||
12 | else \ | ||
13 | if [ "$(FIPSCANLIB)" = "libcrypto" ]; then \ | ||
14 | @@ -373,7 +373,7 @@ libssl$(SHLIB_EXT): libcrypto$(SHLIB_EXT) libssl.a | ||
15 | @if [ "$(SHLIB_TARGET)" != "" ]; then \ | ||
16 | shlibdeps=-lcrypto; \ | ||
17 | [ "$(FIPSCANLIB)" = "libfips" ] && shlibdeps="$$shlibdeps -lfips"; \ | ||
18 | - $(MAKE) SHLIBDIRS=ssl SHLIBDEPS="$$shlibdeps" build-shared; \ | ||
19 | + $(MAKE) -e SHLIBDIRS=ssl SHLIBDEPS="$$shlibdeps" build-shared; \ | ||
20 | else \ | ||
21 | echo "There's no support for shared libraries on this platform" >&2 ; \ | ||
22 | exit 1; \ | ||
23 | diff --git a/crypto/Makefile b/crypto/Makefile | ||
24 | index 6557f2b..a69bf7c 100644 | ||
25 | --- a/crypto/Makefile | ||
26 | +++ b/crypto/Makefile | ||
27 | @@ -103,7 +103,7 @@ $(LIB): $(LIBOBJ) | ||
28 | |||
29 | shared: buildinf.h lib subdirs | ||
30 | if [ -n "$(SHARED_LIBS)" ]; then \ | ||
31 | - (cd ..; $(MAKE) $(SHARED_LIB)); \ | ||
32 | + (cd ..; $(MAKE) -e $(SHARED_LIB)); \ | ||
33 | fi | ||
34 | |||
35 | libs: | ||
36 | diff --git a/ssl/Makefile b/ssl/Makefile | ||
37 | index 5ac3507..77ea2bd 100644 | ||
38 | --- a/ssl/Makefile | ||
39 | +++ b/ssl/Makefile | ||
40 | @@ -62,7 +62,7 @@ lib: $(LIBOBJ) | ||
41 | |||
42 | shared: lib | ||
43 | if [ -n "$(SHARED_LIBS)" ]; then \ | ||
44 | - (cd ..; $(MAKE) $(SHARED_LIB)); \ | ||
45 | + (cd ..; $(MAKE) -e $(SHARED_LIB)); \ | ||
46 | fi | ||
47 | |||
48 | files: | ||