summaryrefslogtreecommitdiffstats
path: root/meta/packages/openobex
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/openobex')
-rw-r--r--meta/packages/openobex/files/disable-cable-test.patch16
-rw-r--r--meta/packages/openobex/files/libusb_crosscompile_check.patch12
-rw-r--r--meta/packages/openobex/openobex_1.2.bb32
3 files changed, 60 insertions, 0 deletions
diff --git a/meta/packages/openobex/files/disable-cable-test.patch b/meta/packages/openobex/files/disable-cable-test.patch
new file mode 100644
index 0000000000..95b636dd8f
--- /dev/null
+++ b/meta/packages/openobex/files/disable-cable-test.patch
@@ -0,0 +1,16 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- openobex-1.2/apps/Makefile.am~disable-cable-test
7+++ openobex-1.2/apps/Makefile.am
8@@ -6,7 +6,7 @@
9 obex_io.c obex_io.h \
10 obex_put_common.c obex_put_common.h
11
12-bin_PROGRAMS = irxfer obex_tcp irobex_palm3 obex_test
13+bin_PROGRAMS = irxfer obex_tcp irobex_palm3
14
15 obex_test_SOURCES = \
16 obex_test.c obex_test.h \
diff --git a/meta/packages/openobex/files/libusb_crosscompile_check.patch b/meta/packages/openobex/files/libusb_crosscompile_check.patch
new file mode 100644
index 0000000000..c28921b8ca
--- /dev/null
+++ b/meta/packages/openobex/files/libusb_crosscompile_check.patch
@@ -0,0 +1,12 @@
1diff -Naur openobex-1.2_old/acinclude.m4 openobex-1.2/acinclude.m4
2--- openobex-1.2_old/acinclude.m4 2006-03-07 19:57:49.000000000 +0200
3+++ openobex-1.2/acinclude.m4 2006-04-18 23:07:25.000000000 +0300
4@@ -195,7 +195,7 @@
5
6 if (test "${usb_enable}" = "yes" && test "${usb_found}" = "yes"); then
7 AC_DEFINE(HAVE_USB, 1, [Define if system supports USB and it's enabled])
8- AC_CHECK_FILE(${usb_prefix}/lib/pkgconfig/libusb.pc, REQUIRES="$REQUIRES libusb")
9+ REQUIRES="libusb"
10 fi
11
12 AM_CONDITIONAL(APPS, test "${apps_enable}" = "yes")
diff --git a/meta/packages/openobex/openobex_1.2.bb b/meta/packages/openobex/openobex_1.2.bb
new file mode 100644
index 0000000000..0c8d118cff
--- /dev/null
+++ b/meta/packages/openobex/openobex_1.2.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "The Openobex project is an open source implementation of the \
2Object Exchange (OBEX) protocol."
3HOMEPAGE = "http://openobex.triq.net"
4SECTION = "libs"
5PROVIDES = "openobex-apps"
6DEPENDS = "libusb bluez-libs"
7LICENSE = "GPL"
8PR = "r3"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/openobex-${PV}.tar.gz \
11 file://disable-cable-test.patch;patch=1" \
12 file://libusb_crosscompile_check.patch;patch=1"
13
14inherit autotools binconfig pkgconfig
15
16EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
17 --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
18
19do_stage() {
20 oe_libinstall -so -C lib libopenobex ${STAGING_LIBDIR}
21 ln -sf libopenobex.so ${STAGING_LIBDIR}/libopenobex-1.2.so
22 install -d ${STAGING_INCDIR}/openobex
23 install -m 0644 include/*.h ${STAGING_INCDIR}/openobex/
24 install -d ${STAGING_DIR}/aclocal
25 install -m 0644 openobex.m4 ${STAGING_DATADIR}/aclocal/
26}
27
28# how to stop shlibrename from renaming -apps?
29PACKAGES += "openobex-apps"
30FILES_${PN} = "${libdir}/lib*.so.*"
31FILES_${PN}-dev += "${bindir}/openobex-config"
32FILES_${PN}-apps = "${bindir}/*"