diff options
Diffstat (limited to 'meta/packages/oh')
-rw-r--r-- | meta/packages/oh/usbinit.bb | 5 | ||||
-rwxr-xr-x | meta/packages/oh/usbinit/usb-gether | 32 |
2 files changed, 20 insertions, 17 deletions
diff --git a/meta/packages/oh/usbinit.bb b/meta/packages/oh/usbinit.bb index 0adcae1b9c..1d4575bddb 100644 --- a/meta/packages/oh/usbinit.bb +++ b/meta/packages/oh/usbinit.bb | |||
@@ -1,8 +1,7 @@ | |||
1 | DESCRIPTION = "Quick hack to start gadget Ethernet on the 770" | 1 | DESCRIPTION = "Initscript to manage gadget Ethernet" |
2 | LICENSE = "GPL" | 2 | LICENSE = "GPL" |
3 | SECTION = "x11" | ||
4 | PRIORITY = "optional" | 3 | PRIORITY = "optional" |
5 | PR = "r0" | 4 | PR = "r1" |
6 | 5 | ||
7 | SRC_URI = "file://usb-gether" | 6 | SRC_URI = "file://usb-gether" |
8 | S = "${WORKDIR}" | 7 | S = "${WORKDIR}" |
diff --git a/meta/packages/oh/usbinit/usb-gether b/meta/packages/oh/usbinit/usb-gether index 590e77b22a..e80a0bb30e 100755 --- a/meta/packages/oh/usbinit/usb-gether +++ b/meta/packages/oh/usbinit/usb-gether | |||
@@ -1,19 +1,23 @@ | |||
1 | #!/bin/sh | 1 | #! /bin/sh |
2 | # | ||
3 | # usb-ether Start up the gadget usb ethernet interface. | ||
4 | # | ||
2 | 5 | ||
3 | case "$1" in | 6 | case "$1" in |
4 | start) | 7 | start|"") |
5 | /sbin/depmod -a | 8 | test "$VERBOSE" != no && echo "Initializing g_ether gadget..." |
6 | /sbin/modprobe g_ether | 9 | modprobe g_ether |
7 | ifconfig usb0 192.168.1.120 | 10 | ifup usb0 |
8 | ;; | 11 | ;; |
9 | 12 | stop) | |
10 | stop) | 13 | test "$VERBOSE" != no && echo "Disabling g_ether..." |
11 | 14 | ifdown usb0 | |
12 | ;; | 15 | rmmod g_ether |
13 | 16 | ;; | |
14 | *) | 17 | *) |
15 | echo "usage: $0 { start | stop }" | 18 | echo "Usage: usb-ether {start|stop}" >&2 |
16 | ;; | 19 | exit 1 |
20 | ;; | ||
17 | esac | 21 | esac |
18 | 22 | ||
19 | exit 0 | 23 | exit 0 |