summaryrefslogtreecommitdiffstats
path: root/meta/packages/ncurses/ncurses/configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/ncurses/ncurses/configure.patch')
-rw-r--r--meta/packages/ncurses/ncurses/configure.patch193
1 files changed, 193 insertions, 0 deletions
diff --git a/meta/packages/ncurses/ncurses/configure.patch b/meta/packages/ncurses/ncurses/configure.patch
new file mode 100644
index 0000000000..992e81008f
--- /dev/null
+++ b/meta/packages/ncurses/ncurses/configure.patch
@@ -0,0 +1,193 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6--- ncurses-5.3/./configure.in~configure
7+++ ncurses-5.3/./configure.in
8@@ -34,9 +34,10 @@
9 dnl See http://invisible-island.net/autoconf/ for additional information.
10 dnl
11 dnl ---------------------------------------------------------------------------
12-AC_PREREQ(2.13.20020210)
13+AC_PREREQ(2.57)
14 AC_REVISION($Revision: 1.297 $)
15-AC_INIT(ncurses/base/lib_initscr.c)
16+AC_INIT
17+AC_CONFIG_SRCDIR([ncurses/base/lib_initscr.c])
18 AC_CONFIG_HEADER(include/ncurses_cfg.h:include/ncurses_cfg.hin)
19
20 CF_SUBST_NCURSES_VERSION
21@@ -45,7 +46,7 @@
22 [AC_MSG_WARN(overriding ABI version to $withval)
23 cf_cv_abi_version=$withval])
24
25-CF_CHECK_CACHE([AC_CANONICAL_SYSTEM])
26+CF_CHECK_CACHE([AC_CANONICAL_TARGET([])])
27 AC_ARG_WITH(system-type,
28 [ --with-system-type=XXX test: override derived host system-type],
29 [AC_MSG_WARN(overriding system type to $withval)
30@@ -110,7 +111,7 @@
31 CF_GXX_VERSION
32 case $GXX_VERSION in
33 1*|2.[[0-6]]*)
34- GXX=""; CXX=""; ac_cv_prog_gxx=no
35+ GXX=""; CXX=""; ac_cv_cxx_compiler_gnu=no
36 cf_cxx_library=no
37 AC_MSG_WARN(templates do not work)
38 ;;
39@@ -370,7 +371,7 @@
40 if test "$CC_SHARED_OPTS" = "unknown"; then
41 for model in $cf_list_models; do
42 if test "$model" = "shared"; then
43- AC_ERROR(Shared libraries are not supported in this version)
44+ AC_MSG_ERROR([Shared libraries are not supported in this version])
45 fi
46 done
47 fi
48@@ -457,7 +458,7 @@
49 AC_ARG_ENABLE(big-core,
50 [ --disable-big-core assume machine has little memory],
51 [with_big_core=$enableval],
52- [AC_TRY_RUN([
53+ [AC_RUN_IFELSE([AC_LANG_SOURCE([[
54 #include <stdlib.h>
55 #include <string.h>
56 int main() {
57@@ -466,10 +467,7 @@
58 if (s != 0)
59 s[0] = s[n-1] = 0;
60 exit(s == 0);
61-}],
62- [with_big_core=yes],
63- [with_big_core=no],
64- [with_big_core=no])])
65+}]])],[with_big_core=yes],[with_big_core=no],[with_big_core=no])])
66 AC_MSG_RESULT($with_big_core)
67 test "$with_big_core" = "yes" && AC_DEFINE(HAVE_BIG_CORE)
68
69@@ -484,7 +482,7 @@
70 if test "$with_termcap" != "yes" ; then
71 if test "$use_database" = no ; then
72 if test -z "$with_fallback" ; then
73- AC_ERROR(You have disabled the database w/o specifying fallbacks)
74+ AC_MSG_ERROR([You have disabled the database w/o specifying fallbacks])
75 fi
76 fi
77 AC_DEFINE(PURE_TERMINFO)
78@@ -903,7 +901,7 @@
79 AC_SUBST(MATH_LIB)
80
81 ### Checks for header files.
82-AC_STDC_HEADERS
83+AC_HEADER_STDC([])
84 AC_HEADER_DIRENT
85 AC_HEADER_TIME
86 CF_REGEX
87@@ -937,7 +935,7 @@
88 CF_SYS_TIME_SELECT
89
90 ### checks for compiler characteristics
91-AC_LANG_C
92+AC_LANG([C])
93 AC_C_CONST
94 AC_C_INLINE
95 test "$ac_cv_c_inline" != no && AC_DEFINE(CC_HAS_INLINE_FUNCS)
96@@ -1012,7 +1010,7 @@
97
98 # Check for C++ compiler characteristics (and ensure that it's there!)
99 if test -n "$CXX" ; then
100- AC_LANG_CPLUSPLUS
101+ AC_LANG([C++])
102 CF_STDCPP_LIBRARY
103
104 case $GXX_VERSION in
105@@ -1286,15 +1284,16 @@
106
107 ################################################################################
108 test "$use_database" = yes && SUB_MAKEFILES="$SUB_MAKEFILES misc/run_tic.sh:misc/run_tic.in"
109-AC_OUTPUT( \
110+AC_CONFIG_FILES([\
111 include/MKterm.h.awk \
112 include/curses.head:include/curses.h.in \
113 include/termcap.h \
114 include/unctrl.h \
115 $SUB_MAKEFILES \
116- Makefile,[
117+ Makefile])
118+AC_CONFIG_COMMANDS([default],[[
119 CF_LIB_RULES
120-],[
121+]],[[
122 ### Special initialization commands, used to pass information from the
123 ### configuration-run into config.status
124
125@@ -1324,5 +1323,6 @@
126 cf_with_cxx_binding="$cf_with_cxx_binding"
127 host="$host"
128
129-],cat)dnl
130+]])
131+AC_OUTPUTdnl
132 ${MAKE-make} preinstall
133--- ncurses-5.3/./test/configure.in~configure
134+++ ncurses-5.3/./test/configure.in
135@@ -38,8 +38,9 @@
136 dnl
137 dnl See http://invisible-island.net/autoconf/ for additional information.
138 dnl ---------------------------------------------------------------------------
139-AC_PREREQ(2.13.20020210)
140-AC_INIT(ncurses.c)
141+AC_PREREQ(2.57)
142+AC_INIT
143+AC_CONFIG_SRCDIR([ncurses.c])
144 AC_CONFIG_HEADER(ncurses_cfg.h:ncurses_tst.hin)
145
146 CF_INHERIT_SCRIPT(config.guess)
147@@ -129,7 +130,7 @@
148
149 AC_TYPE_SIGNAL
150
151-AC_STDC_HEADERS
152+AC_HEADER_STDC([])
153 AC_HEADER_TIME
154 AC_CHECK_HEADERS( \
155 form.h \
156@@ -160,9 +161,8 @@
157 wresize \
158 )
159
160-AC_TRY_LINK([
161-#include <${cf_cv_ncurses_header-curses.h}>],
162-[
163+AC_LINK_IFELSE([AC_LANG_PROGRAM([[
164+#include <${cf_cv_ncurses_header-curses.h}>]], [[
165 (void) assume_default_colors (0, 0);
166 (void) curses_version ();
167 (void) define_key (0, 0);
168@@ -175,7 +175,7 @@
169 (void) use_default_colors ();
170 (void) use_extended_names (0);
171 (void) wresize (0, 0, 0);
172- ],[AC_DEFINE(NCURSES_EXT_FUNCS)])
173+ ]])],[AC_DEFINE(NCURSES_EXT_FUNCS)],[])
174
175 CF_SYS_TIME_SELECT
176 CF_FUNC_CURSES_VERSION
177@@ -186,7 +186,8 @@
178
179 dnl ---------------------------------------------------------------------------
180
181-AC_OUTPUT(Makefile,[
182+AC_CONFIG_FILES([Makefile])
183+AC_CONFIG_COMMANDS([default],[[
184 cat >>Makefile <<TEST_EOF
185
186 # These rules are generated so we do not rely on suffix rules, which do not
187@@ -204,4 +205,5 @@
188 @echo compiling $N; \$(CC) -c \$(CFLAGS_DEFAULT) $N.c
189 TEST_EOF
190 done
191-],[],sort)
192+]],[[]])
193+AC_OUTPUT