summaryrefslogtreecommitdiffstats
path: root/meta/packages/mozilla/minimo
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/mozilla/minimo')
-rw-r--r--meta/packages/mozilla/minimo/host_ldflags_fix.patch62
-rw-r--r--meta/packages/mozilla/minimo/mozconfig76
2 files changed, 138 insertions, 0 deletions
diff --git a/meta/packages/mozilla/minimo/host_ldflags_fix.patch b/meta/packages/mozilla/minimo/host_ldflags_fix.patch
new file mode 100644
index 0000000000..888f545e9d
--- /dev/null
+++ b/meta/packages/mozilla/minimo/host_ldflags_fix.patch
@@ -0,0 +1,62 @@
1Index: mozilla/nsprpub/config/rules.mk
2===================================================================
3--- mozilla.orig/nsprpub/config/rules.mk 2005-01-04 21:27:36.000000000 +0000
4+++ mozilla/nsprpub/config/rules.mk 2005-09-30 11:27:33.000000000 +0000
5@@ -87,6 +87,9 @@
6 CCC=$(HOST_CXX)
7 CFLAGS=$(HOST_CFLAGS)
8 CXXFLAGS=$(HOST_CXXFLAGS)
9+LDFLAGS=$(HOST_LDFLAGS)
10+RANLIB=$(HOST_RANLIB)
11+AR=$(HOST_AR)
12 endif
13 endif
14 endif
15Index: mozilla/configure.in
16===================================================================
17--- mozilla.orig/configure.in 2005-03-30 17:57:38.000000000 +0000
18+++ mozilla/configure.in 2005-09-30 11:36:44.000000000 +0000
19@@ -5612,13 +5612,18 @@
20 fi
21
22 if test -n "$CROSS_COMPILE"; then
23- if test -z "$HOST_LIBIDL_CONFIG"; then
24+ if test -z "$HOST_LIBIDL_CONFIG"; then
25+ AC_MSG_WARN([HOST_LIBIDL_CONFIG not defined])
26 HOST_LIBIDL_CONFIG="$LIBIDL_CONFIG"
27 fi
28 if test -n "$HOST_LIBIDL_CONFIG"; then
29+ AC_MSG_WARN([using $HOST_LIBIDL_CONFIG as config for libIDL on host])
30 HOST_LIBIDL_CFLAGS=`${HOST_LIBIDL_CONFIG} --cflags`
31+ AC_MSG_WARN([HOST_LIBIDL_CFLAGS=$HOST_LIBIDL_CFLAGS])
32 HOST_LIBIDL_LIBS=`${HOST_LIBIDL_CONFIG} --libs`
33+ AC_MSG_WARN([HOST_LIBIDL_LIBS=$HOST_LIBIDL_LIBS])
34 else
35+ AC_MSG_WARN([no config for libIDL found, using LIBIDL_CFLAGS and LIBIDL_LIBS])
36 HOST_LIBIDL_CFLAGS="$LIBIDL_CFLAGS"
37 HOST_LIBIDL_LIBS="$LIBIDL_LIBS"
38 fi
39Index: mozilla/configure
40===================================================================
41--- mozilla.orig/configure 2005-03-30 17:58:47.000000000 +0000
42+++ mozilla/configure 2005-09-30 11:38:36.000000000 +0000
43@@ -16572,11 +16572,18 @@
44
45 if test -n "$CROSS_COMPILE"; then
46 if test -z "$HOST_LIBIDL_CONFIG"; then
47+ echo "HOST_LIBIDL_CONFIG nto defined"
48 HOST_LIBIDL_CONFIG="$LIBIDL_CONFIG"
49 fi
50- if test -n "$HOST_LIBIDL_CONFIG"; then
51+ if test -n "$HOST_LIBIDL_CONFIG" && test -n "$HOST_PKG_CONFIG_PATH"; then
52+ echo "using $HOST_LIBIDL_CONFIG as HOST_LIBIDL_CONFIG with HOST_PKG_CONFIG_PATH=$HOST_PKG_CONFIG_PATH"
53+ _SAVE_PKG_CONFIG_PATH=$PKG_CONFIG_PATH
54+ PKG_CONFIG_PATH=$HOST_PKG_CONFIG_PATH
55 HOST_LIBIDL_CFLAGS=`${HOST_LIBIDL_CONFIG} --cflags`
56+ echo "HOST_LIBIDL_CFLAGS = $HOST_LIBIDL_CFLAGS"
57 HOST_LIBIDL_LIBS=`${HOST_LIBIDL_CONFIG} --libs`
58+ echo "HOST_LIBIDL_LIBS = $HOST_LIBIDL_LIBS"
59+ PKG_CONFIG_PATH=$_SAVE_PKG_CONFIG_PATH
60 else
61 HOST_LIBIDL_CFLAGS="$LIBIDL_CFLAGS"
62 HOST_LIBIDL_LIBS="$LIBIDL_LIBS"
diff --git a/meta/packages/mozilla/minimo/mozconfig b/meta/packages/mozilla/minimo/mozconfig
new file mode 100644
index 0000000000..5a84bcf87e
--- /dev/null
+++ b/meta/packages/mozilla/minimo/mozconfig
@@ -0,0 +1,76 @@
1# build minimo
2MINIMO=1
3mk_add_options MINIMO=1
4
5# enable building the browser
6ac_add_options --enable-application=browser
7
8# use GTK+-2 widget set with XFT font rendering
9
10MOZ_ENABLE_COREXFONTS=0
11mk_add_options MOZ_ENABLE_COREXFONTS=0
12ac_add_options --enable-default-toolkit=gtk2
13ac_add_options --enable-xft
14ac_add_options --disable-freetype2
15
16# disable XUL support to reduce codesize
17ac_add_options --disable-xul
18
19# enable minimal profile support
20ac_add_options --disable-profilesharing
21ac_add_options --disable-profilelocking
22ac_add_options --enable-single-profile
23
24# disable features and skip various build steps
25ac_add_options --disable-extensions
26ac_add_options --disable-accessibility
27ac_add_options --disable-composer
28ac_add_options --disable-extensions
29ac_add_options --disable-installer
30ac_add_options --disable-jsd
31ac_add_options --disable-jsloader
32ac_add_options --disable-ldap
33ac_add_options --disable-mailnews
34ac_add_options --disable-mathml
35ac_add_options --disable-necko-disk-cache
36ac_add_options --disable-postscript
37ac_add_options --disable-view-source
38ac_add_options --disable-xpfe-components
39ac_add_options --disable-xpinstall
40ac_add_options --disable-xprint
41ac_add_options --enable-native-uconv
42ac_add_options --enable-plaintext-editor-only
43ac_add_options --disable-v1-string-abi
44ac_add_options --disable-plugins
45
46# configure necko to allocate smaller network buffers
47ac_add_options --enable-necko-small-buffers
48
49# disable debug logging and tests
50ac_add_options --disable-dtd-debug
51ac_add_options --disable-logging
52ac_add_options --disable-tests
53
54# build crypto module (PSM + NSS)
55ac_add_options --enable-crypto
56
57# build minimal set of protocol handlers
58ac_add_options --enable-necko-protocols=http,file,res,jar
59
60# build minimal set of image decoders
61ac_add_options --enable-image-decoders=png,gif,jpeg
62
63# code generation options (optimize for size)
64ac_add_options --enable-optimize=-Os
65ac_add_options --enable-strip
66ac_add_options --disable-debug
67ac_add_options --enable-reorder
68ac_add_options --enable-elf-dynstr-gc
69
70# enable static build
71ac_add_options --disable-shared
72ac_add_options --enable-static
73
74# remove link dependency on libstdc++.so
75LIBS=-lsupc++
76