summaryrefslogtreecommitdiffstats
path: root/meta/packages/mozilla-headless/mozilla-headless_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/mozilla-headless/mozilla-headless_git.bb')
-rw-r--r--meta/packages/mozilla-headless/mozilla-headless_git.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/packages/mozilla-headless/mozilla-headless_git.bb b/meta/packages/mozilla-headless/mozilla-headless_git.bb
new file mode 100644
index 0000000000..9a016ad69b
--- /dev/null
+++ b/meta/packages/mozilla-headless/mozilla-headless_git.bb
@@ -0,0 +1,49 @@
1
2SRC_URI = "git://git.o-hand.com/${PN}.git;protocol=git \
3 file://configurefix.patch;patch=1 \
4 file://jsautocfg.h \
5 file://mozconfig"
6PV = "0.0+git${SRCREV}"
7PR = "r8"
8
9S = "${WORKDIR}/git"
10
11DEPENDS = "gconf gnome-vfs pango dbus-glib alsa-lib libidl-native sqlite3"
12
13FILES_${PN} += "${libdir}/xulrunner-1.9.2a1pre"
14FILES_${PN}-dev += "${libdir}/xulrunner-devel-1.9.2a1pre"
15FILES_${PN}-dbg += "${libdir}/xulrunner-devel-1.9.2a1pre/sdk/lib/.debug"
16
17inherit autotools_stage mozilla
18
19acpaths = "-I ${S}/build/autoconf "
20
21export topsrcdir = "${S}"
22
23do_configure () {
24 cp ${S}/build/autoconf/install-sh ${S}
25 autotools_do_configure
26 # Yes, we run this twice. The first pass sets up npsrpub-config which then
27 # sets the values correctly on the second try. Ick.
28 autotools_do_configure
29}
30
31do_compile () {
32 cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
33 #oe_runmake -f client.mk build_all
34 base_do_compile
35}
36
37EXTRA_OECONF =+ "--enable-application=xulrunner --disable-javaxpcom --enable-system-sqlite --enable-default-toolkit=cairo-headless --disable-printing --disable-crashreporter --disable-plugins --disable-accessibility --enable-pango --disable-tests"
38
39export LIBXUL_DIST="${S}/dist"
40
41do_stage_append () {
42 autotools_stage_dir ${STAGE_TEMP}/${libdir}/xulrunner-1.9.2a1pre ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-1.9.2a1pre/
43 autotools_stage_dir ${STAGE_TEMP}/${libdir}/xulrunner-devel-1.9.2a1pre ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/
44 ln -fs ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-1.9.2a1pre/ /media/build2/builds/poky/build1/moblin/staging/i586-poky-linux/usr/lib/xulrunner-devel-1.9.2a1pre/bin
45 ln -fs ${STAGING_DIR_HOST}${layout_datadir}/xulrunner-1.9.2a1pre/unstable/ /media/build2/builds/poky/build1/moblin/staging/i586-poky-linux/usr/lib/xulrunner-devel-1.9.2a1pre/idl
46 ln -fs ${STAGING_DIR_HOST}${layout_includedir}/xulrunner-1.9.2a1pre/unstable/ /media/build2/builds/poky/build1/moblin/staging/i586-poky-linux/usr/lib/xulrunner-devel-1.9.2a1pre/include
47 ln -fs ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/sdk/lib/ /media/build2/builds/poky/build1/moblin/staging/i586-poky-linux/usr/lib/xulrunner-devel-1.9.2a1pre/lib
48}
49