summaryrefslogtreecommitdiffstats
path: root/meta/packages/mozilla-headless/mozilla-headless/configurefix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/mozilla-headless/mozilla-headless/configurefix.patch')
-rw-r--r--meta/packages/mozilla-headless/mozilla-headless/configurefix.patch774
1 files changed, 0 insertions, 774 deletions
diff --git a/meta/packages/mozilla-headless/mozilla-headless/configurefix.patch b/meta/packages/mozilla-headless/mozilla-headless/configurefix.patch
deleted file mode 100644
index 7ee1211f1a..0000000000
--- a/meta/packages/mozilla-headless/mozilla-headless/configurefix.patch
+++ /dev/null
@@ -1,774 +0,0 @@
1Index: offscreen/configure.in
2===================================================================
3--- offscreen.orig/configure.in 2009-12-09 13:10:12.000000000 +0000
4+++ offscreen/configure.in 2009-12-09 13:38:51.000000000 +0000
5@@ -64,7 +64,6 @@
6
7 AC_PREREQ(2.13)
8 AC_INIT(config/config.mk)
9-AC_CONFIG_AUX_DIR(${srcdir}/build/autoconf)
10 AC_CANONICAL_SYSTEM
11 TARGET_CPU="${target_cpu}"
12 TARGET_VENDOR="${target_vendor}"
13@@ -106,7 +105,6 @@
14 _SUBDIR_HOST_CFLAGS="$HOST_CFLAGS"
15 _SUBDIR_HOST_CXXFLAGS="$HOST_CXXFLAGS"
16 _SUBDIR_HOST_LDFLAGS="$HOST_LDFLAGS"
17-_SUBDIR_CONFIG_ARGS="$ac_configure_args"
18
19 dnl Set the version number of the libs included with mozilla
20 dnl ========================================================
21@@ -139,6 +137,9 @@
22
23 MSMANIFEST_TOOL=
24
25+ac_cv_have_usable_wchar_v2=no
26+ac_cv_have_usable_wchar_option_v2=no
27+
28 dnl Set various checks
29 dnl ========================================================
30 MISSING_X=
31@@ -308,7 +309,7 @@
32 ;;
33 esac
34
35-if test -n "$CROSS_COMPILE" && test "$target" != "$host"; then
36+
37 echo "cross compiling from $host to $target"
38 cross_compiling=yes
39
40@@ -346,7 +347,7 @@
41
42 AC_MSG_CHECKING([whether the host c compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works])
43 AC_TRY_COMPILE([], [return(0);],
44- [ac_cv_prog_hostcc_works=1 AC_MSG_RESULT([yes])],
45+ [ac_cv_prog_hostcc_works=1; AC_MSG_RESULT([yes])],
46 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CC cannot create executables.]) )
47
48 CC="$HOST_CXX"
49@@ -354,7 +355,7 @@
50
51 AC_MSG_CHECKING([whether the host c++ compiler ($HOST_CXX $HOST_CXXFLAGS $HOST_LDFLAGS) works])
52 AC_TRY_COMPILE([], [return(0);],
53- [ac_cv_prog_hostcxx_works=1 AC_MSG_RESULT([yes])],
54+ [ac_cv_prog_hostcxx_works=1; AC_MSG_RESULT([yes])],
55 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CXX cannot create executables.]) )
56
57 CC=$_SAVE_CC
58@@ -375,7 +376,7 @@
59 ;;
60 esac
61
62- AC_CHECK_PROGS(CC, $CC "${target_alias}-gcc" "${target}-gcc", :)
63+ CC="${target_alias}-gcc"
64 unset ac_cv_prog_CC
65 AC_PROG_CC
66 AC_CHECK_PROGS(CXX, $CXX "${target_alias}-g++" "${target}-g++", :)
67@@ -399,37 +400,6 @@
68 AC_CHECK_PROGS(STRIP, $STRIP "${target_alias}-strip" "${target}-strip", :)
69 AC_CHECK_PROGS(WINDRES, $WINDRES "${target_alias}-windres" "${target}-windres", :)
70 AC_DEFINE(CROSS_COMPILE)
71-else
72- AC_PROG_CC
73- AC_PROG_CXX
74- AC_PROG_RANLIB
75- MOZ_PATH_PROGS(AS, $AS as, $CC)
76- AC_CHECK_PROGS(AR, ar, :)
77- AC_CHECK_PROGS(LD, ld, :)
78- AC_CHECK_PROGS(STRIP, strip, :)
79- AC_CHECK_PROGS(WINDRES, windres, :)
80- if test -z "$HOST_CC"; then
81- HOST_CC="$CC"
82- fi
83- if test -z "$HOST_CFLAGS"; then
84- HOST_CFLAGS="$CFLAGS"
85- fi
86- if test -z "$HOST_CXX"; then
87- HOST_CXX="$CXX"
88- fi
89- if test -z "$HOST_CXXFLAGS"; then
90- HOST_CXXFLAGS="$CXXFLAGS"
91- fi
92- if test -z "$HOST_LDFLAGS"; then
93- HOST_LDFLAGS="$LDFLAGS"
94- fi
95- if test -z "$HOST_RANLIB"; then
96- HOST_RANLIB="$RANLIB"
97- fi
98- if test -z "$HOST_AR"; then
99- HOST_AR="$AR"
100- fi
101-fi
102
103 GNU_AS=
104 GNU_LD=
105@@ -1586,6 +1556,7 @@
106 '
107
108 dnl test that the macros actually work:
109+ac_cv_static_assertion_macros_work="yes"
110 AC_MSG_CHECKING(that static assertion macros used in autoconf tests work)
111 AC_CACHE_VAL(ac_cv_static_assertion_macros_work,
112 [AC_LANG_SAVE
113@@ -2770,9 +2741,13 @@
114 AC_LANG_C
115 AC_HEADER_STDC
116 AC_C_CONST
117+ac_cv_type_mode_t=yes
118 AC_TYPE_MODE_T
119+ac_cv_type_off_t=yes
120 AC_TYPE_OFF_T
121+ac_cv_type_pid_t=yes
122 AC_TYPE_PID_T
123+ac_cv_type_size_t=yes
124 AC_TYPE_SIZE_T
125 AC_STRUCT_ST_BLKSIZE
126 AC_MSG_CHECKING(for siginfo_t)
127@@ -3174,21 +3149,9 @@
128 dnl We don't want to link against libm or libpthread on Darwin since
129 dnl they both are just symlinks to libSystem and explicitly linking
130 dnl against libSystem causes issues when debugging (see bug 299601).
131-case $target in
132-*-darwin*)
133- ;;
134-*-beos*)
135- ;;
136-*-os2*)
137- ;;
138-*)
139 AC_CHECK_LIB(m, atan)
140 AC_CHECK_LIB(dl, dlopen,
141- AC_CHECK_HEADER(dlfcn.h,
142- LIBS="-ldl $LIBS"
143- AC_DEFINE(HAVE_LIBDL)))
144- ;;
145-esac
146+ AC_DEFINE(HAVE_LIBDL))
147
148 _SAVE_CFLAGS="$CFLAGS"
149 CFLAGS="$CFLAGS -D_GNU_SOURCE"
150@@ -6889,18 +6852,13 @@
151
152 # Demangle only for debug or trace-malloc builds
153 MOZ_DEMANGLE_SYMBOLS=
154-if test "$HAVE_DEMANGLE" -a "$HAVE_GCC3_ABI" && test "$MOZ_DEBUG" -o "$NS_TRACE_MALLOC"; then
155- MOZ_DEMANGLE_SYMBOLS=1
156- AC_DEFINE(MOZ_DEMANGLE_SYMBOLS)
157-fi
158+
159 AC_SUBST(MOZ_DEMANGLE_SYMBOLS)
160
161 dnl ========================================================
162 dnl = Support for gcc stack unwinding (from gcc 3.3)
163 dnl ========================================================
164-if test "$HAVE_GCC3_ABI" && test -z "$SKIP_LIBRARY_CHECKS"; then
165- AC_CHECK_HEADER(unwind.h, AC_CHECK_FUNCS(_Unwind_Backtrace))
166-fi
167+
168
169 dnl ========================================================
170 dnl =
171@@ -7420,10 +7378,7 @@
172 dnl if no gtk/libIDL1 or gtk2/libIDL2 combination was found, fall back
173 dnl to either libIDL1 or libIDL2.
174 if test -z "$_LIBIDL_FOUND"; then
175- AM_PATH_LIBIDL($LIBIDL_VERSION,_LIBIDL_FOUND=1)
176- if test -z "$_LIBIDL_FOUND"; then
177 PKG_CHECK_MODULES(LIBIDL, libIDL-2.0 >= 0.8.0,_LIBIDL_FOUND=1)
178- fi
179 fi
180 dnl
181 dnl If we don't have a libIDL config program & not cross-compiling,
182@@ -7495,13 +7450,7 @@
183 fi
184
185 if test -z "$SKIP_PATH_CHECKS"; then
186-if test -z "${GLIB_CFLAGS}" || test -z "${GLIB_LIBS}" ; then
187- if test "$MOZ_ENABLE_GTK2" || test "$USE_ELF_DYNSTR_GC" || test "$MOZ_ENABLE_HEADLESS"; then
188 PKG_CHECK_MODULES(GLIB, glib-2.0 >= 1.3.7 gobject-2.0)
189- else
190- AM_PATH_GLIB(${GLIB_VERSION})
191- fi
192-fi
193 fi
194
195 if test -z "${GLIB_GMODULE_LIBS}" -a -n "${GLIB_CONFIG}"; then
196@@ -8278,10 +8227,7 @@
197 HAVE_WCRTOMB
198 "
199
200-AC_CONFIG_HEADER(
201-netwerk/necko-config.h
202-xpcom/xpcom-config.h
203-xpcom/xpcom-private.h
204+AC_CONFIG_HEADER(netwerk/necko-config.h xpcom/xpcom-config.h xpcom/xpcom-private.h
205 )
206
207 # Save the defines header file before autoconf removes it.
208@@ -8340,31 +8286,11 @@
209 dnl To add new Makefiles, edit allmakefiles.sh.
210 dnl allmakefiles.sh sets the variable, MAKEFILES.
211 . ${srcdir}/allmakefiles.sh
212-dnl
213-dnl Run a perl script to quickly create the makefiles.
214-dnl If it succeeds, it outputs a shell command to set CONFIG_FILES
215-dnl for the files it cannot handle correctly. This way, config.status
216-dnl will handle these files.
217-dnl If it fails, nothing is set and config.status will run as usual.
218-dnl
219-dnl This does not change the $MAKEFILES variable.
220-dnl
221-dnl OpenVMS gets a line overflow on the long eval command, so use a temp file.
222-dnl
223-if test -z "${AS_PERL}"; then
224-echo $MAKEFILES | ${PERL} $srcdir/build/autoconf/acoutput-fast.pl > conftest.sh
225-else
226-echo $MAKEFILES | ${PERL} $srcdir/build/autoconf/acoutput-fast.pl -nowrap --cygwin-srcdir=$srcdir > conftest.sh
227-fi
228-. ./conftest.sh
229-rm conftest.sh
230
231 echo $MAKEFILES > unallmakefiles
232
233 mv -f config/autoconf.mk config/autoconf.mk.orig 2> /dev/null
234
235-AC_OUTPUT($MAKEFILES)
236-
237 dnl Prevent the regeneration of cairo-features.h forcing rebuilds of gfx stuff
238 if test "$CAIRO_FEATURES_H"; then
239 if cmp -s $CAIRO_FEATURES_H "$CAIRO_FEATURES_H".orig; then
240@@ -8390,14 +8316,14 @@
241 HOST_LDFLAGS="$_SUBDIR_HOST_LDFLAGS"
242 RC=
243
244-unset MAKEFILES
245-unset CONFIG_FILES
246+#unset MAKEFILES
247+#unset CONFIG_FILES
248
249 # No need to run subconfigures when building with LIBXUL_SDK_DIR
250 if test "$COMPILE_ENVIRONMENT" -a -z "$LIBXUL_SDK_DIR"; then
251
252 if test -z "$MOZ_NATIVE_NSPR"; then
253- ac_configure_args="$_SUBDIR_CONFIG_ARGS --with-dist-prefix=$MOZ_BUILD_ROOT/dist --with-mozilla"
254+ ac_configure_args="$ac_configure_args --with-dist-prefix=$MOZ_BUILD_ROOT/dist --with-mozilla"
255 if test -z "$MOZ_DEBUG"; then
256 ac_configure_args="$ac_configure_args --disable-debug"
257 fi
258@@ -8413,8 +8339,7 @@
259 if test -n "$USE_ARM_KUSER"; then
260 ac_configure_args="$ac_configure_args --with-arm-kuser"
261 fi
262- AC_OUTPUT_SUBDIRS(nsprpub)
263- ac_configure_args="$_SUBDIR_CONFIG_ARGS"
264+ AC_CONFIG_SUBDIRS(nsprpub)
265 fi
266
267 if test -z "$MOZ_NATIVE_NSPR"; then
268@@ -8431,7 +8356,6 @@
269
270 # Run the SpiderMonkey 'configure' script.
271 dist=$MOZ_BUILD_ROOT/dist
272-ac_configure_args="$_SUBDIR_CONFIG_ARGS"
273 ac_configure_args="$ac_configure_args --enable-threadsafe"
274 if test -z "$MOZ_NATIVE_NSPR"; then
275 ac_configure_args="$ac_configure_args --with-nspr-cflags='$NSPR_CFLAGS'"
276@@ -8448,8 +8372,7 @@
277 export MOZ_MEMORY_LDFLAGS
278 fi
279 fi
280-AC_OUTPUT_SUBDIRS(js/src)
281-ac_configure_args="$_SUBDIR_CONFIG_ARGS"
282+AC_CONFIG_SUBDIRS(js/src)
283
284 # Build jsctypes on the platforms we can.
285 if test "$BUILD_CTYPES"; then
286@@ -8465,20 +8388,14 @@
287 if test -n "$CROSS_COMPILE"; then
288 ac_configure_args="$ac_configure_args --build=$build --host=$target"
289 fi
290- if test "$SOLARIS_SUNPRO_CC"; then
291- # Always use gcc for libffi on Solaris
292- old_cache_file=$cache_file
293- cache_file=js/ctypes/libffi/config.cache
294- ac_configure_args="$ac_configure_args CC=gcc"
295- AC_OUTPUT_SUBDIRS(js/ctypes/libffi)
296- cache_file=$old_cache_file
297- else
298- AC_OUTPUT_SUBDIRS(js/ctypes/libffi)
299- fi
300- ac_configure_args="$_SUBDIR_CONFIG_ARGS"
301+ AC_CONFIG_SUBDIRS(js/ctypes/libffi)
302 fi
303 fi
304
305+m4_pattern_allow(AS_BIN)
306+
307+AC_OUTPUT($MAKEFILES)
308+
309 fi # COMPILE_ENVIRONMENT && !LIBXUL_SDK_DIR
310
311 dnl Prevent the regeneration of autoconf.mk forcing rebuilds of the world
312Index: offscreen/js/src/configure.in
313===================================================================
314--- offscreen.orig/js/src/configure.in 2009-12-09 13:10:12.000000000 +0000
315+++ offscreen/js/src/configure.in 2009-12-09 13:38:51.000000000 +0000
316@@ -62,7 +62,6 @@
317
318 AC_PREREQ(2.13)
319 AC_INIT(jsapi.h)
320-AC_CONFIG_AUX_DIR(${srcdir}/build/autoconf)
321 AC_CONFIG_HEADER(js-config.h)
322 AC_CANONICAL_SYSTEM
323 TARGET_CPU="${target_cpu}"
324@@ -101,6 +100,9 @@
325 _SUBDIR_HOST_LDFLAGS="$HOST_LDFLAGS"
326 _SUBDIR_CONFIG_ARGS="$ac_configure_args"
327
328+ac_cv_have_usable_wchar_v2=no
329+ac_cv_have_usable_wchar_option_v2=no
330+
331 dnl Set the version number of the libs included with mozilla
332 dnl ========================================================
333 NSPR_VERSION=4
334@@ -113,6 +115,8 @@
335
336 MSMANIFEST_TOOL=
337
338+m4_pattern_allow(AS_BIN)
339+
340 dnl Set various checks
341 dnl ========================================================
342 MISSING_X=
343@@ -212,7 +216,7 @@
344
345 if test "$COMPILE_ENVIRONMENT"; then
346
347-if test "$target" != "$host"; then
348+
349 echo "cross compiling from $host to $target"
350
351 _SAVE_CC="$CC"
352@@ -249,7 +253,7 @@
353
354 AC_MSG_CHECKING([whether the host c compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works])
355 AC_TRY_COMPILE([], [return(0);],
356- [ac_cv_prog_hostcc_works=1 AC_MSG_RESULT([yes])],
357+ [ac_cv_prog_hostcc_works=1; AC_MSG_RESULT([yes])],
358 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CC cannot create executables.]) )
359
360 CC="$HOST_CXX"
361@@ -257,7 +261,7 @@
362
363 AC_MSG_CHECKING([whether the host c++ compiler ($HOST_CXX $HOST_CXXFLAGS $HOST_LDFLAGS) works])
364 AC_TRY_COMPILE([], [return(0);],
365- [ac_cv_prog_hostcxx_works=1 AC_MSG_RESULT([yes])],
366+ [ac_cv_prog_hostcxx_works=1; AC_MSG_RESULT([yes])],
367 AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CXX cannot create executables.]) )
368
369 CC=$_SAVE_CC
370@@ -312,7 +316,7 @@
371 ;;
372 esac
373
374- AC_CHECK_PROGS(CC, $CC "${target_alias}-gcc" "${target}-gcc", :)
375+ CC="${target_alias}-gcc"
376 unset ac_cv_prog_CC
377 AC_PROG_CC
378 AC_CHECK_PROGS(CXX, $CXX "${target_alias}-g++" "${target}-g++", :)
379@@ -342,37 +346,6 @@
380 dnl able to run ppc code in a translated environment, making a cross
381 dnl compiler appear native. So we override that here.
382 cross_compiling=yes
383-else
384- AC_PROG_CC
385- AC_PROG_CXX
386- AC_PROG_RANLIB
387- MOZ_PATH_PROGS(AS, $AS as, $CC)
388- AC_CHECK_PROGS(AR, ar, :)
389- AC_CHECK_PROGS(LD, ld, :)
390- AC_CHECK_PROGS(STRIP, strip, :)
391- AC_CHECK_PROGS(WINDRES, windres, :)
392- if test -z "$HOST_CC"; then
393- HOST_CC="$CC"
394- fi
395- if test -z "$HOST_CFLAGS"; then
396- HOST_CFLAGS="$CFLAGS"
397- fi
398- if test -z "$HOST_CXX"; then
399- HOST_CXX="$CXX"
400- fi
401- if test -z "$HOST_CXXFLAGS"; then
402- HOST_CXXFLAGS="$CXXFLAGS"
403- fi
404- if test -z "$HOST_LDFLAGS"; then
405- HOST_LDFLAGS="$LDFLAGS"
406- fi
407- if test -z "$HOST_RANLIB"; then
408- HOST_RANLIB="$RANLIB"
409- fi
410- if test -z "$HOST_AR"; then
411- HOST_AR="$AR"
412- fi
413-fi
414
415 GNU_AS=
416 GNU_LD=
417@@ -1370,6 +1343,8 @@
418 fi # GNU_CC
419 fi # COMPILE_ENVIRONMENT
420
421+ac_cv_static_assertion_macros_work=yes
422+
423 dnl =================================================================
424 dnl Set up and test static assertion macros used to avoid AC_TRY_RUN,
425 dnl which is bad when cross compiling.
426@@ -2557,9 +2532,13 @@
427 AC_LANG_C
428 AC_HEADER_STDC
429 AC_C_CONST
430+ac_cv_type_mode_t=yes
431 AC_TYPE_MODE_T
432+ac_cv_type_off_t=yes
433 AC_TYPE_OFF_T
434+ac_cv_type_pid_t=yes
435 AC_TYPE_PID_T
436+ac_cv_type_size_t=yes
437 AC_TYPE_SIZE_T
438 AC_STRUCT_ST_BLKSIZE
439 AC_MSG_CHECKING(for siginfo_t)
440@@ -2584,7 +2563,8 @@
441
442 AC_CHECK_HEADER(stdint.h)
443 if test "$ac_cv_header_stdint_h" = yes; then
444- AC_DEFINE(JS_HAVE_STDINT_H)
445+ AC_DEFINE(JS_HAVE_STDINT_H, 1, [have stdint.h])
446+ AC_DEFINE(HAVE_STDINT_H)
447 else
448 dnl We'll figure them out for ourselves. List more likely types
449 dnl earlier. If we ever really encounter a size for which none of
450@@ -2938,10 +2918,7 @@
451 ;;
452 *)
453 AC_CHECK_LIB(m, atan)
454- AC_CHECK_LIB(dl, dlopen,
455- AC_CHECK_HEADER(dlfcn.h,
456- LIBS="-ldl $LIBS"
457- AC_DEFINE(HAVE_LIBDL)))
458+ AC_CHECK_LIB(dl, dlopen, AC_DEFINE(HAVE_LIBDL))
459 ;;
460 esac
461
462@@ -3847,6 +3824,7 @@
463 [ --with-nspr-libs=LIBS Pass LIBS to LD when linking code that uses NSPR.
464 See --with-nspr-cflags for more details.],
465 NSPR_LIBS=$withval)
466+$NSPR_LIBS="$NSPR_LIBS -L$(LIBXUL_DIST)/sdk/lib"
467 AC_SUBST(NSPR_CFLAGS)
468 AC_SUBST(NSPR_LIBS)
469
470@@ -4386,18 +4364,11 @@
471
472 # Demangle only for debug or trace-malloc builds
473 MOZ_DEMANGLE_SYMBOLS=
474-if test "$HAVE_DEMANGLE" -a "$HAVE_GCC3_ABI" && test "$MOZ_DEBUG" -o "$NS_TRACE_MALLOC"; then
475- MOZ_DEMANGLE_SYMBOLS=1
476- AC_DEFINE(MOZ_DEMANGLE_SYMBOLS)
477-fi
478 AC_SUBST(MOZ_DEMANGLE_SYMBOLS)
479
480 dnl ========================================================
481 dnl = Support for gcc stack unwinding (from gcc 3.3)
482 dnl ========================================================
483-if test "$HAVE_GCC3_ABI" && test -z "$SKIP_LIBRARY_CHECKS"; then
484- AC_CHECK_HEADER(unwind.h, AC_CHECK_FUNCS(_Unwind_Backtrace))
485-fi
486
487 dnl ========================================================
488 dnl =
489@@ -5097,6 +5068,8 @@
490
491 AC_HAVE_FUNCS(setlocale)
492
493+
494+
495 dnl ========================================================
496 dnl Use cygwin wrapper for win32 builds, except MSYS/MinGW
497 dnl ========================================================
498@@ -5234,3 +5207,4 @@
499 # 'js-config' in Makefile.in.
500 AC_MSG_RESULT(invoking make to create js-config script)
501 $MAKE js-config
502+
503Index: offscreen/nsprpub/configure.in
504===================================================================
505--- offscreen.orig/nsprpub/configure.in 2009-12-09 13:10:12.000000000 +0000
506+++ offscreen/nsprpub/configure.in 2009-12-09 13:10:12.000000000 +0000
507@@ -42,7 +42,6 @@
508 AC_PREREQ(2.12)
509 AC_INIT(config/libc_r.h)
510
511-AC_CONFIG_AUX_DIR(${srcdir}/build/autoconf)
512 AC_CANONICAL_SYSTEM
513
514 dnl ========================================================
515@@ -396,7 +395,7 @@
516 dnl ========================================================
517 dnl Checks for compilers.
518 dnl ========================================================
519-if test "$target" != "$host"; then
520+
521 echo "cross compiling from $host to $target"
522 cross_compiling=yes
523
524@@ -423,7 +422,7 @@
525
526 AC_MSG_CHECKING([whether the $host compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works])
527 AC_TRY_COMPILE([], [return(0);],
528- [ac_cv_prog_host_cc_works=1 AC_MSG_RESULT([yes])],
529+ [ac_cv_prog_host_cc_works=1; AC_MSG_RESULT([yes])],
530 AC_MSG_ERROR([installation or configuration problem: $host compiler $HOST_CC cannot create executables.]) )
531
532 CC=$_SAVE_CC
533@@ -444,7 +443,7 @@
534 ;;
535 esac
536
537- AC_CHECK_PROGS(CC, $CC "${target_alias}-gcc" "${target}-gcc", echo)
538+ CC="${target_alias}-gcc"
539 unset ac_cv_prog_CC
540 AC_PROG_CC
541 if test -n "$USE_CPLUS"; then
542@@ -470,30 +469,6 @@
543 AC_CHECK_PROGS(STRIP, $STRIP "${target_alias}-strip" "${target}-strip", echo)
544 AC_CHECK_PROGS(WINDRES, $WINDRES "${target_alias}-windres" "${target}-windres", echo)
545
546-else
547- AC_PROG_CC
548- if test -n "$USE_CPLUS"; then
549- if test "$CC" = "cl" -a -z "$CXX"; then
550- CXX=$CC
551- else
552- AC_PROG_CXX
553- fi
554- fi
555- AC_PROG_CPP
556- AC_PROG_RANLIB
557- AC_PATH_PROGS(AS, as, $CC)
558- AC_PATH_PROGS(AR, ar, echo not_ar)
559- AC_PATH_PROGS(LD, ld link, echo not_ld)
560- AC_PATH_PROGS(STRIP, strip, echo not_strip)
561- AC_PATH_PROGS(WINDRES, windres, echo not_windres)
562- if test -z "$HOST_CC"; then
563- HOST_CC="$CC"
564- fi
565- if test -z "$HOST_CFLAGS"; then
566- HOST_CFLAGS="$CFLAGS"
567- fi
568-fi
569-
570 if test "$GCC" = "yes"; then
571 GNU_CC=1
572 fi
573@@ -514,11 +489,8 @@
574 ;;
575 esac
576
577-if test "$cross_compiling" = "yes"; then
578+
579 CROSS_COMPILE=1
580-else
581- CROSS_COMPILE=
582-fi
583
584 dnl ========================================================
585 dnl Check for gcc -pipe support
586@@ -2286,10 +2258,7 @@
587 *-darwin*|*-beos*|*-os2*)
588 ;;
589 *)
590- AC_CHECK_LIB(dl, dlopen,
591- AC_CHECK_HEADER(dlfcn.h,
592- OS_LIBS="-ldl $OS_LIBS"))
593- ;;
594+ AC_CHECK_LIB(dl, dlopen)
595 esac
596
597
598@@ -2907,6 +2876,8 @@
599 dnl pr/tests/w16gui/Makefile
600 dnl tools/Makefile
601
602+m4_pattern_allow(AS_BIN)
603+
604 if test -z "$USE_PTHREADS" && test -z "$USE_BTHREADS"; then
605 MAKEFILES="$MAKEFILES pr/src/threads/combined/Makefile"
606 elif test -n "$USE_PTHREADS"; then
607@@ -2922,3 +2893,5 @@
608 echo $MAKEFILES > unallmakefiles
609
610 AC_OUTPUT([$MAKEFILES], [chmod +x config/nspr-config])
611+
612+
613Index: offscreen/js/src/Makefile.in
614===================================================================
615--- offscreen.orig/js/src/Makefile.in 2009-12-09 13:10:12.000000000 +0000
616+++ offscreen/js/src/Makefile.in 2009-12-09 13:10:12.000000000 +0000
617@@ -513,20 +513,8 @@
618
619 export:: jsautocfg.h
620
621-ifeq (,$(CROSS_COMPILE)$(GNU_CC)$(filter-out WINNT,$(OS_ARCH)))
622 jsautocfg.h:
623 touch $@
624-else
625-ifeq ($(OS_ARCH),WINCE)
626-jsautocfg.h:
627- touch $@
628-else
629-jsautocfg.h: jscpucfg$(HOST_BIN_SUFFIX)
630- @rm -f $@ jsautocfg.tmp
631- ./jscpucfg > jsautocfg.tmp
632- mv jsautocfg.tmp $@
633-endif
634-endif
635
636 # jscpucfg is a strange target
637 # Needs to be built with the host compiler but needs to include
638@@ -556,7 +544,7 @@
639 echo no need to build jscpucfg $<
640 else
641 jscpucfg$(HOST_BIN_SUFFIX): jscpucfg.cpp Makefile.in
642- $(HOST_CXX) $(HOST_CXXFLAGS) $(JSCPUCFG_DEFINES) $(DEFINES) $(NSPR_CFLAGS) $(HOST_OUTOPTION)$@ $<
643+ $(HOST_CXX) $(HOST_CXXFLAGS) $(JSCPUCFG_DEFINES) $(DEFINES) -I$(DIST)/sdk/include $(NSPR_CFLAGS) $(HOST_OUTOPTION)$@ $<
644 endif
645 endif
646
647Index: offscreen/js/src/xpconnect/loader/mozJSComponentLoader.cpp
648===================================================================
649--- offscreen.orig/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-12-09 13:10:12.000000000 +0000
650+++ offscreen/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-12-09 13:10:12.000000000 +0000
651@@ -47,6 +47,8 @@
652
653 #include <stdarg.h>
654
655+#include "mozilla-config.h"
656+
657 #include "prlog.h"
658
659 #include "nsCOMPtr.h"
660Index: offscreen/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp
661===================================================================
662--- offscreen.orig/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 2009-12-09 13:10:12.000000000 +0000
663+++ offscreen/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 2009-12-09 13:10:12.000000000 +0000
664@@ -39,6 +39,8 @@
665 *
666 * ***** END LICENSE BLOCK ***** */
667
668+#include "mozilla-config.h"
669+
670 #if !defined(XPCONNECT_STANDALONE) && !defined(NO_SUBSCRIPT_LOADER)
671
672 #include "mozJSSubScriptLoader.h"
673Index: offscreen/toolkit/mozapps/update/src/updater/Makefile.in
674===================================================================
675--- offscreen.orig/toolkit/mozapps/update/src/updater/Makefile.in 2009-12-09 13:10:12.000000000 +0000
676+++ offscreen/toolkit/mozapps/update/src/updater/Makefile.in 2009-12-09 13:10:12.000000000 +0000
677@@ -56,7 +56,7 @@
678
679 LIBS += \
680 $(DEPTH)/modules/libmar/src/$(LIB_PREFIX)mar.$(LIB_SUFFIX) \
681- $(BZ2_LIBS) \
682+ $(BZ2_LIBS) -lpthread \
683 $(NULL)
684
685 ifeq ($(OS_ARCH),WINNT)
686Index: offscreen/xpcom/sample/program/Makefile.in
687===================================================================
688--- offscreen.orig/xpcom/sample/program/Makefile.in 2009-12-09 13:10:12.000000000 +0000
689+++ offscreen/xpcom/sample/program/Makefile.in 2009-12-09 13:10:12.000000000 +0000
690@@ -57,7 +57,7 @@
691 # that the application be linked against the XPCOM dynamic library or the NSPR
692 # dynamic libraries.
693 LIBS = \
694- $(XPCOM_STANDALONE_GLUE_LDOPTS) \
695+ $(XPCOM_STANDALONE_GLUE_LDOPTS) -ldl \
696 $(NULL)
697
698 # Need to link with CoreFoundation on Mac
699Index: offscreen/xpcom/tools/registry/Makefile.in
700===================================================================
701--- offscreen.orig/xpcom/tools/registry/Makefile.in 2009-12-09 13:10:12.000000000 +0000
702+++ offscreen/xpcom/tools/registry/Makefile.in 2009-12-09 13:10:12.000000000 +0000
703@@ -54,7 +54,7 @@
704 SIMPLE_PROGRAMS = $(CPPSRCS:.cpp=$(BIN_SUFFIX))
705
706 LIBS = \
707- $(XPCOM_STANDALONE_GLUE_LDOPTS) \
708+ $(XPCOM_STANDALONE_GLUE_LDOPTS) -ldl \
709 $(NULL)
710
711 # Need to link with CoreFoundation on Mac
712Index: offscreen/xulrunner/app/Makefile.in
713===================================================================
714--- offscreen.orig/xulrunner/app/Makefile.in 2009-12-09 13:10:12.000000000 +0000
715+++ offscreen/xulrunner/app/Makefile.in 2009-12-09 13:10:12.000000000 +0000
716@@ -173,7 +173,7 @@
717 RCFLAGS += -DXULRUNNER_ICO=\"$(DIST)/branding/xulrunner.ico\" -DDOCUMENT_ICO=\"$(DIST)/branding/document.ico\"
718 endif
719
720-LIBS += $(JEMALLOC_LIBS)
721+LIBS += $(JEMALLOC_LIBS) -lpthread -ldl
722
723 include $(topsrcdir)/config/rules.mk
724
725Index: offscreen/xulrunner/stub/Makefile.in
726===================================================================
727--- offscreen.orig/xulrunner/stub/Makefile.in 2009-12-09 13:10:12.000000000 +0000
728+++ offscreen/xulrunner/stub/Makefile.in 2009-12-09 13:10:12.000000000 +0000
729@@ -100,7 +100,7 @@
730 endif
731 endif
732
733-LIBS += $(JEMALLOC_LIBS)
734+LIBS += $(JEMALLOC_LIBS) -lpthread -ldl
735
736 include $(topsrcdir)/config/rules.mk
737
738Index: offscreen/modules/plugin/test/testplugin/Makefile.in
739===================================================================
740--- offscreen.orig/modules/plugin/test/testplugin/Makefile.in 2009-12-09 13:10:12.000000000 +0000
741+++ offscreen/modules/plugin/test/testplugin/Makefile.in 2009-12-09 13:10:12.000000000 +0000
742@@ -60,9 +60,7 @@
743 CMMSRCS = nptest_macosx.mm
744 endif
745
746-ifeq ($(MOZ_WIDGET_TOOLKIT),gtk2)
747 CPPSRCS += nptest_gtk2.cpp
748-endif
749
750 ifeq ($(MOZ_WIDGET_TOOLKIT),os2)
751 CPPSRCS += nptest_os2.cpp
752Index: offscreen/js/src/aclocal.m4
753===================================================================
754--- offscreen.orig/js/src/aclocal.m4 2009-12-09 13:10:12.000000000 +0000
755+++ offscreen/js/src/aclocal.m4 2009-12-09 13:39:01.000000000 +0000
756@@ -8,6 +8,4 @@
757 builtin(include, build/autoconf/altoptions.m4)dnl
758 builtin(include, build/autoconf/moznbytetype.m4)dnl
759 builtin(include, build/autoconf/mozprog.m4)dnl
760-builtin(include, build/autoconf/acwinpaths.m4)dnl
761
762-MOZ_PROG_CHECKMSYS()
763Index: offscreen/toolkit/toolkit-makefiles.sh
764===================================================================
765--- offscreen.orig/toolkit/toolkit-makefiles.sh 2009-12-09 13:10:12.000000000 +0000
766+++ offscreen/toolkit/toolkit-makefiles.sh 2009-12-09 13:10:12.000000000 +0000
767@@ -369,7 +369,6 @@
768 modules/plugin/sdk/samples/Makefile
769 modules/plugin/sdk/samples/common/Makefile
770 modules/plugin/sdk/samples/basic/windows/Makefile
771- modules/plugin/sdk/samples/basic/unix/Makefile
772 modules/plugin/sdk/samples/winless/windows/Makefile
773 "
774