summaryrefslogtreecommitdiffstats
path: root/meta/packages/mesa/mesa-7.0.2/fix-host-compile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/mesa/mesa-7.0.2/fix-host-compile.patch')
-rw-r--r--meta/packages/mesa/mesa-7.0.2/fix-host-compile.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/meta/packages/mesa/mesa-7.0.2/fix-host-compile.patch b/meta/packages/mesa/mesa-7.0.2/fix-host-compile.patch
deleted file mode 100644
index d24d03d379..0000000000
--- a/meta/packages/mesa/mesa-7.0.2/fix-host-compile.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1--- /src/mesa/x86/orig-Makefile 2005-07-01 04:54:38.000000000 +0300
2+++ /src/mesa/x86/Makefile 2007-06-07 21:52:31.000000000 +0300
3@@ -5,6 +5,7 @@
4
5
6 INCLUDE_DIRS = \
7+ -I/usr/include \
8 -I$(TOP)/include/GL \
9 -I$(TOP)/include \
10 -I.. \
11@@ -13,6 +14,10 @@
12 -I../glapi \
13 -I../tnl
14
15+OPT_FLAGS_host = -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os
16+
17+CFLAGS_host = -Wall -Wmissing-prototypes $(OPT_FLAGS_host) $(PIC_FLAGS) $(ARCH_FLAGS) \
18+ $(DEFINES) $(ASM_FLAGS) $(X11_INCLUDES) -std=c99 -ffast-math
19
20 default: gen_matypes matypes.h
21
22@@ -21,7 +26,7 @@
23
24
25 gen_matypes: gen_matypes.c
26- $(CC) $(INCLUDE_DIRS) $(CFLAGS) gen_matypes.c -o gen_matypes
27+ $(CC) $(INCLUDE_DIRS) $(CFLAGS_host) gen_matypes.c -o gen_matypes
28
29 # need some special rules here, unfortunately
30 matypes.h: ../main/mtypes.h ../tnl/t_context.h gen_matypes