summaryrefslogtreecommitdiffstats
path: root/meta/packages/matchbox-wm/matchbox-wm_0.9.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/matchbox-wm/matchbox-wm_0.9.5.bb')
-rw-r--r--meta/packages/matchbox-wm/matchbox-wm_0.9.5.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/packages/matchbox-wm/matchbox-wm_0.9.5.bb b/meta/packages/matchbox-wm/matchbox-wm_0.9.5.bb
new file mode 100644
index 0000000000..c158f590ce
--- /dev/null
+++ b/meta/packages/matchbox-wm/matchbox-wm_0.9.5.bb
@@ -0,0 +1,33 @@
1SECTION = "x11/wm"
2DESCRIPTION = "Matchbox window manager"
3LICENSE = "GPL"
4DEPENDS = "libmatchbox libx11 libxext libxcomposite libxfixes xdamage libxrender startup-notification expat gconf matchbox-common"
5RDEPENDS = "matchbox-common"
6PR="r0"
7
8
9SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/0.9/matchbox-window-manager-${PV}.tar.gz \
10 file://kbdconfig"
11
12S = "${WORKDIR}/matchbox-window-manager-${PV}"
13
14inherit autotools pkgconfig update-alternatives
15
16FILES_${PN} = "${bindir} \
17 ${datadir}/matchbox \
18 ${sysconfdir}/matchbox \
19 ${datadir}/themes/blondie/matchbox \
20 ${datadir}/themes/Default/matchbox \
21 ${datadir}/themes/MBOpus/matchbox"
22
23ALTERNATIVE_NAME = "x-window-manager"
24ALTERNATIVE_LINK = "${bindir}/x-window-manager"
25ALTERNATIVE_PATH = "${bindir}/matchbox-session"
26ALTERNATIVE_PRIORITY = "10"
27
28EXTRA_OECONF = " --enable-startup-notification --disable-xrm"
29
30do_install_prepend() {
31 install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
32}
33