summaryrefslogtreecommitdiffstats
path: root/meta/packages/matchbox-wm-2/matchbox-wm-2_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/matchbox-wm-2/matchbox-wm-2_svn.bb')
-rw-r--r--meta/packages/matchbox-wm-2/matchbox-wm-2_svn.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/packages/matchbox-wm-2/matchbox-wm-2_svn.bb b/meta/packages/matchbox-wm-2/matchbox-wm-2_svn.bb
new file mode 100644
index 0000000000..1584f3d585
--- /dev/null
+++ b/meta/packages/matchbox-wm-2/matchbox-wm-2_svn.bb
@@ -0,0 +1,33 @@
1SECTION = "x11/wm"
2DESCRIPTION = "Matchbox window manager"
3LICENSE = "GPL"
4DEPENDS = "virtual/libx11 libxext libxrender startup-notification expat gconf pango libxdamage libxcomposite"
5
6PV = "0.0+svnr${SRCREV}"
7PR = "r1"
8
9SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager-2;proto=http \
10 "
11
12S = "${WORKDIR}/matchbox-window-manager-2"
13
14inherit autotools pkgconfig update-alternatives
15
16ALTERNATIVE_NAME = "x-window-manager"
17ALTERNATIVE_LINK = "${bindir}/x-window-manager"
18ALTERNATIVE_PATH = "${bindir}/matchbox-session"
19ALTERNATIVE_PRIORITY = "10"
20
21FILES_${PN} = "${bindir}/* \
22 ${datadir}/matchbox-2 \
23 ${sysconfdir}/matchbox-2 \
24 ${datadir}/themes/*"
25
26EXTRA_OECONF = "--enable-debug \
27 --enable-compositing-manager \
28 "
29
30do_install_append () {
31 cd ${D}${bindir}
32 ln -s matchbox-window-manager-2-simple matchbox-window-manager
33}