summaryrefslogtreecommitdiffstats
path: root/meta/packages/matchbox-poky
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/matchbox-poky')
-rwxr-xr-xmeta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session43
-rw-r--r--meta/packages/matchbox-poky/matchbox-poky_0.1.bb20
2 files changed, 63 insertions, 0 deletions
diff --git a/meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session b/meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
new file mode 100755
index 0000000000..fede9e44b9
--- /dev/null
+++ b/meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
@@ -0,0 +1,43 @@
1#!/bin/sh
2
3module_id() {
4 awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo
5}
6
7SHOWCURSOR="no"
8
9## Start up machine specific input devices. Really needs to go in its own session
10case `module_id` in
11 "SHARP Shepherd" | "SHARP Husky" | "SHARP Corgi" | "SHARP Spitz" | "SHARP Akita" | "SHARP Borzoi")
12 chkhinge26 /dev/input/event0 hinge-handler &
13 ;;
14 "Generic OMAP1510/1610/1710")
15 /usr/bin/mbinputmgr &
16 ;;
17 "ARM-IntegratorCP")
18 /usr/bin/mbinputmgr &
19 SHOWCURSOR="yes"
20 ;;
21esac
22
23## All this should be done by themeing/xsettings.. ##
24matchbox-desktop --icon-size 48 \
25 --icon-padding 64 \
26 --font sans-8:bold \
27 --titlefont sans-8:bold &
28
29# let theme set it
30# --bg /usr/share/themes/Clearlooks/background/default.png \
31
32mb-applet-startup-monitor &
33
34matchbox-panel --orientation east \
35 --padding 4 \
36 --no-menu \
37 --no-session \
38 --default-apps mb-applet-home,mb-applet-clock,mb-applet-battery &
39
40## eek ugly no cursor hack - transparent theme should do this
41exec matchbox-window-manager -theme Clearlooks -use_cursor $SHOWCURSOR $@
42
43
diff --git a/meta/packages/matchbox-poky/matchbox-poky_0.1.bb b/meta/packages/matchbox-poky/matchbox-poky_0.1.bb
new file mode 100644
index 0000000000..041a6ea904
--- /dev/null
+++ b/meta/packages/matchbox-poky/matchbox-poky_0.1.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "Custom MB session files for poky"
2LICENSE = "GPL"
3SECTION = "x11"
4RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-theme-clearlooks"
5PR = "r15"
6
7SRC_URI = "file://etc"
8S = ${WORKDIR}
9
10do_install() {
11 cp -R ${S}/etc ${D}/etc
12 rm -fR ${D}/etc/.svn
13 rm -fR ${D}/etc/matchbox/.svn
14 chmod -R 755 ${D}/etc
15}
16
17pkg_postinst_matchbox-poky () {
18#!/bin/sh -e
19gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/theme Clearlooks
20}