summaryrefslogtreecommitdiffstats
path: root/meta/packages/matchbox-panel-hacks
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/matchbox-panel-hacks')
-rw-r--r--meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop7
-rwxr-xr-xmeta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home2
-rw-r--r--meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop7
-rwxr-xr-xmeta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh9
-rw-r--r--meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.pngbin0 -> 1651 bytes
-rw-r--r--meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb23
6 files changed, 48 insertions, 0 deletions
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop
new file mode 100644
index 0000000000..4e08dfd379
--- /dev/null
+++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop
@@ -0,0 +1,7 @@
1[Desktop Entry]
2Name=Home
3Comment=Home
4Exec=mb-applet-home
5Type=PanelApp
6Icon=xrandr.png
7Categories=Panel;Utility;MB
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home
new file mode 100755
index 0000000000..72aa76f227
--- /dev/null
+++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home
@@ -0,0 +1,2 @@
1#!/bin/sh
2mb-applet-launcher -na -o -1 -l --title "Home" mbdesktop.png matchbox-remote -d
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop
new file mode 100644
index 0000000000..512e3771e4
--- /dev/null
+++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.desktop
@@ -0,0 +1,7 @@
1[Desktop Entry]
2Name=Screen Rotator
3Comment=Panel based Rotation tool.
4Exec=mb-applet-launcher -na -l --title "Screen Rotator" /usr/share/pixmaps/xrandr.png xrandr-panelapp.sh
5Type=PanelApp
6Icon=xrandr.png
7Categories=Panel;Utility;MB
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh
new file mode 100755
index 0000000000..d17c805ffc
--- /dev/null
+++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr-panelapp.sh
@@ -0,0 +1,9 @@
1#!/bin/sh
2if [ -n "$(xrandr | grep rotation | grep left)" ]
3then
4xrandr -o normal
5xmodmap /etc/X11/xmodmap-portrait
6else
7xrandr -o left
8xmodmap /etc/X11/xmodmap-left
9fi
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.png b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.png
new file mode 100644
index 0000000000..08cd476e8a
--- /dev/null
+++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/xrandr.png
Binary files differ
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
new file mode 100644
index 0000000000..46b0acfe2e
--- /dev/null
+++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Simple dockapps created with monolaunch and shell script"
2DEPENDS = "matchbox xmodmap"
3SRC_URI = "file://xrandr-panelapp.sh \
4 file://xrandr-panelapp.desktop \
5 file://mb-applet-home \
6 file://home-panelapp.desktop \
7 file://xrandr.png"
8SECTION = "x11/wm"
9PRIORITY = "optional"
10PR = "r6"
11LICENSE = "MIT"
12
13do_install() {
14 install -d ${D}${bindir}
15 install -d ${D}${datadir}/applications
16 install -d ${D}${datadir}/pixmaps
17 install -m 0755 ${WORKDIR}/xrandr-panelapp.sh ${D}${bindir}/
18 install -m 0644 ${WORKDIR}/xrandr-panelapp.desktop ${D}${datadir}/applications/
19 install -m 0644 ${WORKDIR}/xrandr.png ${D}${datadir}/pixmaps/
20 install -m 0755 ${WORKDIR}/mb-applet-home ${D}${bindir}/
21 install -m 0644 ${WORKDIR}/home-panelapp.desktop ${D}${datadir}/applications/
22
23}