summaryrefslogtreecommitdiffstats
path: root/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb')
-rw-r--r--meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
new file mode 100644
index 0000000000..46b0acfe2e
--- /dev/null
+++ b/meta/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Simple dockapps created with monolaunch and shell script"
2DEPENDS = "matchbox xmodmap"
3SRC_URI = "file://xrandr-panelapp.sh \
4 file://xrandr-panelapp.desktop \
5 file://mb-applet-home \
6 file://home-panelapp.desktop \
7 file://xrandr.png"
8SECTION = "x11/wm"
9PRIORITY = "optional"
10PR = "r6"
11LICENSE = "MIT"
12
13do_install() {
14 install -d ${D}${bindir}
15 install -d ${D}${datadir}/applications
16 install -d ${D}${datadir}/pixmaps
17 install -m 0755 ${WORKDIR}/xrandr-panelapp.sh ${D}${bindir}/
18 install -m 0644 ${WORKDIR}/xrandr-panelapp.desktop ${D}${datadir}/applications/
19 install -m 0644 ${WORKDIR}/xrandr.png ${D}${datadir}/pixmaps/
20 install -m 0755 ${WORKDIR}/mb-applet-home ${D}${bindir}/
21 install -m 0644 ${WORKDIR}/home-panelapp.desktop ${D}${datadir}/applications/
22
23}