diff options
Diffstat (limited to 'meta/packages/matchbox-netbook')
-rw-r--r-- | meta/packages/matchbox-netbook/matchbox-session-netbook/session | 22 | ||||
-rw-r--r-- | meta/packages/matchbox-netbook/matchbox-session-netbook_0.1.bb | 43 |
2 files changed, 0 insertions, 65 deletions
diff --git a/meta/packages/matchbox-netbook/matchbox-session-netbook/session b/meta/packages/matchbox-netbook/matchbox-session-netbook/session deleted file mode 100644 index 2417e9b0be..0000000000 --- a/meta/packages/matchbox-netbook/matchbox-session-netbook/session +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | . /etc/formfactor/config | ||
4 | |||
5 | if [ "$HAVE_TOUCHSCREEN" = "1" ]; then | ||
6 | SHOWCURSOR="no" | ||
7 | else | ||
8 | SHOWCURSOR="yes" | ||
9 | fi | ||
10 | |||
11 | matchbox-desktop & | ||
12 | |||
13 | # Lines containing feature-[foo] are removed at build time if the machine | ||
14 | # doesn't have the feature "foo". | ||
15 | |||
16 | START_APPLETS=showdesktop,windowselector | ||
17 | END_APPLETS=clock,battery,brightness,systray,startup-notify,notify | ||
18 | END_APPLETS=openmoko-panel-gsm,$END_APPLETS # feature-phone | ||
19 | |||
20 | matchbox-panel --start-applets $START_APPLETS --end-applets $END_APPLETS & | ||
21 | |||
22 | exec metacity | ||
diff --git a/meta/packages/matchbox-netbook/matchbox-session-netbook_0.1.bb b/meta/packages/matchbox-netbook/matchbox-session-netbook_0.1.bb deleted file mode 100644 index 1b33bff0ff..0000000000 --- a/meta/packages/matchbox-netbook/matchbox-session-netbook_0.1.bb +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | DESCRIPTION = "Custom MB session files for poky" | ||
2 | LICENSE = "GPL" | ||
3 | SECTION = "x11" | ||
4 | RDEPENDS = "formfactor gtk-engines gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts matchbox-session" | ||
5 | PR = "r3" | ||
6 | |||
7 | # This package is architecture specific because the session script is modified | ||
8 | # based on the machine architecture. | ||
9 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
10 | |||
11 | SRC_URI = "file://session" | ||
12 | S = "${WORKDIR}" | ||
13 | |||
14 | do_install() { | ||
15 | # This is the set of machine features that the script has markers for | ||
16 | FEATURES="phone" | ||
17 | SCRIPT="${S}/sedder" | ||
18 | rm -f $SCRIPT | ||
19 | touch $SCRIPT | ||
20 | for FEAT in $FEATURES; do | ||
21 | if echo ${MACHINE_FEATURES} | awk "/$FEAT/ {exit 1}"; then | ||
22 | echo "/feature-$FEAT/d" >> $SCRIPT | ||
23 | fi | ||
24 | done | ||
25 | |||
26 | install -d ${D}/${sysconfdir}/matchbox | ||
27 | sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session | ||
28 | chmod +x ${D}/${sysconfdir}/matchbox/session | ||
29 | } | ||
30 | |||
31 | pkg_postinst_${PN} () { | ||
32 | #!/bin/sh -e | ||
33 | if [ "x$D" != "x" ]; then | ||
34 | exit 1 | ||
35 | fi | ||
36 | |||
37 | . ${sysconfdir}/init.d/functions | ||
38 | |||
39 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Sato | ||
40 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme Sato | ||
41 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /desktop/poky/interface/touchscreen true | ||
42 | |||
43 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 10" \ No newline at end of file | ||