diff options
Diffstat (limited to 'meta/packages/matchbox-config-gtk')
-rw-r--r-- | meta/packages/matchbox-config-gtk/files/no-handed.patch | 33 | ||||
-rw-r--r-- | meta/packages/matchbox-config-gtk/matchbox-config-gtk_svn.bb | 10 |
2 files changed, 40 insertions, 3 deletions
diff --git a/meta/packages/matchbox-config-gtk/files/no-handed.patch b/meta/packages/matchbox-config-gtk/files/no-handed.patch new file mode 100644 index 0000000000..91b27ae171 --- /dev/null +++ b/meta/packages/matchbox-config-gtk/files/no-handed.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | Index: matchbox-config-gtk/appearance/mb-appearance.c | ||
2 | =================================================================== | ||
3 | --- matchbox-config-gtk/appearance/mb-appearance.c (revision 1614) | ||
4 | +++ matchbox-config-gtk/appearance/mb-appearance.c (working copy) | ||
5 | @@ -300,11 +300,13 @@ | ||
6 | gtk_font_button_set_font_name (GTK_FONT_BUTTON (font_button), | ||
7 | gconf_value_get_string (value)); | ||
8 | } else if (strcmp (key, HANDED_KEY) == 0) { | ||
9 | +#if 0 | ||
10 | GEnumValue *e; | ||
11 | e = g_enum_get_value_by_name (g_type_class_ref (GTK_TYPE_CORNER_TYPE), | ||
12 | gconf_value_get_string (value)); | ||
13 | gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (handed_check), | ||
14 | e->value == GTK_CORNER_TOP_RIGHT); | ||
15 | +#endif | ||
16 | } | ||
17 | } | ||
18 | |||
19 | @@ -395,12 +397,13 @@ | ||
20 | gtk_container_add (GTK_CONTAINER (align), font_button); | ||
21 | |||
22 | /* Left/Right Handed */ | ||
23 | - | ||
24 | +#if 0 | ||
25 | frame = new_frame (_("Orientation"), &align); | ||
26 | gtk_box_pack_start (GTK_BOX (box), frame, TRUE, TRUE, 0); | ||
27 | handed_check = gtk_check_button_new_with_mnemonic (_("_Left-handed")); | ||
28 | g_signal_connect (handed_check, "toggled", G_CALLBACK (on_handed_set), NULL); | ||
29 | gtk_container_add (GTK_CONTAINER (align), handed_check); | ||
30 | +#endif | ||
31 | |||
32 | gconf_client_add_dir (gconf, INTERFACE_DIR, GCONF_CLIENT_PRELOAD_ONELEVEL, NULL); | ||
33 | g_signal_connect (gconf, "value-changed", G_CALLBACK (on_gconf_value_changed), NULL); | ||
diff --git a/meta/packages/matchbox-config-gtk/matchbox-config-gtk_svn.bb b/meta/packages/matchbox-config-gtk/matchbox-config-gtk_svn.bb index ec11e45ad7..0e91006661 100644 --- a/meta/packages/matchbox-config-gtk/matchbox-config-gtk_svn.bb +++ b/meta/packages/matchbox-config-gtk/matchbox-config-gtk_svn.bb | |||
@@ -1,11 +1,15 @@ | |||
1 | DESCRIPTION = "Matchbox gtk theme configuration application." | 1 | DESCRIPTION = "Matchbox GTK+ theme configuration application." |
2 | LICENSE = "GPL" | 2 | LICENSE = "GPL" |
3 | DEPENDS = "gconf libglade gtk+" | 3 | DEPENDS = "gconf gtk+" |
4 | RDEPENDS = "settings-daemon" | 4 | RDEPENDS = "settings-daemon" |
5 | |||
5 | PV = "0.0+svn${SRCDATE}" | 6 | PV = "0.0+svn${SRCDATE}" |
7 | PR = "r1" | ||
8 | |||
6 | S = "${WORKDIR}/${PN}" | 9 | S = "${WORKDIR}/${PN}" |
7 | 10 | ||
8 | SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http" | 11 | SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \ |
12 | file://no-handed.patch;patch=1;pnum=0" | ||
9 | 13 | ||
10 | inherit autotools pkgconfig | 14 | inherit autotools pkgconfig |
11 | 15 | ||