summaryrefslogtreecommitdiffstats
path: root/meta/packages/lttng
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/lttng')
-rw-r--r--meta/packages/lttng/lttng-control-0.10/lttctl_sti-r0.patch147
-rw-r--r--meta/packages/lttng/lttng-control-0.6/lttctl_sti-r0.patch134
-rw-r--r--meta/packages/lttng/lttng-control_0.10.bb17
-rw-r--r--meta/packages/lttng/lttng-control_0.6.bb16
-rw-r--r--meta/packages/lttng/lttng-viewer_0.8.41-20060512.bb20
5 files changed, 334 insertions, 0 deletions
diff --git a/meta/packages/lttng/lttng-control-0.10/lttctl_sti-r0.patch b/meta/packages/lttng/lttng-control-0.10/lttctl_sti-r0.patch
new file mode 100644
index 0000000000..9b04752bca
--- /dev/null
+++ b/meta/packages/lttng/lttng-control-0.10/lttctl_sti-r0.patch
@@ -0,0 +1,147 @@
1Index: ltt-control-0.6-28042006/liblttctl/liblttctl.c
2===================================================================
3--- ltt-control-0.6-28042006.orig/liblttctl/liblttctl.c 2006-03-11 17:30:32.000000000 +0000
4+++ ltt-control-0.6-28042006/liblttctl/liblttctl.c 2006-06-01 14:39:05.000000000 +0100
5@@ -298,7 +298,7 @@
6
7
8 int lttctl_create_trace(const struct lttctl_handle *h,
9- char *name, enum trace_mode mode, unsigned subbuf_size, unsigned n_subbufs)
10+ char *name, enum trace_mode mode, char *trace_type, unsigned subbuf_size, unsigned n_subbufs)
11 {
12 int err;
13
14@@ -320,6 +320,7 @@
15 req.nlh.nlmsg_seq = 0;
16
17 strncpy(req.msg.trace_name, name, NAME_MAX);
18+ strncpy(req.msg.trace_type, trace_type, NAME_MAX);
19 req.msg.op = OP_CREATE;
20 req.msg.args.new_trace.mode = mode;
21 req.msg.args.new_trace.subbuf_size = subbuf_size;
22Index: ltt-control-0.6-28042006/liblttctl/lttctl.h
23===================================================================
24--- ltt-control-0.6-28042006.orig/liblttctl/lttctl.h 2006-03-11 17:30:32.000000000 +0000
25+++ ltt-control-0.6-28042006/liblttctl/lttctl.h 2006-06-01 14:40:16.000000000 +0100
26@@ -47,6 +47,7 @@
27
28 typedef struct lttctl_peer_msg {
29 char trace_name[NAME_MAX];
30+ char trace_type[NAME_MAX];
31 enum trace_op op;
32 union {
33 struct {
34@@ -76,7 +77,7 @@
35
36
37 int lttctl_create_trace(const struct lttctl_handle *h,
38- char *name, enum trace_mode mode, unsigned subbuf_size, unsigned n_subbufs);
39+ char *name, enum trace_mode mode, char *trace_type, unsigned subbuf_size, unsigned n_subbufs);
40
41 int lttctl_destroy_trace(const struct lttctl_handle *handle, char *name);
42
43Index: ltt-control-0.6-28042006/lttctl/lttctl.c
44===================================================================
45--- ltt-control-0.6-28042006.orig/lttctl/lttctl.c 2006-03-11 17:30:27.000000000 +0000
46+++ ltt-control-0.6-28042006/lttctl/lttctl.c 2006-06-01 14:40:47.000000000 +0100
47@@ -40,6 +40,7 @@
48 };
49
50 static char *trace_name = NULL;
51+static char *trace_type = "relayfs";
52 static char *mode_name = NULL;
53 static unsigned subbuf_size = 0;
54 static unsigned n_subbufs = 0;
55@@ -81,6 +82,7 @@
56 printf(" (optionnaly, you can set LTT_DAEMON\n");
57 printf(" and the LTT_FACILITIES env. vars.)\n");
58 printf("-t Trace root path. (ex. /root/traces/example_trace)\n");
59+ printf("-T Type of trace (ex. relayfs, sti, stirelayfs)\n");
60 printf("-l LTT channels root path. (ex. /mnt/relayfs/ltt)\n");
61 printf("-z Size of the subbuffers (will be rounded to next page size)\n");
62 printf("-x Number of subbuffers\n");
63@@ -217,6 +219,16 @@
64 argn++;
65 }
66 break;
67+ case 'T':
68+ if(argn+1 < argc) {
69+ trace_type = argv[argn+1];
70+ argn++;
71+ } else {
72+ printf("Specify a trace type after -T.\n");
73+ printf("\n");
74+ ret = EINVAL;
75+ }
76+ break;
77 default:
78 printf("Invalid argument '%s'.\n", argv[argn]);
79 printf("\n");
80@@ -390,7 +402,7 @@
81 strcat(channel_path, trace_name);
82
83
84- ret = lttctl_create_trace(handle, trace_name, mode, subbuf_size, n_subbufs);
85+ ret = lttctl_create_trace(handle, trace_name, mode, trace_type, subbuf_size, n_subbufs);
86 if(ret != 0) goto create_error;
87
88 act.sa_handler = sigchld_handler;
89@@ -466,13 +478,13 @@
90
91 switch(op) {
92 case CTL_OP_CREATE_START:
93- ret = lttctl_create_trace(handle, trace_name, mode, subbuf_size,
94+ ret = lttctl_create_trace(handle, trace_name, mode, trace_type, subbuf_size,
95 n_subbufs);
96 if(!ret)
97 ret = lttctl_start(handle, trace_name);
98 break;
99 case CTL_OP_CREATE:
100- ret = lttctl_create_trace(handle, trace_name, mode, subbuf_size,
101+ ret = lttctl_create_trace(handle, trace_name, mode, trace_type, subbuf_size,
102 n_subbufs);
103 break;
104 case CTL_OP_DESTROY:
105Index: ltt-control-0.6-28042006/facilities/dynticks.xml
106===================================================================
107--- /dev/null 1970-01-01 00:00:00.000000000 +0000
108+++ ltt-control-0.6-28042006/facilities/dynticks.xml 2006-06-05 18:03:41.000000000 +0100
109@@ -0,0 +1,18 @@
110+<?xml version="1.0"?>
111+<facility name="dynticks">
112+ <description>Dynamic Timer Events</description>
113+
114+ <event name="handler_entry">
115+ <description>Dynticks Handler Entered</description>
116+ </event>
117+
118+ <event name="handler_exit">
119+ <description>Dynticks Handler Exitted</description>
120+ </event>
121+
122+ <event name="reprogram">
123+ <description>Dynticks Reprogram</description>
124+ <field name="ticks"><description>Number of ticks to sleep for</description><uint size="4"></field>
125+ </event>
126+
127+</facility>
128Index: ltt-control-0.6-28042006/facilities/Makefile.am
129===================================================================
130--- ltt-control-0.6-28042006.orig/facilities/Makefile.am 2006-04-28 21:26:26.000000000 +0100
131+++ ltt-control-0.6-28042006/facilities/Makefile.am 2006-06-05 18:04:30.000000000 +0100
132@@ -1,6 +1,7 @@
133
134 EXTRA_DIST = \
135 core.xml \
136+dynticks.xml \
137 fs.xml \
138 ipc.xml \
139 kernel.xml \
140@@ -21,6 +22,7 @@
141
142 facilities_DATA = \
143 core.xml \
144+dynticks.xml \
145 fs.xml \
146 ipc.xml \
147 kernel.xml \
diff --git a/meta/packages/lttng/lttng-control-0.6/lttctl_sti-r0.patch b/meta/packages/lttng/lttng-control-0.6/lttctl_sti-r0.patch
new file mode 100644
index 0000000000..f1e45ac159
--- /dev/null
+++ b/meta/packages/lttng/lttng-control-0.6/lttctl_sti-r0.patch
@@ -0,0 +1,134 @@
1Index: ltt-control-0.6-28042006/liblttctl/liblttctl.c
2===================================================================
3--- ltt-control-0.6-28042006.orig/liblttctl/liblttctl.c 2006-03-11 17:30:32.000000000 +0000
4+++ ltt-control-0.6-28042006/liblttctl/liblttctl.c 2006-05-12 11:21:13.000000000 +0100
5@@ -298,7 +298,7 @@
6
7
8 int lttctl_create_trace(const struct lttctl_handle *h,
9- char *name, enum trace_mode mode, unsigned subbuf_size, unsigned n_subbufs)
10+ char *name, enum trace_mode mode, enum ltt_trace_type type, unsigned subbuf_size, unsigned n_subbufs)
11 {
12 int err;
13
14@@ -324,6 +324,7 @@
15 req.msg.args.new_trace.mode = mode;
16 req.msg.args.new_trace.subbuf_size = subbuf_size;
17 req.msg.args.new_trace.n_subbufs = n_subbufs;
18+ req.msg.args.new_trace.type = type;
19
20 err = lttctl_netlink_sendto(h, (void *)&req, req.nlh.nlmsg_len);
21 if(err < 0) goto senderr;
22Index: ltt-control-0.6-28042006/liblttctl/lttctl.h
23===================================================================
24--- ltt-control-0.6-28042006.orig/liblttctl/lttctl.h 2006-03-11 17:30:32.000000000 +0000
25+++ ltt-control-0.6-28042006/liblttctl/lttctl.h 2006-05-12 11:20:46.000000000 +0100
26@@ -45,6 +45,12 @@
27 LTT_TRACE_FLIGHT
28 };
29
30+enum ltt_trace_type {
31+ LTT_TYPE_RELAYFS,
32+ LTT_TYPE_STI,
33+ LTT_TYPE_STIRELAYFS
34+};
35+
36 typedef struct lttctl_peer_msg {
37 char trace_name[NAME_MAX];
38 enum trace_op op;
39@@ -53,6 +59,7 @@
40 enum trace_mode mode;
41 unsigned subbuf_size;
42 unsigned n_subbufs;
43+ enum ltt_trace_type type;
44 } new_trace;
45 } args;
46 } lttctl_peer_msg_t;
47@@ -76,7 +83,7 @@
48
49
50 int lttctl_create_trace(const struct lttctl_handle *h,
51- char *name, enum trace_mode mode, unsigned subbuf_size, unsigned n_subbufs);
52+ char *name, enum trace_mode mode, enum ltt_trace_type type, unsigned subbuf_size, unsigned n_subbufs);
53
54 int lttctl_destroy_trace(const struct lttctl_handle *handle, char *name);
55
56Index: ltt-control-0.6-28042006/lttctl/lttctl.c
57===================================================================
58--- ltt-control-0.6-28042006.orig/lttctl/lttctl.c 2006-03-11 17:30:27.000000000 +0000
59+++ ltt-control-0.6-28042006/lttctl/lttctl.c 2006-05-12 11:19:53.000000000 +0100
60@@ -40,11 +40,13 @@
61 };
62
63 static char *trace_name = NULL;
64+static char *trace_type = NULL;
65 static char *mode_name = NULL;
66 static unsigned subbuf_size = 0;
67 static unsigned n_subbufs = 0;
68 static unsigned append_trace = 0;
69 static enum trace_mode mode = LTT_TRACE_NORMAL;
70+static enum ltt_trace_type type = LTT_TYPE_RELAYFS;
71 static enum trace_ctl_op op = CTL_OP_NONE;
72 static char *channel_root = NULL;
73 static char *trace_root = NULL;
74@@ -81,6 +83,7 @@
75 printf(" (optionnaly, you can set LTT_DAEMON\n");
76 printf(" and the LTT_FACILITIES env. vars.)\n");
77 printf("-t Trace root path. (ex. /root/traces/example_trace)\n");
78+ printf("-T Type of trace (ex. relayfs, sti, stirelayfs)\n");
79 printf("-l LTT channels root path. (ex. /mnt/relayfs/ltt)\n");
80 printf("-z Size of the subbuffers (will be rounded to next page size)\n");
81 printf("-x Number of subbuffers\n");
82@@ -217,6 +220,27 @@
83 argn++;
84 }
85 break;
86+ case 'T':
87+ if(argn+1 < argc) {
88+ trace_type = argv[argn+1];
89+ argn++;
90+ if(strcmp(trace_type, "relayfs") == 0)
91+ type = LTT_TYPE_RELAYFS;
92+ else if(strcmp(trace_type, "sti") == 0)
93+ type = LTT_TYPE_STI;
94+ else if(strcmp(trace_type, "stirelayfs") == 0)
95+ type = LTT_TYPE_STIRELAYFS;
96+ else {
97+ printf("Invalid trace type '%s'.\n", argv[argn]);
98+ printf("\n");
99+ ret = EINVAL;
100+ }
101+ } else {
102+ printf("Specify a trace type after -T.\n");
103+ printf("\n");
104+ ret = EINVAL;
105+ }
106+ break;
107 default:
108 printf("Invalid argument '%s'.\n", argv[argn]);
109 printf("\n");
110@@ -390,7 +414,7 @@
111 strcat(channel_path, trace_name);
112
113
114- ret = lttctl_create_trace(handle, trace_name, mode, subbuf_size, n_subbufs);
115+ ret = lttctl_create_trace(handle, trace_name, mode, type, subbuf_size, n_subbufs);
116 if(ret != 0) goto create_error;
117
118 act.sa_handler = sigchld_handler;
119@@ -466,13 +490,13 @@
120
121 switch(op) {
122 case CTL_OP_CREATE_START:
123- ret = lttctl_create_trace(handle, trace_name, mode, subbuf_size,
124+ ret = lttctl_create_trace(handle, trace_name, mode, type, subbuf_size,
125 n_subbufs);
126 if(!ret)
127 ret = lttctl_start(handle, trace_name);
128 break;
129 case CTL_OP_CREATE:
130- ret = lttctl_create_trace(handle, trace_name, mode, subbuf_size,
131+ ret = lttctl_create_trace(handle, trace_name, mode, type, subbuf_size,
132 n_subbufs);
133 break;
134 case CTL_OP_DESTROY:
diff --git a/meta/packages/lttng/lttng-control_0.10.bb b/meta/packages/lttng/lttng-control_0.10.bb
new file mode 100644
index 0000000000..24399e4ec8
--- /dev/null
+++ b/meta/packages/lttng/lttng-control_0.10.bb
@@ -0,0 +1,17 @@
1SECTION = "devel"
2DESCRIPTION = "The Linux trace toolkit is a suite of tools designed to \
3extract program execution details from the Linux operating system and \
4interpret them."
5LICENSE = "GPL"
6MAINTAINER = "Richard Purdie <rpurdie@rpsys.net>"
7
8SRC_URI = "http://ltt.polymtl.ca/lttng/ltt-control-${PV}-12062006.tar.gz \
9 file://lttctl_sti-r0.patch;patch=1 "
10
11S = "${WORKDIR}/ltt-control-${PV}-12062006"
12
13inherit autotools
14
15export KERNELDIR="${STAGING_KERNEL_DIR}"
16
17FILES_${PN} += "${datadir}/ltt-control/facilities/*" \ No newline at end of file
diff --git a/meta/packages/lttng/lttng-control_0.6.bb b/meta/packages/lttng/lttng-control_0.6.bb
new file mode 100644
index 0000000000..b18f507e9d
--- /dev/null
+++ b/meta/packages/lttng/lttng-control_0.6.bb
@@ -0,0 +1,16 @@
1SECTION = "devel"
2DESCRIPTION = "The Linux trace toolkit is a suite of tools designed to \
3extract program execution details from the Linux operating system and \
4interpret them."
5LICENSE = "GPL"
6MAINTAINER = "Richard Purdie <rpurdie@rpsys.net>"
7
8SRC_URI = "http://ltt.polymtl.ca/lttng/ltt-control-${PV}-28042006.tar.gz"
9
10S = "${WORKDIR}/ltt-control-${PV}-28042006"
11
12inherit autotools
13
14export KERNELDIR="${STAGING_KERNEL_DIR}"
15
16FILES_${PN} += "${datadir}/ltt-control/facilities/*" \ No newline at end of file
diff --git a/meta/packages/lttng/lttng-viewer_0.8.41-20060512.bb b/meta/packages/lttng/lttng-viewer_0.8.41-20060512.bb
new file mode 100644
index 0000000000..c6069bc794
--- /dev/null
+++ b/meta/packages/lttng/lttng-viewer_0.8.41-20060512.bb
@@ -0,0 +1,20 @@
1SECTION = "devel"
2DESCRIPTION = "The Linux trace toolkit is a suite of tools designed to \
3extract program execution details from the Linux operating system and \
4interpret them."
5LICENSE = "GPL"
6MAINTAINER = "Richrd Purdie <richard@openedhand.com>"
7PR = "r1"
8DEPENDS = "gtk+ pango popt"
9
10ALTNAME = "LinuxTraceToolkitViewer-0.8.41-12052006"
11
12SRC_URI = "http://ltt.polymtl.ca/packages/${ALTNAME}.tar.gz "
13S = "${WORKDIR}/${ALTNAME}"
14
15inherit autotools
16
17FILES_${PN} += "\
18 ${libdir}/lttv/plugins/* \
19 ${datadir}/LinuxTraceToolkitViewer/facilities/* \
20 ${datadir}/LinuxTraceToolkitViewer/pixmaps/* "