summaryrefslogtreecommitdiffstats
path: root/meta/packages/lttng/lttng-control-0.10/lttctl_sti-r0.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/lttng/lttng-control-0.10/lttctl_sti-r0.patch')
-rw-r--r--meta/packages/lttng/lttng-control-0.10/lttctl_sti-r0.patch147
1 files changed, 147 insertions, 0 deletions
diff --git a/meta/packages/lttng/lttng-control-0.10/lttctl_sti-r0.patch b/meta/packages/lttng/lttng-control-0.10/lttctl_sti-r0.patch
new file mode 100644
index 0000000000..9b04752bca
--- /dev/null
+++ b/meta/packages/lttng/lttng-control-0.10/lttctl_sti-r0.patch
@@ -0,0 +1,147 @@
1Index: ltt-control-0.6-28042006/liblttctl/liblttctl.c
2===================================================================
3--- ltt-control-0.6-28042006.orig/liblttctl/liblttctl.c 2006-03-11 17:30:32.000000000 +0000
4+++ ltt-control-0.6-28042006/liblttctl/liblttctl.c 2006-06-01 14:39:05.000000000 +0100
5@@ -298,7 +298,7 @@
6
7
8 int lttctl_create_trace(const struct lttctl_handle *h,
9- char *name, enum trace_mode mode, unsigned subbuf_size, unsigned n_subbufs)
10+ char *name, enum trace_mode mode, char *trace_type, unsigned subbuf_size, unsigned n_subbufs)
11 {
12 int err;
13
14@@ -320,6 +320,7 @@
15 req.nlh.nlmsg_seq = 0;
16
17 strncpy(req.msg.trace_name, name, NAME_MAX);
18+ strncpy(req.msg.trace_type, trace_type, NAME_MAX);
19 req.msg.op = OP_CREATE;
20 req.msg.args.new_trace.mode = mode;
21 req.msg.args.new_trace.subbuf_size = subbuf_size;
22Index: ltt-control-0.6-28042006/liblttctl/lttctl.h
23===================================================================
24--- ltt-control-0.6-28042006.orig/liblttctl/lttctl.h 2006-03-11 17:30:32.000000000 +0000
25+++ ltt-control-0.6-28042006/liblttctl/lttctl.h 2006-06-01 14:40:16.000000000 +0100
26@@ -47,6 +47,7 @@
27
28 typedef struct lttctl_peer_msg {
29 char trace_name[NAME_MAX];
30+ char trace_type[NAME_MAX];
31 enum trace_op op;
32 union {
33 struct {
34@@ -76,7 +77,7 @@
35
36
37 int lttctl_create_trace(const struct lttctl_handle *h,
38- char *name, enum trace_mode mode, unsigned subbuf_size, unsigned n_subbufs);
39+ char *name, enum trace_mode mode, char *trace_type, unsigned subbuf_size, unsigned n_subbufs);
40
41 int lttctl_destroy_trace(const struct lttctl_handle *handle, char *name);
42
43Index: ltt-control-0.6-28042006/lttctl/lttctl.c
44===================================================================
45--- ltt-control-0.6-28042006.orig/lttctl/lttctl.c 2006-03-11 17:30:27.000000000 +0000
46+++ ltt-control-0.6-28042006/lttctl/lttctl.c 2006-06-01 14:40:47.000000000 +0100
47@@ -40,6 +40,7 @@
48 };
49
50 static char *trace_name = NULL;
51+static char *trace_type = "relayfs";
52 static char *mode_name = NULL;
53 static unsigned subbuf_size = 0;
54 static unsigned n_subbufs = 0;
55@@ -81,6 +82,7 @@
56 printf(" (optionnaly, you can set LTT_DAEMON\n");
57 printf(" and the LTT_FACILITIES env. vars.)\n");
58 printf("-t Trace root path. (ex. /root/traces/example_trace)\n");
59+ printf("-T Type of trace (ex. relayfs, sti, stirelayfs)\n");
60 printf("-l LTT channels root path. (ex. /mnt/relayfs/ltt)\n");
61 printf("-z Size of the subbuffers (will be rounded to next page size)\n");
62 printf("-x Number of subbuffers\n");
63@@ -217,6 +219,16 @@
64 argn++;
65 }
66 break;
67+ case 'T':
68+ if(argn+1 < argc) {
69+ trace_type = argv[argn+1];
70+ argn++;
71+ } else {
72+ printf("Specify a trace type after -T.\n");
73+ printf("\n");
74+ ret = EINVAL;
75+ }
76+ break;
77 default:
78 printf("Invalid argument '%s'.\n", argv[argn]);
79 printf("\n");
80@@ -390,7 +402,7 @@
81 strcat(channel_path, trace_name);
82
83
84- ret = lttctl_create_trace(handle, trace_name, mode, subbuf_size, n_subbufs);
85+ ret = lttctl_create_trace(handle, trace_name, mode, trace_type, subbuf_size, n_subbufs);
86 if(ret != 0) goto create_error;
87
88 act.sa_handler = sigchld_handler;
89@@ -466,13 +478,13 @@
90
91 switch(op) {
92 case CTL_OP_CREATE_START:
93- ret = lttctl_create_trace(handle, trace_name, mode, subbuf_size,
94+ ret = lttctl_create_trace(handle, trace_name, mode, trace_type, subbuf_size,
95 n_subbufs);
96 if(!ret)
97 ret = lttctl_start(handle, trace_name);
98 break;
99 case CTL_OP_CREATE:
100- ret = lttctl_create_trace(handle, trace_name, mode, subbuf_size,
101+ ret = lttctl_create_trace(handle, trace_name, mode, trace_type, subbuf_size,
102 n_subbufs);
103 break;
104 case CTL_OP_DESTROY:
105Index: ltt-control-0.6-28042006/facilities/dynticks.xml
106===================================================================
107--- /dev/null 1970-01-01 00:00:00.000000000 +0000
108+++ ltt-control-0.6-28042006/facilities/dynticks.xml 2006-06-05 18:03:41.000000000 +0100
109@@ -0,0 +1,18 @@
110+<?xml version="1.0"?>
111+<facility name="dynticks">
112+ <description>Dynamic Timer Events</description>
113+
114+ <event name="handler_entry">
115+ <description>Dynticks Handler Entered</description>
116+ </event>
117+
118+ <event name="handler_exit">
119+ <description>Dynticks Handler Exitted</description>
120+ </event>
121+
122+ <event name="reprogram">
123+ <description>Dynticks Reprogram</description>
124+ <field name="ticks"><description>Number of ticks to sleep for</description><uint size="4"></field>
125+ </event>
126+
127+</facility>
128Index: ltt-control-0.6-28042006/facilities/Makefile.am
129===================================================================
130--- ltt-control-0.6-28042006.orig/facilities/Makefile.am 2006-04-28 21:26:26.000000000 +0100
131+++ ltt-control-0.6-28042006/facilities/Makefile.am 2006-06-05 18:04:30.000000000 +0100
132@@ -1,6 +1,7 @@
133
134 EXTRA_DIST = \
135 core.xml \
136+dynticks.xml \
137 fs.xml \
138 ipc.xml \
139 kernel.xml \
140@@ -21,6 +22,7 @@
141
142 facilities_DATA = \
143 core.xml \
144+dynticks.xml \
145 fs.xml \
146 ipc.xml \
147 kernel.xml \