summaryrefslogtreecommitdiffstats
path: root/meta/packages/lirc/lirc-modules_0.8.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/lirc/lirc-modules_0.8.3.bb')
-rw-r--r--meta/packages/lirc/lirc-modules_0.8.3.bb33
1 files changed, 0 insertions, 33 deletions
diff --git a/meta/packages/lirc/lirc-modules_0.8.3.bb b/meta/packages/lirc/lirc-modules_0.8.3.bb
deleted file mode 100644
index ee1de7194e..0000000000
--- a/meta/packages/lirc/lirc-modules_0.8.3.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls."
2SECTION = "base"
3PRIORITY = "optional"
4LICENSE = "GPL"
5DEPENDS = "virtual/kernel virtual/fakeroot-native"
6PR = "r2"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/lirc/lirc-${PV}.tar.gz \
9 file://lirc_sir-sa1100.patch;patch=1"
10S = "${WORKDIR}/lirc-${PV}"
11
12inherit autotools module-base
13
14include lirc-config.inc
15
16do_compile() {
17 # ${KERNEL_LD} doesn't understand the LDFLAGS, so suppress them
18 cd drivers && oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" LDFLAGS=""
19}
20
21fakeroot do_install() {
22 oe_runmake -C drivers DESTDIR="${D}" moduledir="/lib/modules/${KERNEL_VERSION}/lirc" install
23 rm -rf ${D}/dev
24}
25
26pkg_postinst() {
27#!/bin/sh
28set -e
29if [ ! -c $D/dev/lirc ]; then mknod $D/dev/lirc c 61 0; fi
30exit 0
31}
32
33FILES_${PN} = "/lib/modules"