summaryrefslogtreecommitdiffstats
path: root/meta/packages/lirc/lirc-modules_0.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/lirc/lirc-modules_0.7.1.bb')
-rw-r--r--meta/packages/lirc/lirc-modules_0.7.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/packages/lirc/lirc-modules_0.7.1.bb b/meta/packages/lirc/lirc-modules_0.7.1.bb
new file mode 100644
index 0000000000..0bf709ee92
--- /dev/null
+++ b/meta/packages/lirc/lirc-modules_0.7.1.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls."
2SECTION = "base"
3PRIORITY = "optional"
4MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5LICENSE = "GPL"
6DEPENDS = "virtual/kernel fakeroot-native"
7PR = "r2"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/lirc/lirc-${PV}.tar.gz \
10 file://lirc_sir-sa1100.patch;patch=1"
11S = "${WORKDIR}/lirc-${PV}"
12
13inherit autotools module-base
14
15include lirc-config.inc
16
17do_compile() {
18 # ${KERNEL_LD} doesn't understand the LDFLAGS, so suppress them
19 cd drivers && oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" LDFLAGS=""
20}
21
22fakeroot do_install() {
23 oe_runmake -C drivers DESTDIR="${D}" moduledir="/lib/modules/${KERNEL_VERSION}/lirc" install
24 rm -rf ${D}/dev
25}
26
27pkg_postinst() {
28#!/bin/sh
29set -e
30if [ ! -c $D/dev/lirc ]; then mknod $D/dev/lirc c 61 0; fi
31exit 0
32}
33
34FILES_${PN} = "/lib/modules"