summaryrefslogtreecommitdiffstats
path: root/meta/packages/linux/linux-omap3-pm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/linux/linux-omap3-pm_git.bb')
-rw-r--r--meta/packages/linux/linux-omap3-pm_git.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/packages/linux/linux-omap3-pm_git.bb b/meta/packages/linux/linux-omap3-pm_git.bb
new file mode 100644
index 0000000000..86824f2558
--- /dev/null
+++ b/meta/packages/linux/linux-omap3-pm_git.bb
@@ -0,0 +1,75 @@
1DESCRIPTION = "Linux Kernel"
2SECTION = "kernel"
3LICENSE = "GPL"
4
5inherit kernel
6
7FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/${PN}-git/${MACHINE}"
8
9SRCREV = "${AUTOREV}"
10
11PV = "2.6.31-rc1+${PR}+git${SRCREV}"
12PR = "r1"
13
14SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-omap-pm.git;branch=pm;protocol=git"
15
16SRC_URI_append_zoom2 = " \
17 file://0001-OMAP3-MMC-Add-mux-for-pins.patch;patch=1 \
18 file://0002-OMAP3-Zoom2-Add-TWL4030-support.patch;patch=1 \
19 file://0003-OMAP3-Zoom2-Update-board-defconfig.patch;patch=1 \
20 file://0004-serial-8250-add-IRQ-trigger-support.patch;patch=1 \
21 file://0005-OMAP2-Zoom2-Pass-irqflags-to-8250-driver.patch;patch=1 \
22 file://0006-OMAP3-Zoom2-ext-UART-needs-plaform_device.id-3.patch;patch=1 \
23 file://0007-omap-zoom2-add-external-uart-DEBUG_LL-support-to-zoo.patch;patch=1 \
24 file://0008-omap2-add-support-for-DEBUG_LL-on-external-UART.patch;patch=1 \
25 "
26
27COMPATIBLE_MACHINE = "beagleboard|omap-3430sdp|omap3evm|overo|rx51|zoom2"
28
29S = "${WORKDIR}/git"
30
31do_configure_prepend() {
32 # logo support: if you supply logo_linux_clut224.ppm in SRC_URI,
33 # then it's going to be used instead of "Tux" in the kernel sources
34 if [ -e ${WORKDIR}/logo_linux_clut224.ppm ]; then
35 install -m 0644 ${WORKDIR}/logo_linux_clut224.ppm \
36 drivers/video/logo/logo_linux_clut224.ppm
37 fi
38
39 # use the externally-supplied ${MACHINE}_external_defconfig if present,
40 # else use omap3_pm_defconfig from the sources
41 if [ -e ${WORKDIR}/${MACHINE}_external_defconfig ]; then
42 cp ${WORKDIR}/${MACHINE}_external_defconfig ${S}/arch/arm/configs/
43 yes '' | oe_runmake ${MACHINE}_external_defconfig
44 else
45 case ${MACHINE} in
46 omap-3430sdp|omap3evm)
47 # works out of the box
48 yes '' | oe_runmake omap3_pm_defconfig
49 ;;
50 beagleboard | overo | rx51)
51 # adjust LL_DEBUG console for these boards
52 yes '' | oe_runmake omap3_pm_defconfig
53 sed -e "s/CONFIG_OMAP_LL_DEBUG_UART1=y/# CONFIG_OMAP_LL_DEBUG_UART1 is not set/" \
54 -e "s/# CONFIG_OMAP_LL_DEBUG_UART3 is not set/CONFIG_OMAP_LL_DEBUG_UART3=y/" \
55 -e "s/CONFIG_MMC_BLOCK=m/CONFIG_MMC_BLOCK=y/" \
56 -e "s/CONFIG_MMC_OMAP_HS=m/CONFIG_MMC_OMAP_HS=y/" \
57 -i ${S}/.config
58 ;;
59 zoom2)
60 # adjust LL_DEBUG console for these boards
61 yes '' | oe_runmake omap3_pm_defconfig
62 sed -e "s/CONFIG_OMAP_LL_DEBUG_UART1=y/# CONFIG_OMAP_LL_DEBUG_UART1 is not set/" \
63 -e "s/CONFIG_MMC_BLOCK=m/CONFIG_MMC_BLOCK=y/" \
64 -e "s/CONFIG_MMC_OMAP_HS=m/CONFIG_MMC_OMAP_HS=y/" \
65 -i ${S}/.config
66 echo "CONFIG_OMAP_LL_DEBUG_UART_EXT=y" >> ${S}/.config
67# yes '' | oe_runmake oldconfig
68 ;;
69 *)
70 # its worth a try...
71 yes '' | oe_runmake ${MACHINE}_defconfig
72 ;;
73 esac
74 fi
75}