summaryrefslogtreecommitdiffstats
path: root/meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb')
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb80
1 files changed, 80 insertions, 0 deletions
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
new file mode 100644
index 0000000000..28926f0264
--- /dev/null
+++ b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
@@ -0,0 +1,80 @@
1SECTION = "devel"
2DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
3# This package is derived from the original linux-libc-headers at
4# http://ep09.pld-linux.org/~mmazur/linux-libc-headers/
5# More specifically, llh-2.6.12.0 was patched up to 2.6.16-rc6 with
6# the official linux patches (where applicable) and then fixed up just
7# enough to build glibc-2.4. BEWARE!
8#
9# license note from the linux-libc-headers package:
10# Linux-libc-headers are derived from linux kernel headers. For license of a
11# particular header, check it's content, and if copyright notice isn't present,
12# standard linux kernel license applies.
13# since we assume GPL for linux i think we can also assume it here
14LICENSE = "GPL"
15DEFAULT_PREFERENCE = "-1"
16INHIBIT_DEFAULT_DEPS = "1"
17PR = "r4"
18
19SRC_URI = "http://ewi546.ewi.utwente.nl/OE/eabi/linux-libc-headers-${PV}.tar.bz2 \
20 file://keyboard.patch;patch=1 \
21 file://asm-arch-irqs.patch;patch=1 \
22 file://linux-netdevice.patch;patch=1 \
23 file://linux-netfilter_ipv4.patch;patch=1 \
24 file://linux-rtc.patch;patch=1 \
25 file://linux-videodev2.patch;patch=1 \
26 file://3477-1.patch;patch=1"
27
28S = "${WORKDIR}/linux-libc-headers-${PV}"
29
30do_configure () {
31 case ${TARGET_ARCH} in
32 alpha*) ARCH=alpha ;;
33 arm*) ARCH=arm ;;
34 cris*) ARCH=cris ;;
35 hppa*) ARCH=parisc ;;
36 i*86*) ARCH=i386 ;;
37 ia64*) ARCH=ia64 ;;
38 mips*) ARCH=mips ;;
39 m68k*) ARCH=m68k ;;
40 powerpc*) ARCH=ppc ;;
41 s390*) ARCH=s390 ;;
42 sh*) ARCH=sh ;;
43 sparc64*) ARCH=sparc64 ;;
44 sparc*) ARCH=sparc ;;
45 x86_64*) ARCH=x86_64 ;;
46 esac
47 if test ! -e include/asm-$ARCH; then
48 oefatal unable to create asm symlink in kernel headers
49 fi
50 rm "include/asm"
51 cp -pPR "include/asm-$ARCH" "include/asm"
52 if test "$ARCH" = "arm"; then
53 cp -pPR include/asm/arch-ebsa285 include/asm/arch
54 elif test "$ARCH" = "sh"; then
55 cp -pPR include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
56 fi
57}
58
59do_stage () {
60 install -d ${STAGING_INCDIR}
61 rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
62 cp -pfLR include/linux ${STAGING_INCDIR}/
63 cp -pfLR include/asm ${STAGING_INCDIR}/
64 cp -pfLR include/asm-generic ${STAGING_INCDIR}/
65 rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/linux
66 rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm
67 rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm-generic
68 install -d ${CROSS_DIR}/${TARGET_SYS}/include
69 cp -pfLR include/linux ${CROSS_DIR}/${TARGET_SYS}/include/
70 cp -pfLR include/asm ${CROSS_DIR}/${TARGET_SYS}/include/
71 cp -pfLR include/asm-generic ${CROSS_DIR}/${TARGET_SYS}/include/
72}
73
74do_install() {
75 install -d ${D}${includedir}
76 cp -pfLR include/linux ${D}${includedir}/
77 cp -pfLR include/asm ${D}${includedir}/
78 cp -pfLR include/asm-generic ${D}${includedir}/
79}
80