summaryrefslogtreecommitdiffstats
path: root/meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb')
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb58
1 files changed, 0 insertions, 58 deletions
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
deleted file mode 100644
index 3f5cc3a0b5..0000000000
--- a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
+++ /dev/null
@@ -1,58 +0,0 @@
1require linux-libc-headers.inc
2
3HOMEPAGE = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/"
4# license note from the package:
5# Linux-libc-headers are derived from linux kernel headers. For license of a
6# particular header, check it's content, and if copyright notice isn't present,
7# standard linux kernel license applies.
8# since we assume GPL for linux i think we can also assume it here
9INHIBIT_DEFAULT_DEPS = "1"
10PR = "r2"
11
12SRC_URI = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/linux-libc-headers-${PV}.tar.bz2 \
13 file://keyboard.patch;patch=1"
14
15S = "${WORKDIR}/linux-libc-headers-${PV}"
16
17do_configure () {
18 case ${TARGET_ARCH} in
19 alpha*) ARCH=alpha ;;
20 arm*) ARCH=arm ;;
21 cris*) ARCH=cris ;;
22 hppa*) ARCH=parisc ;;
23 i*86*) ARCH=i386 ;;
24 ia64*) ARCH=ia64 ;;
25 mips*) ARCH=mips ;;
26 m68k*) ARCH=m68k ;;
27 powerpc*) ARCH=ppc ;;
28 s390*) ARCH=s390 ;;
29 sh*) ARCH=sh ;;
30 sparc64*) ARCH=sparc64 ;;
31 sparc*) ARCH=sparc ;;
32 x86_64*) ARCH=x86_64 ;;
33 esac
34 if test ! -e include/asm-$ARCH; then
35 oefatal unable to create asm symlink in kernel headers
36 fi
37 cp -pPR "include/asm-$ARCH" "include/asm"
38 if test "$ARCH" = "arm"; then
39 cp -pPR include/asm/arch-ebsa285 include/asm/arch
40 elif test "$ARCH" = "sh"; then
41 cp -pPR include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
42 cp -pPR include/asm/cpu/* include/asm
43 fi
44}
45
46do_stage () {
47 install -d ${STAGING_INCDIR}
48 rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm
49 cp -pfLR include/linux ${STAGING_INCDIR}/
50 cp -pfLR include/asm ${STAGING_INCDIR}/
51}
52
53do_install() {
54 install -d ${D}${includedir}
55 cp -pfLR include/linux ${D}${includedir}/
56 cp -pfLR include/asm ${D}${includedir}/
57}
58