summaryrefslogtreecommitdiffstats
path: root/meta/packages/libxml
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libxml')
-rw-r--r--meta/packages/libxml/files/no-testapi.patch51
-rw-r--r--meta/packages/libxml/libxml2_2.6.10.bb40
-rw-r--r--meta/packages/libxml/libxml2_2.6.22.bb39
-rw-r--r--meta/packages/libxml/libxml2_cvs.bb43
4 files changed, 173 insertions, 0 deletions
diff --git a/meta/packages/libxml/files/no-testapi.patch b/meta/packages/libxml/files/no-testapi.patch
new file mode 100644
index 0000000000..15a4dea0ee
--- /dev/null
+++ b/meta/packages/libxml/files/no-testapi.patch
@@ -0,0 +1,51 @@
1--- /tmp/Makefile.am 2005-11-13 14:33:15.844432536 +0100
2+++ libxml2-2.6.22/Makefile.am 2005-11-13 14:33:25.796919528 +0100
3@@ -8,7 +8,7 @@
4
5 noinst_PROGRAMS=testSchemas testRelax testSAX testHTML testXPath testURI \
6 testThreads testC14N testAutomata testRegexp \
7- testReader testapi testModule runtest runsuite
8+ testReader testModule runtest runsuite
9
10 bin_PROGRAMS = xmllint xmlcatalog
11
12@@ -135,20 +135,9 @@
13 testdso_la_LDFLAGS = -module -rpath $(libdir)
14
15 # that one forces the rebuild when "make rebuild" is run on doc/
16-rebuild_testapi:
17- -@(if [ "$(PYTHON)" != "" ] ; then \
18- $(PYTHON) $(srcdir)/gentest.py $(srcdir) ; fi )
19
20 # that one is just to make sure it is rebuilt if missing
21 # but adding the dependances generate mess
22-testapi.c:
23- -@(if [ "$(PYTHON)" != "" ] ; then \
24- $(PYTHON) $(srcdir)/gentest.py $(srcdir) ; fi )
25-
26-testapi_SOURCES=testapi.c
27-testapi_LDFLAGS =
28-testapi_DEPENDENCIES = $(DEPS)
29-testapi_LDADD= $(LDADDS)
30
31 #testOOM_SOURCES=testOOM.c testOOMlib.h testOOMlib.c
32 #testOOM_LDFLAGS =
33@@ -169,9 +158,6 @@
34 @echo '## Go get a cup of coffee it is gonna take a while ...'
35 $(MAKE) CHECKER='valgrind' tests
36
37-APItests: testapi$(EXEEXT)
38- @echo "## Running the API regression tests this may take a little while"
39- -@($(CHECKER) $(top_builddir)/testapi -q)
40
41 HTMLtests : testHTML$(EXEEXT)
42 @(echo > .memdump)
43@@ -1116,7 +1102,7 @@
44 dist-test: distdir
45 (mkdir -p $(distdir))
46 (cd $(srcdir) ; tar -cf - --exclude CVS xstc/Tests) | (cd $(distdir); tar xf -)
47- tar -cf - $(distdir)/test $(distdir)/result $(distdir)/xstc/Tests $(distdir)/Makefile.tests $(distdir)/README $(distdir)/README.tests $(distdir)/AUTHORS $(distdir)/testapi.c $(distdir)/runtest.c $(distdir)/runsuite.c | GZIP=$(GZIP_ENV) gzip -c >`echo "$(distdir)" | sed "s+libxml2+libxml2-tests+"`.tar.gz
48+ tar -cf - $(distdir)/test $(distdir)/result $(distdir)/xstc/Tests $(distdir)/Makefile.tests $(distdir)/README $(distdir)/README.tests $(distdir)/AUTHORS $(distdir)/runtest.c $(distdir)/runsuite.c | GZIP=$(GZIP_ENV) gzip -c >`echo "$(distdir)" | sed "s+libxml2+libxml2-tests+"`.tar.gz
49 @(rm -rf $(distdir)/xstc/Test)
50
51 cleantar:
diff --git a/meta/packages/libxml/libxml2_2.6.10.bb b/meta/packages/libxml/libxml2_2.6.10.bb
new file mode 100644
index 0000000000..9f789a499e
--- /dev/null
+++ b/meta/packages/libxml/libxml2_2.6.10.bb
@@ -0,0 +1,40 @@
1PR = "r0"
2DESCRIPTION = "GNOME XML library"
3SECTION = "libs"
4PRIORITY = "optional"
5MAINTAINER = "Phil Blundell <pb@handhelds.org>"
6LICENSE = "MIT"
7PACKAGES = "${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
8
9FILES_${PN}-dev += "${bindir}/xml-config"
10FILES_${PN}-utils += "${bindir}"
11
12SRC_URI = "http://xmlsoft.org/sources/libxml2/old/libxml2-${PV}.tar.gz"
13
14inherit autotools pkgconfig
15
16EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-schemas --without-catalog --without-docbook --without-c14n"
17
18headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
19
20do_stage () {
21 oe_libinstall -so libxml2 ${STAGING_LIBDIR}
22
23 mkdir -p ${STAGING_INCDIR}/libxml2/libxml
24 for i in ${headers}; do
25 install -m 0644 include/libxml/$i ${STAGING_INCDIR}/libxml2/libxml/$i
26 done
27
28 cat xml2-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
29 -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
30 -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
31 -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/xml2-config
32 chmod a+rx ${STAGING_BINDIR}/xml2-config
33 install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
34}
35
36python populate_packages_prepend () {
37 # autonamer would call this libxml2-2, but we don't want that
38 if bb.data.getVar('DEBIAN_NAMES', d, 1):
39 bb.data.setVar('PKG_libxml2', 'libxml2', d)
40}
diff --git a/meta/packages/libxml/libxml2_2.6.22.bb b/meta/packages/libxml/libxml2_2.6.22.bb
new file mode 100644
index 0000000000..fae00a6063
--- /dev/null
+++ b/meta/packages/libxml/libxml2_2.6.22.bb
@@ -0,0 +1,39 @@
1PR = "r1"
2DESCRIPTION = "GNOME XML library"
3SECTION = "libs"
4PRIORITY = "optional"
5LICENSE = "MIT"
6PACKAGES = "${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
7
8FILES_${PN}-dev += "${bindir}/xml-config"
9FILES_${PN}-utils += "${bindir}"
10
11SRC_URI = "http://xmlsoft.org/sources/libxml2/libxml2-${PV}.tar.gz \
12 file://no-testapi.patch;patch=1"
13inherit autotools pkgconfig
14
15EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --without-c14n"
16
17headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
18
19do_stage () {
20 oe_libinstall -so libxml2 ${STAGING_LIBDIR}
21
22 mkdir -p ${STAGING_INCDIR}/libxml2/libxml
23 for i in ${headers}; do
24 install -m 0644 include/libxml/$i ${STAGING_INCDIR}/libxml2/libxml/$i
25 done
26
27 cat xml2-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
28 -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
29 -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
30 -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/xml2-config
31 chmod a+rx ${STAGING_BINDIR}/xml2-config
32 install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
33}
34
35python populate_packages_prepend () {
36 # autonamer would call this libxml2-2, but we don't want that
37 if bb.data.getVar('DEBIAN_NAMES', d, 1):
38 bb.data.setVar('PKG_libxml2', 'libxml2', d)
39}
diff --git a/meta/packages/libxml/libxml2_cvs.bb b/meta/packages/libxml/libxml2_cvs.bb
new file mode 100644
index 0000000000..29fb53fc04
--- /dev/null
+++ b/meta/packages/libxml/libxml2_cvs.bb
@@ -0,0 +1,43 @@
1DEFAULT_PREFERENCE = "-1"
2PR = "r0"
3DESCRIPTION = "GNOME XML library"
4SECTION = "libs"
5PRIORITY = "optional"
6MAINTAINER = "Phil Blundell <pb@handhelds.org>"
7LICENSE = "MIT"
8PACKAGES = "${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
9
10FILES_${PN}-dev += "${bindir}/xml-config"
11FILES_${PN}-utils += "${bindir}"
12
13PV = "2.6.23+cvs${SRCDATE}"
14S = "${WORKDIR}/${PN}"
15SRC_URI = "cvs://anonymous@anoncvs.gnome.org/cvs/gnome;module=libxml2"
16
17inherit autotools pkgconfig
18
19EXTRA_OECONF = "--without-python --without-debug --without-legacy --with-schemas --without-catalog --without-docbook --without-c14n"
20
21headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
22
23do_stage () {
24 oe_libinstall -so libxml2 ${STAGING_LIBDIR}
25
26 mkdir -p ${STAGING_INCDIR}/libxml2/libxml
27 for i in ${headers}; do
28 install -m 0644 include/libxml/$i ${STAGING_INCDIR}/libxml2/libxml/$i
29 done
30
31 cat xml2-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
32 -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
33 -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
34 -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/xml2-config
35 chmod a+rx ${STAGING_BINDIR}/xml2-config
36 install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
37}
38
39python populate_packages_prepend () {
40 # autonamer would call this libxml2-2, but we don't want that
41 if bb.data.getVar('DEBIAN_NAMES', d, 1):
42 bb.data.setVar('PKG_libxml2', 'libxml2', d)
43}