diff options
Diffstat (limited to 'meta/packages/libxml/libxml2_2.6.29.bb')
-rw-r--r-- | meta/packages/libxml/libxml2_2.6.29.bb | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/packages/libxml/libxml2_2.6.29.bb b/meta/packages/libxml/libxml2_2.6.29.bb new file mode 100644 index 0000000000..12fb6ca08e --- /dev/null +++ b/meta/packages/libxml/libxml2_2.6.29.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | DESCRIPTION = "GNOME XML Parser library" | ||
2 | SECTION = "libs" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "MIT" | ||
5 | PR = "r4" | ||
6 | |||
7 | SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz" | ||
8 | |||
9 | inherit autotools pkgconfig binconfig | ||
10 | |||
11 | EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n" | ||
12 | |||
13 | export LDFLAGS += "-ldl" | ||
14 | |||
15 | do_stage() { | ||
16 | autotools_stage_all | ||
17 | install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/ | ||
18 | #this is need it by php during its install | ||
19 | install -m 0755 xml2-config ${STAGING_BINDIR} | ||
20 | } | ||
21 | |||
22 | python populate_packages_prepend () { | ||
23 | # autonamer would call this libxml2-2, but we don't want that | ||
24 | if bb.data.getVar('DEBIAN_NAMES', d, 1): | ||
25 | bb.data.setVar('PKG_libxml2', 'libxml2', d) | ||
26 | } | ||
27 | |||
28 | PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale" | ||
29 | |||
30 | FILES_${PN}-dev += "${bindir}/*-config" | ||
31 | FILES_${PN}-utils += "${bindir}/*" | ||