summaryrefslogtreecommitdiffstats
path: root/meta/packages/libxml/libxml2_2.6.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libxml/libxml2_2.6.22.bb')
-rw-r--r--meta/packages/libxml/libxml2_2.6.22.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/packages/libxml/libxml2_2.6.22.bb b/meta/packages/libxml/libxml2_2.6.22.bb
new file mode 100644
index 0000000000..fae00a6063
--- /dev/null
+++ b/meta/packages/libxml/libxml2_2.6.22.bb
@@ -0,0 +1,39 @@
1PR = "r1"
2DESCRIPTION = "GNOME XML library"
3SECTION = "libs"
4PRIORITY = "optional"
5LICENSE = "MIT"
6PACKAGES = "${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
7
8FILES_${PN}-dev += "${bindir}/xml-config"
9FILES_${PN}-utils += "${bindir}"
10
11SRC_URI = "http://xmlsoft.org/sources/libxml2/libxml2-${PV}.tar.gz \
12 file://no-testapi.patch;patch=1"
13inherit autotools pkgconfig
14
15EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --without-c14n"
16
17headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
18
19do_stage () {
20 oe_libinstall -so libxml2 ${STAGING_LIBDIR}
21
22 mkdir -p ${STAGING_INCDIR}/libxml2/libxml
23 for i in ${headers}; do
24 install -m 0644 include/libxml/$i ${STAGING_INCDIR}/libxml2/libxml/$i
25 done
26
27 cat xml2-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
28 -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
29 -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
30 -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/xml2-config
31 chmod a+rx ${STAGING_BINDIR}/xml2-config
32 install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
33}
34
35python populate_packages_prepend () {
36 # autonamer would call this libxml2-2, but we don't want that
37 if bb.data.getVar('DEBIAN_NAMES', d, 1):
38 bb.data.setVar('PKG_libxml2', 'libxml2', d)
39}