summaryrefslogtreecommitdiffstats
path: root/meta/packages/libxml/files/no-testapi.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libxml/files/no-testapi.patch')
-rw-r--r--meta/packages/libxml/files/no-testapi.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/packages/libxml/files/no-testapi.patch b/meta/packages/libxml/files/no-testapi.patch
new file mode 100644
index 0000000000..15a4dea0ee
--- /dev/null
+++ b/meta/packages/libxml/files/no-testapi.patch
@@ -0,0 +1,51 @@
1--- /tmp/Makefile.am 2005-11-13 14:33:15.844432536 +0100
2+++ libxml2-2.6.22/Makefile.am 2005-11-13 14:33:25.796919528 +0100
3@@ -8,7 +8,7 @@
4
5 noinst_PROGRAMS=testSchemas testRelax testSAX testHTML testXPath testURI \
6 testThreads testC14N testAutomata testRegexp \
7- testReader testapi testModule runtest runsuite
8+ testReader testModule runtest runsuite
9
10 bin_PROGRAMS = xmllint xmlcatalog
11
12@@ -135,20 +135,9 @@
13 testdso_la_LDFLAGS = -module -rpath $(libdir)
14
15 # that one forces the rebuild when "make rebuild" is run on doc/
16-rebuild_testapi:
17- -@(if [ "$(PYTHON)" != "" ] ; then \
18- $(PYTHON) $(srcdir)/gentest.py $(srcdir) ; fi )
19
20 # that one is just to make sure it is rebuilt if missing
21 # but adding the dependances generate mess
22-testapi.c:
23- -@(if [ "$(PYTHON)" != "" ] ; then \
24- $(PYTHON) $(srcdir)/gentest.py $(srcdir) ; fi )
25-
26-testapi_SOURCES=testapi.c
27-testapi_LDFLAGS =
28-testapi_DEPENDENCIES = $(DEPS)
29-testapi_LDADD= $(LDADDS)
30
31 #testOOM_SOURCES=testOOM.c testOOMlib.h testOOMlib.c
32 #testOOM_LDFLAGS =
33@@ -169,9 +158,6 @@
34 @echo '## Go get a cup of coffee it is gonna take a while ...'
35 $(MAKE) CHECKER='valgrind' tests
36
37-APItests: testapi$(EXEEXT)
38- @echo "## Running the API regression tests this may take a little while"
39- -@($(CHECKER) $(top_builddir)/testapi -q)
40
41 HTMLtests : testHTML$(EXEEXT)
42 @(echo > .memdump)
43@@ -1116,7 +1102,7 @@
44 dist-test: distdir
45 (mkdir -p $(distdir))
46 (cd $(srcdir) ; tar -cf - --exclude CVS xstc/Tests) | (cd $(distdir); tar xf -)
47- tar -cf - $(distdir)/test $(distdir)/result $(distdir)/xstc/Tests $(distdir)/Makefile.tests $(distdir)/README $(distdir)/README.tests $(distdir)/AUTHORS $(distdir)/testapi.c $(distdir)/runtest.c $(distdir)/runsuite.c | GZIP=$(GZIP_ENV) gzip -c >`echo "$(distdir)" | sed "s+libxml2+libxml2-tests+"`.tar.gz
48+ tar -cf - $(distdir)/test $(distdir)/result $(distdir)/xstc/Tests $(distdir)/Makefile.tests $(distdir)/README $(distdir)/README.tests $(distdir)/AUTHORS $(distdir)/runtest.c $(distdir)/runsuite.c | GZIP=$(GZIP_ENV) gzip -c >`echo "$(distdir)" | sed "s+libxml2+libxml2-tests+"`.tar.gz
49 @(rm -rf $(distdir)/xstc/Test)
50
51 cleantar: