summaryrefslogtreecommitdiffstats
path: root/meta/packages/libvorbis/libvorbis_1.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libvorbis/libvorbis_1.0.1.bb')
-rw-r--r--meta/packages/libvorbis/libvorbis_1.0.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/packages/libvorbis/libvorbis_1.0.1.bb b/meta/packages/libvorbis/libvorbis_1.0.1.bb
new file mode 100644
index 0000000000..8a2d17a0ad
--- /dev/null
+++ b/meta/packages/libvorbis/libvorbis_1.0.1.bb
@@ -0,0 +1,32 @@
1SECTION = "libs"
2DEPENDS = "libogg"
3DESCRIPTION = "Ogg Vorbis is a high-quality lossy audio codec \
4that is free of intellectual property restrictions. libvorbis \
5is the main vorbis codec library."
6LICENSE = "BSD"
7PR = "r2"
8
9SRC_URI = "http://www.vorbis.com/files/${PV}/unix/libvorbis-${PV}.tar.gz \
10file://m4.patch;patch=1"
11
12inherit autotools pkgconfig
13
14# vorbisfile.c reveals a problem in the gcc register spilling for the
15# thumb instruction set...
16FULL_OPTIMIZATION_thumb = "-O0"
17
18EXTRA_OECONF = "--with-ogg-libraries=${STAGING_LIBDIR} \
19 --with-ogg-includes=${STAGING_INCDIR}"
20
21do_stage () {
22 oe_libinstall -a -so -C lib libvorbis ${STAGING_LIBDIR}
23 oe_libinstall -a -so -C lib libvorbisfile ${STAGING_LIBDIR}
24 oe_libinstall -a -so -C lib libvorbisenc ${STAGING_LIBDIR}
25
26 install -d ${STAGING_INCDIR}/vorbis
27 install -m 0644 include/vorbis/vorbisenc.h \
28 include/vorbis/vorbisfile.h \
29 include/vorbis/codec.h ${STAGING_INCDIR}/vorbis/
30 install -d ${STAGING_DATADIR}/aclocal
31 install -m 0644 vorbis.m4 ${STAGING_DATADIR}/aclocal/
32}