summaryrefslogtreecommitdiffstats
path: root/meta/packages/libtool/libtool_1.5.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libtool/libtool_1.5.10.bb')
-rw-r--r--meta/packages/libtool/libtool_1.5.10.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/packages/libtool/libtool_1.5.10.bb b/meta/packages/libtool/libtool_1.5.10.bb
new file mode 100644
index 0000000000..1202279524
--- /dev/null
+++ b/meta/packages/libtool/libtool_1.5.10.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "Generic library support script \
2This is GNU libtool, a generic library support script. Libtool hides \
3the complexity of generating special library types (such as shared \
4libraries) behind a consistent interface."
5HOMEPAGE = "http://www.gnu.org/software/libtool/libtool.html"
6LICENSE = "GPL"
7SECTION = "devel"
8PR = "r3"
9
10SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
11 file://autotools.patch;patch=1 \
12 file://uclibc.patch;patch=1 \
13 file://3figures.patch;patch=1"
14S = "${WORKDIR}/libtool-${PV}"
15
16PACKAGES = "libltdl libltdl-dev ${PN}"
17FILES_${PN} += "${datadir}/aclocal*"
18FILES_libltdl = "${libdir}/libltdl.so.*"
19FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h"
20
21inherit autotools
22
23EXTRA_AUTORECONF = "--exclude=libtoolize"
24
25do_configure () {
26 find ${S} -name acinclude.m4 | for m4 in `cat`; do
27 cat ${S}/libtool.m4 ${S}/ltdl.m4 > $m4
28 done
29 autotools_do_configure
30}
31
32do_stage () {
33 oe_libinstall -a -so -C libltdl libltdl ${STAGING_LIBDIR}
34 install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/
35}