diff options
Diffstat (limited to 'meta/packages/libtool/libtool-2.2.6/prefix.patch')
-rw-r--r-- | meta/packages/libtool/libtool-2.2.6/prefix.patch | 103 |
1 files changed, 103 insertions, 0 deletions
diff --git a/meta/packages/libtool/libtool-2.2.6/prefix.patch b/meta/packages/libtool/libtool-2.2.6/prefix.patch new file mode 100644 index 0000000000..639feb7456 --- /dev/null +++ b/meta/packages/libtool/libtool-2.2.6/prefix.patch | |||
@@ -0,0 +1,103 @@ | |||
1 | Renames "libtool" -> "${TARGET_PREFIX}libtool" which makes sure | ||
2 | it can't be confused with the host libtool. | ||
3 | |||
4 | Index: libtool-2.2.2/libltdl/m4/libtool.m4 | ||
5 | =================================================================== | ||
6 | --- libtool-2.2.2.orig/libltdl/m4/libtool.m4 2008-04-13 22:43:05.000000000 +0100 | ||
7 | +++ libtool-2.2.2/libltdl/m4/libtool.m4 2008-04-13 22:43:05.000000000 +0100 | ||
8 | @@ -89,7 +89,8 @@ | ||
9 | LIBTOOL_DEPS="$ltmain" | ||
10 | |||
11 | # Always use our own libtool. | ||
12 | -LIBTOOL='$(SHELL) $(top_builddir)/libtool' | ||
13 | +LIBTOOL='$(SHELL) $(top_builddir)' | ||
14 | +LIBTOOL="$LIBTOOL/$host_alias-libtool" | ||
15 | AC_SUBST(LIBTOOL)dnl | ||
16 | |||
17 | _LT_SETUP | ||
18 | @@ -211,7 +212,7 @@ | ||
19 | no_glob_subst='s/\*/\\\*/g' | ||
20 | |||
21 | # Global variables: | ||
22 | -ofile=libtool | ||
23 | +ofile=${host_alias}-libtool | ||
24 | can_build_shared=yes | ||
25 | |||
26 | # All known linkers require a `.a' archive for static linking (except MSVC, | ||
27 | Index: libtool-2.2.2/Makefile.am | ||
28 | =================================================================== | ||
29 | --- libtool-2.2.2.orig/Makefile.am 2008-04-01 19:06:08.000000000 +0100 | ||
30 | +++ libtool-2.2.2/Makefile.am 2008-04-13 22:49:17.000000000 +0100 | ||
31 | @@ -31,7 +31,7 @@ | ||
32 | DIST_SUBDIRS = . | ||
33 | EXTRA_DIST = | ||
34 | |||
35 | -BUILT_SOURCES = libtool | ||
36 | +BUILT_SOURCES = $(host_alias)-libtool | ||
37 | |||
38 | CLEANFILES = | ||
39 | MOSTLYCLEANFILES = | ||
40 | @@ -64,7 +64,7 @@ | ||
41 | ## ---------------- ## | ||
42 | |||
43 | # The libtool distributor and the standalone libtool script. | ||
44 | -bin_SCRIPTS = libtoolize libtool | ||
45 | +bin_SCRIPTS = libtoolize $(host_alias)-libtool | ||
46 | |||
47 | libtoolize: $(srcdir)/libtoolize.in $(top_builddir)/config.status | ||
48 | rm -f libtoolize.tmp libtoolize | ||
49 | @@ -90,8 +90,8 @@ | ||
50 | # We used to do this with a 'stamp-vcl' file, but non-gmake builds | ||
51 | # would rerun configure on every invocation, so now we manually | ||
52 | # check the version numbers from the build rule when necessary. | ||
53 | -libtool: $(top_builddir)/config.status $(srcdir)/$(auxdir)/ltmain.sh ChangeLog | ||
54 | - @target=libtool; $(rebuild); \ | ||
55 | +$(host_alias)-libtool: $(top_builddir)/config.status $(srcdir)/$(auxdir)/ltmain.sh ChangeLog | ||
56 | + @target=$(host_alias)-libtool; $(rebuild); \ | ||
57 | if test -f "$$target"; then \ | ||
58 | set dummy `./$$target --version | sed 1q`; actualver="$$5"; \ | ||
59 | test "$$actualver" = "$$correctver" && rebuild=false; \ | ||
60 | @@ -100,8 +100,8 @@ | ||
61 | case $$prereq in *ChangeLog);; *) rebuild=:;; esac; \ | ||
62 | done; \ | ||
63 | if $$rebuild; then \ | ||
64 | - echo $(SHELL) ./config.status $$target; \ | ||
65 | - cd $(top_builddir) && $(SHELL) ./config.status $$target; \ | ||
66 | + echo $(SHELL) ./config.status libtool; \ | ||
67 | + cd $(top_builddir) && $(SHELL) ./config.status libtool; \ | ||
68 | fi | ||
69 | |||
70 | .PHONY: configure-subdirs | ||
71 | @@ -145,7 +145,7 @@ | ||
72 | ChangeLog.1999 ChangeLog.2000 ChangeLog.2001 \ | ||
73 | ChangeLog.2002 ChangeLog.2003 ChangeLog.2004 \ | ||
74 | ChangeLog.2005 ChangeLog.2006 ChangeLog.2007 | ||
75 | -CLEANFILES += libtool libtoolize libtoolize.tmp \ | ||
76 | +CLEANFILES += $(host_alias)-libtool libtoolize libtoolize.tmp \ | ||
77 | $(auxdir)/ltmain.tmp $(m4dir)/ltversion.tmp | ||
78 | |||
79 | ## We build ltversion.m4 here, instead of from config.status, | ||
80 | @@ -483,12 +483,12 @@ | ||
81 | |||
82 | BUILDCHECK_ENVIRONMENT = _lt_pkgdatadir="$(abs_top_srcdir)" \ | ||
83 | LIBTOOLIZE="$(abs_top_builddir)/libtoolize" \ | ||
84 | - LIBTOOL="$(abs_top_builddir)/libtool" \ | ||
85 | + LIBTOOL="$(abs_top_builddir)/$(host_alias)-libtool" \ | ||
86 | tst_aclocaldir="$(abs_top_srcdir)/libltdl/m4" | ||
87 | |||
88 | INSTALLCHECK_ENVIRONMENT = \ | ||
89 | LIBTOOLIZE="$(bindir)/`echo libtoolize | sed '$(program_transform_name)'`" \ | ||
90 | - LIBTOOL="$(bindir)/`echo libtool | sed '$(program_transform_name)'`" \ | ||
91 | + LIBTOOL="$(bindir)/`echo $(host_alias)-libtool | sed '$(program_transform_name)'`" \ | ||
92 | LTDLINCL="-I$(includedir)" \ | ||
93 | LIBLTDL="$(libdir)/libltdl.la" \ | ||
94 | tst_aclocaldir="$(aclocaldir)" | ||
95 | @@ -620,7 +620,7 @@ | ||
96 | TESTS += $(FC_TESTS) | ||
97 | endif | ||
98 | |||
99 | -tests/demo-conf.test: libtool | ||
100 | +tests/demo-conf.test: $(host_alias)-libtool | ||
101 | |||
102 | EXTRA_DIST += $(srcdir)/tests/defs.in tests/defs.m4sh \ | ||
103 | $(COMMON_TESTS) $(CXX_TESTS) $(F77_TESTS) $(FC_TESTS) | ||