summaryrefslogtreecommitdiffstats
path: root/meta/packages/libtool/libtool-1.5.10
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libtool/libtool-1.5.10')
-rw-r--r--meta/packages/libtool/libtool-1.5.10/3figures.patch29
-rw-r--r--meta/packages/libtool/libtool-1.5.10/autotools.patch127
-rw-r--r--meta/packages/libtool/libtool-1.5.10/install-path-check.patch25
-rw-r--r--meta/packages/libtool/libtool-1.5.10/libdir-la.patch52
-rw-r--r--meta/packages/libtool/libtool-1.5.10/prefix.patch40
-rw-r--r--meta/packages/libtool/libtool-1.5.10/sedvar.patch16
-rw-r--r--meta/packages/libtool/libtool-1.5.10/tag.patch19
-rw-r--r--meta/packages/libtool/libtool-1.5.10/tag1.patch13
-rw-r--r--meta/packages/libtool/libtool-1.5.10/uclibc.patch19
9 files changed, 340 insertions, 0 deletions
diff --git a/meta/packages/libtool/libtool-1.5.10/3figures.patch b/meta/packages/libtool/libtool-1.5.10/3figures.patch
new file mode 100644
index 0000000000..6f632fbe7d
--- /dev/null
+++ b/meta/packages/libtool/libtool-1.5.10/3figures.patch
@@ -0,0 +1,29 @@
1--- /tmp/ltmain.in 2005-07-24 18:52:11.867735112 +0200
2+++ libtool-1.5.10/ltmain.in 2005-07-24 18:55:49.204694872 +0200
3@@ -3101,7 +3101,7 @@
4
5 # Check that each of the things are valid numbers.
6 case $current in
7- 0 | [1-9] | [1-9][0-9] | [1-9][0-9][0-9]) ;;
8+ 0 | [1-9] | [1-9][0-9]*) ;;
9 *)
10 $echo "$modename: CURRENT \`$current' is not a nonnegative integer" 1>&2
11 $echo "$modename: \`$vinfo' is not valid version information" 1>&2
12@@ -3110,7 +3110,7 @@
13 esac
14
15 case $revision in
16- 0 | [1-9] | [1-9][0-9] | [1-9][0-9][0-9]) ;;
17+ 0 | [1-9] | [1-9][0-9]*) ;;
18 *)
19 $echo "$modename: REVISION \`$revision' is not a nonnegative integer" 1>&2
20 $echo "$modename: \`$vinfo' is not valid version information" 1>&2
21@@ -3119,7 +3119,7 @@
22 esac
23
24 case $age in
25- 0 | [1-9] | [1-9][0-9] | [1-9][0-9][0-9]) ;;
26+ 0 | [1-9] | [1-9][0-9]*) ;;
27 *)
28 $echo "$modename: AGE \`$age' is not a nonnegative integer" 1>&2
29 $echo "$modename: \`$vinfo' is not valid version information" 1>&2
diff --git a/meta/packages/libtool/libtool-1.5.10/autotools.patch b/meta/packages/libtool/libtool-1.5.10/autotools.patch
new file mode 100644
index 0000000000..5df441e945
--- /dev/null
+++ b/meta/packages/libtool/libtool-1.5.10/autotools.patch
@@ -0,0 +1,127 @@
1diff -urNd -urNd libtool-1.5/cdemo/configure.ac libtool-1.5.ac/cdemo/configure.ac
2--- libtool-1.5/cdemo/configure.ac 2001-10-06 11:35:17.000000000 -0400
3+++ libtool-1.5.ac/cdemo/configure.ac 2004-05-05 17:16:17.000000000 -0400
4@@ -24,6 +24,7 @@
5 ## ------------------------ ##
6 AC_INIT([cdemo], [0.1], [bug-libtool@gnu.org])
7 AC_CONFIG_SRCDIR([main.c])
8+AC_CONFIG_AUX_DIR([..])
9
10
11 ## ------------------------ ##
12diff -urNd -urNd libtool-1.5/demo/configure.ac libtool-1.5.ac/demo/configure.ac
13--- libtool-1.5/demo/configure.ac 2002-03-02 22:19:55.000000000 -0500
14+++ libtool-1.5.ac/demo/configure.ac 2004-05-05 17:16:17.000000000 -0400
15@@ -24,6 +24,7 @@
16 ## ------------------------ ##
17 AC_INIT([demo], [1.0], [bug-libtool@gnu.org])
18 AC_CONFIG_SRCDIR([hello.c])
19+AC_CONFIG_AUX_DIR([..])
20
21
22 ## ------------------------ ##
23diff -urNd -urNd libtool-1.5/demo/Makefile.am libtool-1.5.ac/demo/Makefile.am
24--- libtool-1.5/demo/Makefile.am 2002-11-19 04:42:39.000000000 -0500
25+++ libtool-1.5.ac/demo/Makefile.am 2004-05-05 17:17:34.000000000 -0400
26@@ -121,17 +121,16 @@
27
28 # This is one of the essential tests for deplibs_check_method=pass_all.
29 # If this one passes with pass_all, it is likely that pass_all works
30-EXTRA_LIBRARIES = libhell0.a
31-libhell0_a_SOURCES = hello.c foo.c
32-EXTRA_LTLIBRARIES = libhell1.la libhell2.la
33+EXTRA_LTLIBRARIES = libhell0.la libhell1.la libhell2.la
34+libhell0_la_SOURCES = hello.c foo.c
35 libhell1_la_SOURCES = hell1.c
36 libhell1_la_LIBADD = -L. -lhell0
37 libhell1_la_LDFLAGS = -no-undefined -rpath $(libdir)
38-libhell1_la_DEPENDENCIES = libhell0.a
39+libhell1_la_DEPENDENCIES = libhell0.la
40 libhell2_la_SOURCES = hell2.c
41 libhell2_la_LIBADD = -L. -lhell0
42 libhell2_la_LDFLAGS = -no-undefined -rpath $(libdir)
43-libhell2_la_DEPENDENCIES = libhell0.a
44+libhell2_la_DEPENDENCIES = libhell0.la
45 EXTRA_PROGRAMS = hell0
46 hell0_SOURCES = main.c
47 hell0_LDADD = libhell1.la libhell2.la $(LIBM)
48diff -urNd -urNd libtool-1.5/depdemo/configure.ac libtool-1.5.ac/depdemo/configure.ac
49--- libtool-1.5/depdemo/configure.ac 2002-10-22 15:29:28.000000000 -0400
50+++ libtool-1.5.ac/depdemo/configure.ac 2004-05-05 17:16:17.000000000 -0400
51@@ -24,6 +24,7 @@
52 ## ------------------------ ##
53 AC_INIT([depdemo], [0.1], [bug-libtool@gnu.org])
54 AC_CONFIG_SRCDIR([main.c])
55+AC_CONFIG_AUX_DIR([..])
56
57
58 ## ------------------------ ##
59diff -urNd -urNd libtool-1.5/f77demo/configure.ac libtool-1.5.ac/f77demo/configure.ac
60--- libtool-1.5/f77demo/configure.ac 2003-03-22 01:34:27.000000000 -0500
61+++ libtool-1.5.ac/f77demo/configure.ac 2004-05-05 17:16:17.000000000 -0400
62@@ -23,6 +23,7 @@
63 ## ------------------------ ##
64 AC_INIT([f77demo], [0.1], [bug-libtool@gnu.org])
65 AC_CONFIG_SRCDIR([foof.f])dnl
66+AC_CONFIG_AUX_DIR([..])
67
68 ## ------------------------ ##
69 ## Automake Initialisation. ##
70diff -urNd -urNd libtool-1.5/mdemo/configure.ac libtool-1.5.ac/mdemo/configure.ac
71--- libtool-1.5/mdemo/configure.ac 2001-10-06 11:35:17.000000000 -0400
72+++ libtool-1.5.ac/mdemo/configure.ac 2004-05-05 17:16:17.000000000 -0400
73@@ -24,6 +24,7 @@
74 ## ------------------------ ##
75 AC_INIT([mdemo], [0.1], [bug-libtool@gnu.org])
76 AC_CONFIG_SRCDIR([main.c])
77+AC_CONFIG_AUX_DIR([..])
78
79
80 ## ------------------------ ##
81diff -urNd -urNd libtool-1.5/pdemo/configure.ac libtool-1.5.ac/pdemo/configure.ac
82--- libtool-1.5/pdemo/configure.ac 2001-10-06 11:35:17.000000000 -0400
83+++ libtool-1.5.ac/pdemo/configure.ac 2004-05-05 17:16:17.000000000 -0400
84@@ -24,6 +24,7 @@
85 ## ------------------------ ##
86 AC_INIT([pdemo], [0.1], [bug-libtool@gnu.org])
87 AC_CONFIG_SRCDIR([longer_file_name_hello.c])
88+AC_CONFIG_AUX_DIR([..])
89
90
91 ## ------------------------ ##
92diff -urNd -urNd libtool-1.5/pdemo/Makefile.am libtool-1.5.ac/pdemo/Makefile.am
93--- libtool-1.5/pdemo/Makefile.am 2002-11-19 04:42:39.000000000 -0500
94+++ libtool-1.5.ac/pdemo/Makefile.am 2004-05-05 17:17:59.000000000 -0400
95@@ -121,17 +121,16 @@
96
97 # This is one of the essential tests for deplibs_check_method=pass_all.
98 # If this one passes with pass_all, it is likely that pass_all works
99-EXTRA_LIBRARIES = libhell0.a
100-libhell0_a_SOURCES = longer_file_name_hello.c longer_file_name_foo.c
101-EXTRA_LTLIBRARIES = libhell1.la libhell2.la
102+libhell0_la_SOURCES = longer_file_name_hello.c longer_file_name_foo.c
103+EXTRA_LTLIBRARIES = libhell0.la libhell1.la libhell2.la
104 libhell1_la_SOURCES = longer_file_name_hell1.c
105 libhell1_la_LIBADD = -L. -lhell0
106 libhell1_la_LDFLAGS = -no-undefined -rpath $(libdir)
107-libhell1_la_DEPENDENCIES = libhell0.a
108+libhell1_la_DEPENDENCIES = libhell0.la
109 libhell2_la_SOURCES = longer_file_name_hell2.c
110 libhell2_la_LIBADD = -L. -lhell0
111 libhell2_la_LDFLAGS = -no-undefined -rpath $(libdir)
112-libhell2_la_DEPENDENCIES = libhell0.a
113+libhell2_la_DEPENDENCIES = libhell0.la
114 EXTRA_PROGRAMS = hell0
115 hell0_SOURCES = longer_file_name_main.c
116 hell0_LDADD = libhell1.la libhell2.la $(LIBM)
117diff -urNd -urNd libtool-1.5/tagdemo/configure.ac libtool-1.5.ac/tagdemo/configure.ac
118--- libtool-1.5/tagdemo/configure.ac 2001-10-06 11:35:17.000000000 -0400
119+++ libtool-1.5.ac/tagdemo/configure.ac 2004-05-05 17:16:17.000000000 -0400
120@@ -24,6 +24,7 @@
121 ## ------------------------ ##
122 AC_INIT([tagdemo], [0.1], [bug-libtool@gnu.org])
123 AC_CONFIG_SRCDIR([foo.cpp])
124+AC_CONFIG_AUX_DIR([..])
125
126 AC_CANONICAL_TARGET
127
diff --git a/meta/packages/libtool/libtool-1.5.10/install-path-check.patch b/meta/packages/libtool/libtool-1.5.10/install-path-check.patch
new file mode 100644
index 0000000000..46cc960986
--- /dev/null
+++ b/meta/packages/libtool/libtool-1.5.10/install-path-check.patch
@@ -0,0 +1,25 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6--- libtool-1.5.6/ltmain.in~install-path-check 2004-05-14 22:56:19.000000000 -0500
7+++ libtool-1.5.6/ltmain.in 2004-05-14 22:57:48.000000000 -0500
8@@ -5503,10 +5503,13 @@
9 # At present, this check doesn't affect windows .dll's that
10 # are installed into $libdir/../bin (currently, that works fine)
11 # but it's something to keep an eye on.
12- if test "$inst_prefix_dir" = "$destdir"; then
13- $echo "$modename: error: cannot install \`$file' to a directory not ending in $libdir" 1>&2
14- exit $EXIT_FAILURE
15- fi
16+ #
17+ # This breaks install into our staging area. -PB
18+ #
19+ # if test "$inst_prefix_dir" = "$destdir"; then
20+ # $echo "$modename: error: cannot install \`$file' to a directory not ending in $libdir" 1>&2
21+ # exit $EXIT_FAILURE
22+ # fi
23
24 if test -n "$inst_prefix_dir"; then
25 # Stick the inst_prefix_dir data into the link command.
diff --git a/meta/packages/libtool/libtool-1.5.10/libdir-la.patch b/meta/packages/libtool/libtool-1.5.10/libdir-la.patch
new file mode 100644
index 0000000000..47aae4c7af
--- /dev/null
+++ b/meta/packages/libtool/libtool-1.5.10/libdir-la.patch
@@ -0,0 +1,52 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6--- libtool-1.5.6/ltmain.in~libdir-la 2004-04-01 21:46:15.000000000 -0600
7+++ libtool-1.5.6/ltmain.in 2004-05-14 22:53:51.000000000 -0500
8@@ -2147,8 +2147,14 @@
9 absdir="$abs_ladir"
10 libdir="$abs_ladir"
11 else
12- dir="$libdir"
13- absdir="$libdir"
14+ # Adding 'libdir' from the .la file to our library search paths
15+ # breaks crosscompilation horribly. We cheat here and don't add
16+ # it, instead adding the path where we found the .la. -CL
17+ dir="$abs_ladir"
18+ absdir="$abs_ladir"
19+ libdir="$abs_ladir"
20+ #dir="$libdir"
21+ #absdir="$libdir"
22 fi
23 else
24 dir="$ladir/$objdir"
25@@ -2615,6 +2621,16 @@
26 esac
27 if grep "^installed=no" $deplib > /dev/null; then
28 path="$absdir/$objdir"
29+# This interferes with crosscompilation. -CL
30+# else
31+# eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
32+# if test -z "$libdir"; then
33+# $echo "$modename: \`$deplib' is not a valid libtool archive" 1>&2
34+# exit 1
35+# fi
36+# if test "$absdir" != "$libdir"; then
37+# $echo "$modename: warning: \`$deplib' seems to be moved" 1>&2
38+# fi
39 else
40 eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
41 if test -z "$libdir"; then
42@@ -5165,6 +5181,10 @@
43 # Replace all uninstalled libtool libraries with the installed ones
44 newdependency_libs=
45 for deplib in $dependency_libs; do
46+ # Replacing uninstalled with installed can easily break crosscompilation,
47+ # since the installed path is generally the wrong architecture. -CL
48+ newdependency_libs="$newdependency_libs $deplib"
49+ continue
50 case $deplib in
51 *.la)
52 name=`$echo "X$deplib" | $Xsed -e 's%^.*/%%'`
diff --git a/meta/packages/libtool/libtool-1.5.10/prefix.patch b/meta/packages/libtool/libtool-1.5.10/prefix.patch
new file mode 100644
index 0000000000..fa30d02f26
--- /dev/null
+++ b/meta/packages/libtool/libtool-1.5.10/prefix.patch
@@ -0,0 +1,40 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6--- libtool-1.5.6/libtool.m4~prefix.patch 2004-05-14 23:02:28.000000000 -0500
7+++ libtool-1.5.6/libtool.m4 2004-05-14 23:02:34.000000000 -0500
8@@ -82,7 +82,8 @@
9 LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
10
11 # Always use our own libtool.
12-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
13+LIBTOOL='$(SHELL) $(top_builddir)'
14+LIBTOOL="$LIBTOOL/$host_alias-libtool"
15 AC_SUBST(LIBTOOL)dnl
16
17 # Prevent multiple expansion
18@@ -149,7 +150,7 @@
19 rm="rm -f"
20
21 # Global variables:
22-default_ofile=libtool
23+default_ofile=${host_alias}-libtool
24 can_build_shared=yes
25
26 # All known linkers require a `.a' archive for static linking (except M$VC,
27--- libtool-1.5.6/Makefile.am~prefix.patch 2004-04-11 00:07:06.000000000 -0500
28+++ libtool-1.5.6/Makefile.am 2004-05-14 23:02:46.000000000 -0500
29@@ -30,9 +30,9 @@
30 aclocal_DATA = $(aclocal_macros)
31
32 # The standalone libtool script, and the libtool distributor.
33-bin_SCRIPTS = libtool libtoolize
34+bin_SCRIPTS = $(host_alias)-libtool libtoolize
35
36-libtool: $(srcdir)/ltmain.sh $(top_builddir)/configure.ac
37+$(host_alias)-libtool: $(srcdir)/ltmain.sh $(top_builddir)/configure.ac
38 $(SHELL) $(top_builddir)/config.status --recheck
39 chmod +x $@
40
diff --git a/meta/packages/libtool/libtool-1.5.10/sedvar.patch b/meta/packages/libtool/libtool-1.5.10/sedvar.patch
new file mode 100644
index 0000000000..d505edae24
--- /dev/null
+++ b/meta/packages/libtool/libtool-1.5.10/sedvar.patch
@@ -0,0 +1,16 @@
1
2#
3# Made by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6--- libtool-1.5/ltmain.in~sedvar 2003-04-14 16:58:24.000000000 -0500
7+++ libtool-1.5/ltmain.in 2003-09-24 14:18:50.175518400 -0500
8@@ -48,6 +48,8 @@
9 exit 0
10 fi
11
12+[ -z "${SED}" ] && SED=sed
13+
14 # The name of this program.
15 progname=`$echo "$0" | ${SED} 's%^.*/%%'`
16 modename="$progname"
diff --git a/meta/packages/libtool/libtool-1.5.10/tag.patch b/meta/packages/libtool/libtool-1.5.10/tag.patch
new file mode 100644
index 0000000000..8921a3efb7
--- /dev/null
+++ b/meta/packages/libtool/libtool-1.5.10/tag.patch
@@ -0,0 +1,19 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6--- libtool-1.5.6/ltmain.in~tag 2004-05-15 05:14:32.000000000 -0400
7+++ libtool-1.5.6/ltmain.in 2004-05-15 05:18:01.000000000 -0400
8@@ -226,8 +226,9 @@
9 # line option must be used.
10 if test -z "$tagname"; then
11 $echo "$modename: unable to infer tagged configuration"
12- $echo "$modename: specify a tag with \`--tag'" 1>&2
13- exit $EXIT_FAILURE
14+ $echo "$modename: defaulting to \`CC'"
15+ $echo "$modename: if this is not correct, specify a tag with \`--tag'"
16+# exit $EXIT_FAILURE
17 # else
18 # $echo "$modename: using $tagname tagged configuration"
19 fi
diff --git a/meta/packages/libtool/libtool-1.5.10/tag1.patch b/meta/packages/libtool/libtool-1.5.10/tag1.patch
new file mode 100644
index 0000000000..6fefd6266d
--- /dev/null
+++ b/meta/packages/libtool/libtool-1.5.10/tag1.patch
@@ -0,0 +1,13 @@
1Index: libtool-1.5.10/libltdl/ltmain.sh
2===================================================================
3--- libtool-1.5.10.orig/libltdl/ltmain.sh 2004-09-19 13:34:44.000000000 +0100
4+++ libtool-1.5.10/libltdl/ltmain.sh 2006-05-25 15:28:39.000000000 +0100
5@@ -232,7 +232,7 @@
6 if test -z "$tagname"; then
7 $echo "$modename: unable to infer tagged configuration"
8 $echo "$modename: specify a tag with \`--tag'" 1>&2
9- exit $EXIT_FAILURE
10+# exit $EXIT_FAILURE
11 # else
12 # $echo "$modename: using $tagname tagged configuration"
13 fi
diff --git a/meta/packages/libtool/libtool-1.5.10/uclibc.patch b/meta/packages/libtool/libtool-1.5.10/uclibc.patch
new file mode 100644
index 0000000000..2c8cbabbb3
--- /dev/null
+++ b/meta/packages/libtool/libtool-1.5.10/uclibc.patch
@@ -0,0 +1,19 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- libtool-1.5.8/libtool.m4~uclibc
7+++ libtool-1.5.8/libtool.m4
8@@ -2221,6 +2221,11 @@
9 lt_cv_deplibs_check_method=pass_all
10 ;;
11
12+linux-uclibc*)
13+ lt_cv_deplibs_check_method=pass_all
14+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
15+ ;;
16+
17 netbsd*)
18 if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
19 lt_cv_deplibs_check_method='match_pattern /lib[[^/]]+(\.so\.[[0-9]]+\.[[0-9]]+|_pic\.a)$'