summaryrefslogtreecommitdiffstats
path: root/meta/packages/libpcap/libpcap_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libpcap/libpcap_1.0.0.bb')
-rw-r--r--meta/packages/libpcap/libpcap_1.0.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/packages/libpcap/libpcap_1.0.0.bb b/meta/packages/libpcap/libpcap_1.0.0.bb
new file mode 100644
index 0000000000..edd9706b1e
--- /dev/null
+++ b/meta/packages/libpcap/libpcap_1.0.0.bb
@@ -0,0 +1,19 @@
1require libpcap.inc
2
3PR = "r0"
4
5SRC_URI += "file://config-fixes.patch;patch=1 \
6 file://aclocal.patch;patch=1 \
7 file://ieee80215-arphrd.patch;patch=1 \
8 file://ldflags.patch;patch=1"
9
10#
11# make install doesn't cover the shared lib
12# make install-shared is just broken (no symlinks)
13#
14do_install_prepend () {
15 install -d ${D}${libdir}
16 install -d ${D}${bindir}
17 oe_runmake install-shared DESTDIR=${D}
18 oe_libinstall -a -so libpcap ${D}${libdir}
19}