summaryrefslogtreecommitdiffstats
path: root/meta/packages/libgpg-error/libgpg-error_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/libgpg-error/libgpg-error_1.0.bb')
-rw-r--r--meta/packages/libgpg-error/libgpg-error_1.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/packages/libgpg-error/libgpg-error_1.0.bb b/meta/packages/libgpg-error/libgpg-error_1.0.bb
new file mode 100644
index 0000000000..c29053832b
--- /dev/null
+++ b/meta/packages/libgpg-error/libgpg-error_1.0.bb
@@ -0,0 +1,28 @@
1PR = "r0"
2DESCRIPTION = "GPG-Error library"
3SECTION = "libs"
4PRIORITY = "optional"
5LICENSE = "GPL LGPL FDL"
6
7SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${PV}.tar.gz \
8 file://pkgconfig.patch;patch=1"
9
10# move libgpg-error-config into -dev package
11FILES_${PN} = "${libdir}/lib*.so.*"
12FILES_${PN}-dev += "${bindir}"
13
14inherit autotools binconfig pkgconfig
15
16do_stage() {
17 oe_libinstall -a -so -C src libgpg-error ${STAGING_LIBDIR}
18 install -m 0755 src/gpg-error-config ${STAGING_BINDIR}/
19
20 install -d ${STAGING_INCDIR}/
21 for X in gpg-error.h
22 do
23 install -m 0644 ${S}/src/$X ${STAGING_INCDIR}/$X
24 done
25
26 install -d ${STAGING_DATADIR}/aclocal
27 install -m 0644 src/gpg-error.m4 ${STAGING_DATADIR}/aclocal/
28}