diff options
Diffstat (limited to 'meta/packages/liba52')
-rw-r--r-- | meta/packages/liba52/liba52/buildcleanup.patch | 87 | ||||
-rw-r--r-- | meta/packages/liba52/liba52_0.7.4.bb | 25 |
2 files changed, 0 insertions, 112 deletions
diff --git a/meta/packages/liba52/liba52/buildcleanup.patch b/meta/packages/liba52/liba52/buildcleanup.patch deleted file mode 100644 index a86c5a8e37..0000000000 --- a/meta/packages/liba52/liba52/buildcleanup.patch +++ /dev/null | |||
@@ -1,87 +0,0 @@ | |||
1 | It makes much more sense to control our own CFLAGS and avoiding fPIC breaks | ||
2 | some arches too. Assume we know what we're doing and remove all the messing | ||
3 | around. | ||
4 | |||
5 | RP 23/2/10 | ||
6 | |||
7 | Index: a52dec-0.7.4/configure.in | ||
8 | =================================================================== | ||
9 | --- a52dec-0.7.4.orig/configure.in 2010-02-23 14:51:50.000000000 +0000 | ||
10 | +++ a52dec-0.7.4/configure.in 2010-02-23 14:52:36.000000000 +0000 | ||
11 | @@ -14,62 +14,6 @@ | ||
12 | AC_PROG_CC | ||
13 | AC_PROG_GCC_TRADITIONAL | ||
14 | |||
15 | -if test x"$GCC" = x"yes"; then | ||
16 | - | ||
17 | - dnl GCC-specific flags - try to optimize them sometime | ||
18 | - dnl -Wall -Werror moved to the end to not disturb the configure script | ||
19 | - | ||
20 | - dnl -O3 | ||
21 | - changequote(<<,>>) | ||
22 | - OPT_CFLAGS=`echo "$CFLAGS"|sed "s/-O[0-9]*//g"` | ||
23 | - changequote([,]) | ||
24 | - OPT_CFLAGS="$OPT_CFLAGS -O3" | ||
25 | - AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]) | ||
26 | - | ||
27 | - dnl -fomit-frame-pointer | ||
28 | - OPT_CFLAGS="$CFLAGS -fomit-frame-pointer" | ||
29 | - AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]) | ||
30 | - | ||
31 | - dnl arch-specific flags | ||
32 | - case "$host" in | ||
33 | - i?86-* | k?-*) | ||
34 | - case "$host" in | ||
35 | - i386-*) OPT_CFLAGS="$CFLAGS -mcpu=i386";; | ||
36 | - i486-*) OPT_CFLAGS="$CFLAGS -mcpu=i486";; | ||
37 | - i586-*) OPT_CFLAGS="$CFLAGS -mcpu=pentium";; | ||
38 | - i686-*) OPT_CFLAGS="$CFLAGS -mcpu=pentiumpro";; | ||
39 | - k6-*) OPT_CFLAGS="$CFLAGS -mcpu=k6";; | ||
40 | - esac | ||
41 | - AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);; | ||
42 | - sparc-* | sparc64-*) | ||
43 | - OPT_CFLAGS="$CFLAGS -mtune=ultrasparc" | ||
44 | - AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);; | ||
45 | - mips-sgi-irix6.*) dnl do we need to be that specific ? | ||
46 | - OPT_CFLAGS="$CFLAGS -mabi=64" | ||
47 | - AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);; | ||
48 | - esac | ||
49 | -elif test x"$CC" = x"tcc" -a x"`$CC -version 2>&1 | grep TenDRA`" != x""; then | ||
50 | - dnl TenDRA portability checking compiler | ||
51 | - TENDRA=yes | ||
52 | - CFLAGS="-Xp -Yansi -f`pwd`/include/tendra.h -DELIDE_CODE" | ||
53 | - enable_mlib=no | ||
54 | - enable_oss=no | ||
55 | - enable_solaris_audio=no | ||
56 | -elif test x"$CC" = x"icc" -a x"`$CC -V 2>&1 | grep Intel`" != x""; then | ||
57 | - dnl Intel C++ compiler | ||
58 | - CFLAGS="-g -O3 -unroll -ip" | ||
59 | -else | ||
60 | - dnl non-gcc flags - we probably need exact configuration triplets here. | ||
61 | - case "$host" in | ||
62 | - mips-sgi-irix6.*) | ||
63 | - OPT_CFLAGS="$CFLAGS -64" | ||
64 | - AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);; | ||
65 | - sparc-sun-solaris*) | ||
66 | - OPT_CFLAGS="$CFLAGS -xCC -fast -xO5" | ||
67 | - AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);; | ||
68 | - esac | ||
69 | -fi | ||
70 | - | ||
71 | dnl Checks for libtool - this must be done after we set cflags | ||
72 | AC_DISABLE_SHARED | ||
73 | AC_LIBTOOL_WIN32_DLL | ||
74 | Index: a52dec-0.7.4/liba52/configure.incl | ||
75 | =================================================================== | ||
76 | --- a52dec-0.7.4.orig/liba52/configure.incl 2010-02-23 14:51:44.000000000 +0000 | ||
77 | +++ a52dec-0.7.4/liba52/configure.incl 2010-02-23 14:51:59.000000000 +0000 | ||
78 | @@ -1,9 +1,6 @@ | ||
79 | AC_SUBST([LIBA52_CFLAGS]) | ||
80 | AC_SUBST([LIBA52_LIBS]) | ||
81 | |||
82 | -dnl avoid -fPIC when possible | ||
83 | -LIBA52_CFLAGS="$LIBA52_CFLAGS -prefer-non-pic" | ||
84 | - | ||
85 | AC_ARG_ENABLE([double], | ||
86 | [ --enable-double use double-precision samples]) | ||
87 | if test x"$enable_double" = x"yes"; then | ||
diff --git a/meta/packages/liba52/liba52_0.7.4.bb b/meta/packages/liba52/liba52_0.7.4.bb deleted file mode 100644 index 884b861a91..0000000000 --- a/meta/packages/liba52/liba52_0.7.4.bb +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | DESCRIPTION = "Library for reading some sort of media format." | ||
2 | HOMEPAGE = "http://liba52.sourceforge.net/" | ||
3 | LICENSE = "GPLv2+" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ | ||
5 | file://include/a52.h;beginline=1;endline=12;md5=81152ceb3562bf20a60d1b6018175dd1" | ||
6 | SECTION = "libs" | ||
7 | PRIORITY = "optional" | ||
8 | PR = "r2" | ||
9 | |||
10 | inherit autotools | ||
11 | |||
12 | SRC_URI = "http://liba52.sourceforge.net/files/a52dec-${PV}.tar.gz \ | ||
13 | file://buildcleanup.patch;patch=1" | ||
14 | S = "${WORKDIR}/a52dec-${PV}" | ||
15 | |||
16 | EXTRA_OECONF = " --enable-shared " | ||
17 | |||
18 | PACKAGES =+ "a52dec a52dec-dbg a52dec-doc" | ||
19 | |||
20 | FILES_${PN} = " ${libdir}/liba52.so.0 ${libdir}/liba52.so.0.0.0 " | ||
21 | FILES_${PN}-dev = " ${includedir}/a52dec/*.h ${libdir}/liba52.so ${libdir}/liba52.la ${libdir}/liba52.a " | ||
22 | FILES_${PN}-dbg = " ${libdir}/.debug/*" | ||
23 | FILES_a52dec = " ${bindir}/* " | ||
24 | FILES_a52dec-dbg = " ${bindir}/.debug/* " | ||
25 | FILES_a52dec-doc = " ${mandir}/man1/* " | ||