diff options
Diffstat (limited to 'meta/packages/initrdscripts')
-rw-r--r-- | meta/packages/initrdscripts/files/init-boot.sh | 8 | ||||
-rw-r--r-- | meta/packages/initrdscripts/files/init-install.sh | 170 | ||||
-rw-r--r-- | meta/packages/initrdscripts/files/init-live.sh | 92 | ||||
-rw-r--r-- | meta/packages/initrdscripts/initramfs-boot_1.0.bb | 13 | ||||
-rw-r--r-- | meta/packages/initrdscripts/initramfs-live-boot_1.0.bb | 13 | ||||
-rw-r--r-- | meta/packages/initrdscripts/initramfs-live-install_1.0.bb | 18 |
6 files changed, 0 insertions, 314 deletions
diff --git a/meta/packages/initrdscripts/files/init-boot.sh b/meta/packages/initrdscripts/files/init-boot.sh deleted file mode 100644 index 9d804fc3a7..0000000000 --- a/meta/packages/initrdscripts/files/init-boot.sh +++ /dev/null | |||
@@ -1,8 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | mkdir /proc | ||
4 | mkdir /sys | ||
5 | mount -t proc proc /proc | ||
6 | mount -t sysfs sysfs /sys | ||
7 | |||
8 | exec sh | ||
diff --git a/meta/packages/initrdscripts/files/init-install.sh b/meta/packages/initrdscripts/files/init-install.sh deleted file mode 100644 index ecd0a1b44a..0000000000 --- a/meta/packages/initrdscripts/files/init-install.sh +++ /dev/null | |||
@@ -1,170 +0,0 @@ | |||
1 | #!/bin/sh -e | ||
2 | # | ||
3 | # Copyright (C) 2008 Intel | ||
4 | # | ||
5 | # install.sh [device_name] [rootfs_name] [video_mode] [vga_mode] | ||
6 | # | ||
7 | |||
8 | # We need 20 Mb for the boot partition | ||
9 | boot_size=20 | ||
10 | |||
11 | # 5% for the swap | ||
12 | swap_ratio=5 | ||
13 | |||
14 | found="no" | ||
15 | |||
16 | echo "Searching for a hard drive..." | ||
17 | for device in 'hda' 'hdb' 'sda' 'sdb' | ||
18 | do | ||
19 | if [ -e /sys/block/${device}/removable ]; then | ||
20 | if [ "$(cat /sys/block/${device}/removable)" = "0" ]; then | ||
21 | found="yes" | ||
22 | |||
23 | while true; do | ||
24 | echo "Found drive at /dev/${device}. Do you want to install moblin there ? [y/n]" | ||
25 | read answer | ||
26 | if [ "$answer" = "y" ] ; then | ||
27 | break | ||
28 | fi | ||
29 | |||
30 | if [ "$answer" = "n" ] ; then | ||
31 | found=no | ||
32 | break | ||
33 | fi | ||
34 | |||
35 | echo "Please answer by y or n" | ||
36 | done | ||
37 | fi | ||
38 | fi | ||
39 | |||
40 | if [ "$found" = "yes" ]; then | ||
41 | break; | ||
42 | fi | ||
43 | |||
44 | done | ||
45 | |||
46 | if [ "$found" = "no" ]; then | ||
47 | exit 1 | ||
48 | fi | ||
49 | |||
50 | echo "Installing image on /dev/${device}" | ||
51 | |||
52 | # | ||
53 | # The udev automounter can cause pain here, kill it | ||
54 | # | ||
55 | rm -f /etc/udev/scripts/mount* | ||
56 | |||
57 | # | ||
58 | # Unmount anything the automounter had mounted | ||
59 | # | ||
60 | umount /dev/${device} 2> /dev/null || /bin/true | ||
61 | umount /dev/${device}1 2> /dev/null || /bin/true | ||
62 | umount /dev/${device}2 2> /dev/null || /bin/true | ||
63 | umount /dev/${device}3 2> /dev/null || /bin/true | ||
64 | umount /dev/${device}4 2> /dev/null || /bin/true | ||
65 | umount /dev/${device}5 2> /dev/null || /bin/true | ||
66 | umount /dev/${device}6 2> /dev/null || /bin/true | ||
67 | |||
68 | if [ ! -b /dev/sda ] ; then | ||
69 | mknod /dev/sda b 8 0 | ||
70 | fi | ||
71 | |||
72 | if [ ! -b /dev/sdb ] ; then | ||
73 | mknod /dev/sdb b 8 16 | ||
74 | fi | ||
75 | |||
76 | if [ ! -b /dev/loop0 ] ; then | ||
77 | mknod /dev/loop0 b 7 0 | ||
78 | fi | ||
79 | |||
80 | mkdir -p /tmp | ||
81 | cat /proc/mounts > /etc/mtab | ||
82 | |||
83 | disk_size=$(parted /dev/${device} unit mb print | grep Disk | cut -d" " -f 3 | sed -e "s/MB//") | ||
84 | |||
85 | swap_size=$((disk_size*5/100)) | ||
86 | rootfs_size=$((disk_size-boot_size-swap_size)) | ||
87 | |||
88 | rootfs_start=$((boot_size + 1)) | ||
89 | rootfs_end=$((rootfs_start+rootfs_size)) | ||
90 | swap_start=$((rootfs_end+1)) | ||
91 | |||
92 | bootfs=/dev/${device}1 | ||
93 | rootfs=/dev/${device}2 | ||
94 | swap=/dev/${device}3 | ||
95 | |||
96 | echo "*****************" | ||
97 | echo "Boot partition size: $boot_size MB (/dev/${device}1)" | ||
98 | echo "Rootfs partition size: $rootfs_size MB (/dev/${device}2)" | ||
99 | echo "Swap partition size: $swap_size MB (/dev/${device}3)" | ||
100 | echo "*****************" | ||
101 | echo "Deleting partition table on /dev/${device} ..." | ||
102 | dd if=/dev/zero of=/dev/${device} bs=512 count=2 | ||
103 | |||
104 | echo "Creating new partition table on /dev/${device} ..." | ||
105 | parted /dev/${device} mklabel msdos | ||
106 | |||
107 | echo "Creating boot partition on /dev/${device}1" | ||
108 | parted /dev/${device} mkpartfs primary ext2 0 $boot_size | ||
109 | |||
110 | echo "Creating rootfs partition on /dev/${device}2" | ||
111 | parted /dev/${device} mkpartfs primary ext2 $rootfs_start $rootfs_end | ||
112 | |||
113 | echo "Creating swap partition on /dev/${device}3" | ||
114 | parted /dev/${device} mkpartfs primary linux-swap $swap_start $disk_size | ||
115 | |||
116 | parted /dev/${device} print | ||
117 | |||
118 | echo "Formatting /dev/${device}1 to ext2..." | ||
119 | mkfs.ext3 $bootfs | ||
120 | |||
121 | echo "Formatting /dev/${device}2 to ext3..." | ||
122 | mkfs.ext3 $rootfs | ||
123 | |||
124 | echo "Formatting swap partition...(/dev/${device}3)" | ||
125 | mkswap $swap | ||
126 | |||
127 | mkdir /ssd | ||
128 | mkdir /rootmnt | ||
129 | |||
130 | mount $rootfs /ssd | ||
131 | mount -o rw,loop,noatime,nodiratime /media/$1/$2 /rootmnt | ||
132 | |||
133 | echo "Copying rootfs files..." | ||
134 | cp -a /rootmnt/* /ssd | ||
135 | |||
136 | if [ -d /ssd/etc/ ] ; then | ||
137 | echo "$swap swap swap defaults 0 0" >> /ssd/etc/fstab | ||
138 | |||
139 | # We dont want udev to mount our root device while we're booting... | ||
140 | if [ -d /ssd/etc/udev/ ] ; then | ||
141 | echo "/dev/${device}" >> /ssd/etc/udev/mount.blacklist | ||
142 | fi | ||
143 | fi | ||
144 | |||
145 | umount /ssd | ||
146 | umount /rootmnt | ||
147 | |||
148 | echo "Preparing boot partition..." | ||
149 | mount $bootfs /ssd | ||
150 | grub-install --root-directory=/ssd /dev/${device} | ||
151 | |||
152 | echo "(hd0) /dev/${device}" > /ssd/boot/grub/device.map | ||
153 | |||
154 | echo "default 0" > /ssd/boot/grub/menu.lst | ||
155 | echo "timeout 30" >> /ssd/boot/grub/menu.lst | ||
156 | echo "title Poky-Netbook" >> /ssd/boot/grub/menu.lst | ||
157 | echo "root (hd0,0)" >> /ssd/boot/grub/menu.lst | ||
158 | echo "kernel /boot/vmlinuz root=$rootfs rw $3 $4 quiet" >> /ssd/boot/grub/menu.lst | ||
159 | |||
160 | cp /media/$1/vmlinuz /ssd/boot/ | ||
161 | |||
162 | umount /ssd | ||
163 | sync | ||
164 | |||
165 | echo "Remove your installation media, and press ENTER" | ||
166 | |||
167 | read enter | ||
168 | |||
169 | echo "Rebooting..." | ||
170 | reboot -f | ||
diff --git a/meta/packages/initrdscripts/files/init-live.sh b/meta/packages/initrdscripts/files/init-live.sh deleted file mode 100644 index c96b1f47c3..0000000000 --- a/meta/packages/initrdscripts/files/init-live.sh +++ /dev/null | |||
@@ -1,92 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | ROOT_MOUNT="/rootfs/" | ||
4 | ROOT_IMAGE=rootfs.img | ||
5 | MOUNT="/bin/mount" | ||
6 | UMOUNT="/bin/umount" | ||
7 | |||
8 | early_setup() { | ||
9 | mkdir /proc | ||
10 | mkdir /sys | ||
11 | mount -t proc proc /proc | ||
12 | mount -t sysfs sysfs /sys | ||
13 | udevd --daemon | ||
14 | } | ||
15 | |||
16 | read_args() { | ||
17 | [ -z "$CMDLINE" ] && CMDLINE=`cat /proc/cmdline` | ||
18 | for arg in $CMDLINE; do | ||
19 | optarg=`expr "x$arg" : 'x[^=]*=\(.*\)'` | ||
20 | case $arg in | ||
21 | root=*) | ||
22 | ROOT_DEVICE=$optarg ;; | ||
23 | rootfstype=*) | ||
24 | ROOT_FSTYPE=$optarg ;; | ||
25 | rootdelay=*) | ||
26 | rootdelay=$optarg ;; | ||
27 | LABEL=*) | ||
28 | label=$optarg ;; | ||
29 | video=*) | ||
30 | video_mode=$arg ;; | ||
31 | vga=*) | ||
32 | vga_mode=$arg ;; | ||
33 | esac | ||
34 | done | ||
35 | } | ||
36 | |||
37 | boot_live_root() { | ||
38 | killall udevd | ||
39 | cd $ROOT_MOUNT | ||
40 | exec switch_root -c /dev/console $ROOT_MOUNT /sbin/init | ||
41 | } | ||
42 | |||
43 | fatal() { | ||
44 | echo $1 >$CONSOLE | ||
45 | echo >$CONSOLE | ||
46 | exec sh | ||
47 | } | ||
48 | |||
49 | early_setup | ||
50 | |||
51 | [ -z "$CONSOLE" ] && CONSOLE="/dev/console" | ||
52 | |||
53 | read_args | ||
54 | |||
55 | echo "Waiting for removable media..." | ||
56 | while true | ||
57 | do | ||
58 | for i in `ls /media 2>/dev/null`; do | ||
59 | if [ -f /media/$i/$ROOT_IMAGE ] ; then | ||
60 | found="yes" | ||
61 | break | ||
62 | fi | ||
63 | done | ||
64 | if [ "$found" = "yes" ]; then | ||
65 | break; | ||
66 | fi | ||
67 | sleep 1 | ||
68 | done | ||
69 | |||
70 | case $label in | ||
71 | boot) | ||
72 | mkdir $ROOT_MOUNT | ||
73 | mknod /dev/loop0 b 7 0 | ||
74 | |||
75 | if ! $MOUNT -o rw,loop,noatime,nodiratime /media/$i/$ROOT_IMAGE $ROOT_MOUNT ; then | ||
76 | fatal "Couldnt mount rootfs image" | ||
77 | else | ||
78 | boot_live_root | ||
79 | fi | ||
80 | ;; | ||
81 | install) | ||
82 | if [ -f /media/$i/$ROOT_IMAGE ] ; then | ||
83 | ./install.sh $i $ROOT_IMAGE $video_mode $vga_mode | ||
84 | else | ||
85 | fatal "Couldnt find install script" | ||
86 | fi | ||
87 | |||
88 | # If we're getting here, we failed... | ||
89 | fatal "Installation image failed" | ||
90 | ;; | ||
91 | esac | ||
92 | |||
diff --git a/meta/packages/initrdscripts/initramfs-boot_1.0.bb b/meta/packages/initrdscripts/initramfs-boot_1.0.bb deleted file mode 100644 index 04ce51fafa..0000000000 --- a/meta/packages/initrdscripts/initramfs-boot_1.0.bb +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | DESCRIPTON = "A live image init script" | ||
2 | LICENSE = "MIT" | ||
3 | |||
4 | SRC_URI = "file://init-boot.sh" | ||
5 | |||
6 | PR = "r0" | ||
7 | |||
8 | do_install() { | ||
9 | install -m 0755 ${WORKDIR}/init-boot.sh ${D}/init | ||
10 | } | ||
11 | |||
12 | PACKAGE_ARCH = "all" | ||
13 | FILES_${PN} += " /init " | ||
diff --git a/meta/packages/initrdscripts/initramfs-live-boot_1.0.bb b/meta/packages/initrdscripts/initramfs-live-boot_1.0.bb deleted file mode 100644 index ba36a58049..0000000000 --- a/meta/packages/initrdscripts/initramfs-live-boot_1.0.bb +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | DESCRIPTON = "A live image init script" | ||
2 | LICENSE = "MIT" | ||
3 | |||
4 | SRC_URI = "file://init-live.sh" | ||
5 | |||
6 | PR = "r2" | ||
7 | |||
8 | do_install() { | ||
9 | install -m 0755 ${WORKDIR}/init-live.sh ${D}/init | ||
10 | } | ||
11 | |||
12 | PACKAGE_ARCH = "all" | ||
13 | FILES_${PN} += " /init " | ||
diff --git a/meta/packages/initrdscripts/initramfs-live-install_1.0.bb b/meta/packages/initrdscripts/initramfs-live-install_1.0.bb deleted file mode 100644 index b15621b668..0000000000 --- a/meta/packages/initrdscripts/initramfs-live-install_1.0.bb +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | DESCRIPTON = "A live image init script" | ||
2 | LICENSE = "MIT" | ||
3 | |||
4 | SRC_URI = "file://init-install.sh" | ||
5 | |||
6 | PR = "r3" | ||
7 | |||
8 | RDEPENDS="grub parted e2fsprogs-mke2fs" | ||
9 | |||
10 | do_install() { | ||
11 | install -m 0755 ${WORKDIR}/init-install.sh ${D}/install.sh | ||
12 | } | ||
13 | |||
14 | PACKAGE_ARCH = "all" | ||
15 | FILES_${PN} = " /install.sh " | ||
16 | |||
17 | # Alternatives to grub need adding for other arch support | ||
18 | COMPATIBLE_HOST = "(i.86|x86_64).*-linux" | ||