summaryrefslogtreecommitdiffstats
path: root/meta/packages/hostap/hostap-modules
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/hostap/hostap-modules')
-rw-r--r--meta/packages/hostap/hostap-modules/Makefile.patch11
-rw-r--r--meta/packages/hostap/hostap-modules/add_event.patch28
-rw-r--r--meta/packages/hostap/hostap-modules/hostap-utsname.patch77
-rw-r--r--meta/packages/hostap/hostap-modules/hostap_cardid.patch70
-rw-r--r--meta/packages/hostap/hostap-modules/ipaq_compat.patch11
-rw-r--r--meta/packages/hostap/hostap-modules/kernel_updates.patch192
-rw-r--r--meta/packages/hostap/hostap-modules/mtx_compat.diff20
-rw-r--r--meta/packages/hostap/hostap-modules/mtx_hostap_deferred_irq.diff81
8 files changed, 490 insertions, 0 deletions
diff --git a/meta/packages/hostap/hostap-modules/Makefile.patch b/meta/packages/hostap/hostap-modules/Makefile.patch
new file mode 100644
index 0000000000..2fc5e9ed4b
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/Makefile.patch
@@ -0,0 +1,11 @@
1--- hostap-driver-0.2.4/Makefile.old 2004-07-31 10:35:50.000000000 +0100
2+++ hostap-driver-0.2.4/Makefile 2004-07-31 10:35:56.000000000 +0100
3@@ -51,7 +51,7 @@
4
5 VERFILE := $(KERNEL_PATH)/include/linux/version.h
6 KERNELRELEASE := $(shell if [ -r $(VERFILE) ]; \
7- then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -1 | xargs echo; \
8+ then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -n 1 | xargs echo; \
9 else uname -r; fi)
10 KERNELVER := $(shell echo "$(KERNELRELEASE)" | \
11 sed "s/\([0-9]*\.[0-9]*\.[0-9]*\).*/\1/")
diff --git a/meta/packages/hostap/hostap-modules/add_event.patch b/meta/packages/hostap/hostap-modules/add_event.patch
new file mode 100644
index 0000000000..d5f2a10e86
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/add_event.patch
@@ -0,0 +1,28 @@
1Index: hostap-driver-0.3.7/driver/modules/hostap_cs.c
2===================================================================
3--- hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c 2005-08-03 17:05:53.000000000 +0100
4+++ hostap-driver-0.3.7/driver/modules/hostap_cs.c 2005-08-03 17:07:59.000000000 +0100
5@@ -526,11 +526,13 @@
6 dev_list = link;
7 client_reg.dev_info = &dev_info;
8 client_reg.Attributes = INFO_IO_CLIENT;
9+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,13))
10 client_reg.EventMask = CS_EVENT_CARD_INSERTION |
11 CS_EVENT_CARD_REMOVAL |
12 CS_EVENT_RESET_PHYSICAL | CS_EVENT_CARD_RESET |
13 CS_EVENT_PM_SUSPEND | CS_EVENT_PM_RESUME;
14 client_reg.event_handler = &prism2_event;
15+#endif
16 client_reg.Version = 0x0210;
17 client_reg.event_callback_args.client_data = link;
18 ret = pcmcia_register_client(&link->handle, &client_reg);
19@@ -913,6 +915,9 @@
20 .name = "hostap_cs",
21 },
22 .attach = prism2_attach,
23+#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
24+ .event = prism2_event,
25+#endif
26 .detach = prism2_detach,
27 .owner = THIS_MODULE,
28 };
diff --git a/meta/packages/hostap/hostap-modules/hostap-utsname.patch b/meta/packages/hostap/hostap-modules/hostap-utsname.patch
new file mode 100644
index 0000000000..c29cc8d2c9
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/hostap-utsname.patch
@@ -0,0 +1,77 @@
1diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap.c hostap-driver-0.3.7/driver/modules/hostap.c
2--- hostap-driver-0.3.7.orig/driver/modules/hostap.c 2005-07-25 09:14:01.995965088 +0000
3+++ hostap-driver-0.3.7/driver/modules/hostap.c 2005-07-25 09:13:22.301999488 +0000
4@@ -25,6 +25,7 @@
5 #include <linux/if_arp.h>
6 #include <linux/delay.h>
7 #include <linux/random.h>
8+#include <linux/utsname.h>
9 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
10 #include <linux/tqueue.h>
11 #else
12diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_ccmp.c hostap-driver-0.3.7/driver/modules/hostap_crypt_ccmp.c
13--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_ccmp.c 2005-07-25 09:14:01.996964936 +0000
14+++ hostap-driver-0.3.7/driver/modules/hostap_crypt_ccmp.c 2005-07-25 09:13:22.302999336 +0000
15@@ -19,6 +19,7 @@
16 #include <linux/netdevice.h>
17 #include <linux/if_ether.h>
18 #include <linux/if_arp.h>
19+#include <linux/utsname.h>
20 #include <asm/string.h>
21
22 #include "hostap_crypt.h"
23diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_tkip.c hostap-driver-0.3.7/driver/modules/hostap_crypt_tkip.c
24--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_tkip.c 2005-07-25 09:14:01.996964936 +0000
25+++ hostap-driver-0.3.7/driver/modules/hostap_crypt_tkip.c 2005-07-25 09:13:22.302999336 +0000
26@@ -19,6 +19,7 @@
27 #include <linux/netdevice.h>
28 #include <linux/if_ether.h>
29 #include <linux/if_arp.h>
30+#include <linux/utsname.h>
31 #include <asm/string.h>
32
33 #include "hostap_crypt.h"
34diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_wep.c hostap-driver-0.3.7/driver/modules/hostap_crypt_wep.c
35--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_wep.c 2005-07-25 09:14:01.996964936 +0000
36+++ hostap-driver-0.3.7/driver/modules/hostap_crypt_wep.c 2005-07-25 09:13:22.302999336 +0000
37@@ -15,6 +15,7 @@
38 #include <linux/init.h>
39 #include <linux/slab.h>
40 #include <linux/random.h>
41+#include <linux/utsname.h>
42 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
43 #include <linux/tqueue.h>
44 #else
45diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c hostap-driver-0.3.7/driver/modules/hostap_cs.c
46--- hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c 2005-07-25 09:14:01.997964784 +0000
47+++ hostap-driver-0.3.7/driver/modules/hostap_cs.c 2005-07-25 09:13:22.302999336 +0000
48@@ -12,6 +12,7 @@
49 #include <linux/timer.h>
50 #include <linux/skbuff.h>
51 #include <linux/netdevice.h>
52+#include <linux/utsname.h>
53 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
54 #include <linux/tqueue.h>
55 #else
56diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_pci.c hostap-driver-0.3.7/driver/modules/hostap_pci.c
57--- hostap-driver-0.3.7.orig/driver/modules/hostap_pci.c 2005-07-25 09:14:01.997964784 +0000
58+++ hostap-driver-0.3.7/driver/modules/hostap_pci.c 2005-07-25 09:13:22.303999184 +0000
59@@ -11,6 +11,7 @@
60 #include <linux/if.h>
61 #include <linux/skbuff.h>
62 #include <linux/netdevice.h>
63+#include <linux/utsname.h>
64 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
65 #include <linux/tqueue.h>
66 #else
67diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_plx.c hostap-driver-0.3.7/driver/modules/hostap_plx.c
68--- hostap-driver-0.3.7.orig/driver/modules/hostap_plx.c 2005-07-25 09:14:01.997964784 +0000
69+++ hostap-driver-0.3.7/driver/modules/hostap_plx.c 2005-07-25 09:13:22.303999184 +0000
70@@ -14,6 +14,7 @@
71 #include <linux/if.h>
72 #include <linux/skbuff.h>
73 #include <linux/netdevice.h>
74+#include <linux/utsname.h>
75 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
76 #include <linux/tqueue.h>
77 #else
diff --git a/meta/packages/hostap/hostap-modules/hostap_cardid.patch b/meta/packages/hostap/hostap-modules/hostap_cardid.patch
new file mode 100644
index 0000000000..05f716e22f
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/hostap_cardid.patch
@@ -0,0 +1,70 @@
1Index: hostap-driver-0.3.9/driver/modules/hostap_cs.c
2===================================================================
3--- hostap-driver-0.3.9.orig/driver/modules/hostap_cs.c 2005-08-24 10:11:47.000000000 +0100
4+++ hostap-driver-0.3.9/driver/modules/hostap_cs.c 2005-08-24 10:39:10.000000000 +0100
5@@ -908,6 +908,57 @@
6 return 0;
7 }
8
9+#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
10+static struct pcmcia_device_id hostap_cs_ids[] = {
11+ PCMCIA_DEVICE_MANF_CARD(0x000b, 0x7100),
12+ PCMCIA_DEVICE_MANF_CARD(0x000b, 0x7300),
13+ PCMCIA_DEVICE_MANF_CARD(0x0101, 0x0777),
14+ PCMCIA_DEVICE_MANF_CARD(0x0126, 0x8000),
15+ PCMCIA_DEVICE_MANF_CARD(0x0138, 0x0002),
16+ PCMCIA_DEVICE_MANF_CARD(0x0156, 0x0002),
17+ PCMCIA_DEVICE_MANF_CARD(0x0250, 0x0002),
18+ PCMCIA_DEVICE_MANF_CARD(0x0274, 0x1612),
19+ PCMCIA_DEVICE_MANF_CARD(0x0274, 0x1613),
20+ PCMCIA_DEVICE_MANF_CARD(0x028a, 0x0002),
21+ PCMCIA_DEVICE_MANF_CARD(0x02aa, 0x0002),
22+ PCMCIA_DEVICE_MANF_CARD(0x02d2, 0x0001),
23+ PCMCIA_DEVICE_MANF_CARD(0x50c2, 0x0001),
24+ PCMCIA_DEVICE_MANF_CARD(0x50c2, 0x7300),
25+ PCMCIA_DEVICE_MANF_CARD(0xc00f, 0x0000),
26+ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0002),
27+ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0005),
28+ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0010),
29+ PCMCIA_MFC_DEVICE_PROD_ID12(0, "SanDisk", "ConnectPlus",
30+ 0x7a954bd9, 0x74be00c6),
31+ PCMCIA_DEVICE_PROD_ID1234(
32+ "Intersil", "PRISM 2_5 PCMCIA ADAPTER", "ISL37300P",
33+ "Eval-RevA",
34+ 0x4b801a17, 0x6345a0bf, 0xc9049a39, 0xc23adc0e),
35+ PCMCIA_DEVICE_PROD_ID123(
36+ "Addtron", "AWP-100 Wireless PCMCIA", "Version 01.02",
37+ 0xe6ec52ce, 0x08649af2, 0x4b74baa0),
38+ PCMCIA_DEVICE_PROD_ID123(
39+ "D", "Link DWL-650 11Mbps WLAN Card", "Version 01.02",
40+ 0x71b18589, 0xb6f1b0ab, 0x4b74baa0),
41+ PCMCIA_DEVICE_PROD_ID123(
42+ "Instant Wireless ", " Network PC CARD", "Version 01.02",
43+ 0x11d901af, 0x6e9bd926, 0x4b74baa0),
44+ PCMCIA_DEVICE_PROD_ID123(
45+ "SMC", "SMC2632W", "Version 01.02",
46+ 0xc4f8b18b, 0x474a1f2a, 0x4b74baa0),
47+ PCMCIA_DEVICE_PROD_ID12("Compaq", "WL200_11Mbps_Wireless_PCI_Card",
48+ 0x54f7c49c, 0x15a75e5b),
49+ PCMCIA_DEVICE_PROD_ID12("INTERSIL", "HFA384x/IEEE",
50+ 0x74c5e40d, 0xdb472a18),
51+ PCMCIA_DEVICE_PROD_ID12("Linksys", "Wireless CompactFlash Card",
52+ 0x0733cc81, 0x0c52f395),
53+ PCMCIA_DEVICE_PROD_ID12(
54+ "ZoomAir 11Mbps High", "Rate wireless Networking",
55+ 0x273fe3db, 0x32a1eaee),
56+ PCMCIA_DEVICE_NULL
57+};
58+MODULE_DEVICE_TABLE(pcmcia, hostap_cs_ids);
59+#endif
60
61 #if LINUX_VERSION_CODE > KERNEL_VERSION(2,5,67)
62 static struct pcmcia_driver hostap_driver = {
63@@ -917,6 +968,7 @@
64 .attach = prism2_attach,
65 #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
66 .event = prism2_event,
67+ .id_table = hostap_cs_ids,
68 #endif
69 .detach = prism2_detach,
70 .owner = THIS_MODULE,
diff --git a/meta/packages/hostap/hostap-modules/ipaq_compat.patch b/meta/packages/hostap/hostap-modules/ipaq_compat.patch
new file mode 100644
index 0000000000..b139ef38f1
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/ipaq_compat.patch
@@ -0,0 +1,11 @@
1--- hostap-driver-0.3.7/driver/modules/hostap_compat.h.old 2005-04-17 09:12:38.304421464 +0100
2+++ hostap-driver-0.3.7/driver/modules/hostap_compat.h 2005-04-17 09:13:04.413452288 +0100
3@@ -5,7 +5,7 @@
4 #define NEW_MODULE_CODE
5 #endif
6
7-#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
8+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44)) && !defined(CONFIG_IPAQ_HANDHELD)
9
10 #define HOSTAP_QUEUE struct tq_struct
11
diff --git a/meta/packages/hostap/hostap-modules/kernel_updates.patch b/meta/packages/hostap/hostap-modules/kernel_updates.patch
new file mode 100644
index 0000000000..70487a96f8
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/kernel_updates.patch
@@ -0,0 +1,192 @@
1Index: hostap-driver-0.4.4/driver/modules/hostap_cs.c
2===================================================================
3--- hostap-driver-0.4.4.orig/driver/modules/hostap_cs.c 2005-08-21 20:23:21.000000000 +0100
4+++ hostap-driver-0.4.4/driver/modules/hostap_cs.c 2005-09-17 17:09:05.000000000 +0100
5@@ -207,12 +207,17 @@
6 #include "hostap_hw.c"
7
8
9-
10+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
11 static void prism2_detach(dev_link_t *link);
12+#else
13+static void prism2_detach(struct pcmcia_device *p_dev);
14+#endif
15+
16 static void prism2_release(u_long arg);
17+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
18 static int prism2_event(event_t event, int priority,
19 event_callback_args_t *args);
20-
21+#endif
22
23 static int prism2_pccard_card_present(local_info_t *local)
24 {
25@@ -508,25 +513,36 @@
26 }
27 #endif
28
29+static int prism2_config(dev_link_t *link);
30
31 /* allocate local data and register with CardServices
32 * initialize dev_link structure, but do not configure the card yet */
33+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
34 static dev_link_t *prism2_attach(void)
35+#else
36+static int prism2_attach(struct pcmcia_device *p_dev)
37+#endif
38 {
39 dev_link_t *link;
40+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
41 client_reg_t client_reg;
42 int ret;
43+#endif
44
45 link = kmalloc(sizeof(dev_link_t), GFP_KERNEL);
46 if (link == NULL)
47+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
48 return NULL;
49-
50+#else
51+ return -ENOMEM;
52+#endif
53 memset(link, 0, sizeof(dev_link_t));
54
55 PDEBUG(DEBUG_HW, "%s: setting Vcc=33 (constant)\n", dev_info);
56 link->conf.Vcc = 33;
57 link->conf.IntType = INT_MEMORY_AND_IO;
58
59+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
60 /* register with CardServices */
61 link->next = dev_list;
62 dev_list = link;
63@@ -547,12 +563,28 @@
64 prism2_detach(link);
65 return NULL;
66 }
67+
68 return link;
69-}
70+#else
71+ link->handle = p_dev;
72+ p_dev->instance = link;
73+
74+ link->state |= DEV_PRESENT | DEV_CONFIG_PENDING;
75+ prism2_config(link);
76
77+ return 0;
78+#endif
79+}
80
81+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
82 static void prism2_detach(dev_link_t *link)
83+#else
84+static void prism2_detach(struct pcmcia_device *p_dev)
85+#endif
86 {
87+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,15))
88+ dev_link_t *link = dev_to_instance(p_dev);
89+#endif
90 dev_link_t **linkp;
91
92 PDEBUG(DEBUG_FLOW, "prism2_detach\n");
93@@ -570,6 +602,7 @@
94 prism2_release((u_long)link);
95 }
96
97+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
98 if (link->handle) {
99 int res = pcmcia_deregister_client(link->handle);
100 if (res) {
101@@ -577,6 +610,7 @@
102 cs_error(link->handle, DeregisterClient, res);
103 }
104 }
105+#endif
106
107 *linkp = link->next;
108 /* release net devices */
109@@ -855,7 +889,53 @@
110 PDEBUG(DEBUG_FLOW, "release - done\n");
111 }
112
113+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,15))
114+static int prism2_suspend1(struct pcmcia_device *dev)
115+{
116+ dev_link_t *link = dev_to_instance(dev);
117+ struct net_device *ndev = (struct net_device *) link->priv;
118+
119+ PDEBUG(DEBUG_EXTRA, "%s: CS_EVENT_PM_SUSPEND\n", dev_info);
120+ link->state |= DEV_SUSPEND;
121+ /* fall through */
122
123+ if (link->state & DEV_CONFIG) {
124+ if (link->open) {
125+ netif_stop_queue(ndev);
126+ netif_device_detach(ndev);
127+ }
128+ prism2_suspend(ndev);
129+ pcmcia_release_configuration(link->handle);
130+ }
131+
132+ return 0;
133+}
134+
135+static int prism2_resume1(struct pcmcia_device *dev)
136+{
137+ dev_link_t *link = dev_to_instance(dev);
138+ struct net_device *ndev = (struct net_device *) link->priv;
139+
140+ PDEBUG(DEBUG_EXTRA, "%s: CS_EVENT_PM_RESUME\n", dev_info);
141+
142+ link->state &= ~DEV_SUSPEND;
143+ /* fall through */
144+
145+ if (link->state & DEV_CONFIG) {
146+ pcmcia_request_configuration(link->handle, &link->conf);
147+ prism2_hw_shutdown(ndev, 1);
148+ prism2_hw_config(ndev, link->open ? 0 : 1);
149+ if (link->open) {
150+ netif_device_attach(ndev);
151+ netif_start_queue(ndev);
152+ }
153+ }
154+
155+ return 0;
156+}
157+#endif
158+
159+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
160 static int prism2_event(event_t event, int priority,
161 event_callback_args_t *args)
162 {
163@@ -924,7 +1004,7 @@
164 }
165 return 0;
166 }
167-
168+#endif
169
170 #if LINUX_VERSION_CODE > KERNEL_VERSION(2,5,67)
171 #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,13))
172@@ -983,11 +1063,20 @@
173 .drv = {
174 .name = "hostap_cs",
175 },
176+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,15))
177+ .probe = prism2_attach,
178+ .remove = prism2_detach,
179+ .suspend = prism2_suspend1,
180+ .resume = prism2_resume1,
181+#else
182 .attach = prism2_attach,
183 .detach = prism2_detach,
184+#endif
185 .owner = THIS_MODULE,
186 #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,13))
187+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
188 .event = prism2_event,
189+#endif
190 .id_table = hostap_cs_ids,
191 #endif
192 };
diff --git a/meta/packages/hostap/hostap-modules/mtx_compat.diff b/meta/packages/hostap/hostap-modules/mtx_compat.diff
new file mode 100644
index 0000000000..c2d6662d69
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/mtx_compat.diff
@@ -0,0 +1,20 @@
1--- driver/modules/hostap_compat.h.orig 2004-08-09 16:16:48.359929856 +0200
2+++ driver/modules/hostap_compat.h 2004-08-09 16:17:12.383277752 +0200
3@@ -13,7 +13,7 @@
4 MOD_INC_USE_COUNT; \
5 if (schedule_task((q)) == 0) \
6 MOD_DEC_USE_COUNT;
7-
8+/*
9 static inline void flush_scheduled_work(void)
10 {
11 flush_scheduled_tasks();
12@@ -27,7 +27,7 @@
13 tq->routine = routine;
14 tq->data = data;
15 }
16-
17+*/
18 #else /* kernel < 2.5.44 */
19
20 #define HOSTAP_QUEUE struct work_struct
diff --git a/meta/packages/hostap/hostap-modules/mtx_hostap_deferred_irq.diff b/meta/packages/hostap/hostap-modules/mtx_hostap_deferred_irq.diff
new file mode 100644
index 0000000000..e979b72d93
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/mtx_hostap_deferred_irq.diff
@@ -0,0 +1,81 @@
1--- driver/modules/hostap_pci.c.orig 2004-11-30 06:41:48.000000000 +0100
2+++ driver/modules/hostap_pci.c 2005-01-17 19:47:33.710400496 +0100
3@@ -50,6 +50,13 @@
4 };
5
6
7+#define DEFERRED_IRQ_INITIALIZATION
8+
9+#ifdef DEFERRED_IRQ_INITIALIZATION
10+struct net_device *devb[MAX_PARM_DEVICES];
11+#endif
12+
13+
14 #ifdef PRISM2_IO_DEBUG
15
16 static inline void hfa384x_outb_debug(struct net_device *dev, int a, u8 v)
17@@ -280,6 +287,10 @@
18
19 pci_set_drvdata(pdev, dev);
20
21+#ifdef DEFERRED_IRQ_INITIALIZATION
22+ printk("%s: deferred initialization of IRQs\n", dev_info);
23+ devb[cards_found-1] = dev;
24+#else
25 if (request_irq(dev->irq, prism2_interrupt, SA_SHIRQ, dev->name,
26 dev)) {
27 printk(KERN_WARNING "%s: request_irq failed\n", dev->name);
28@@ -295,7 +306,7 @@
29
30 printk(KERN_INFO "%s: Intersil Prism2.5 PCI: "
31 "mem=0x%lx, irq=%d\n", dev->name, phymem, dev->irq);
32-
33+#endif
34 return hostap_hw_ready(dev);
35
36 fail:
37@@ -399,18 +410,43 @@
38 };
39
40
41+#ifdef DEFERRED_IRQ_INITIALIZATION
42+static void deferred_init(int num_devices)
43+{
44+ int n;
45+ for (n=0; n<num_devices && n<MAX_PARM_DEVICES; n++)
46+ {
47+ if (request_irq(devb[n]->irq, prism2_interrupt, SA_SHIRQ, devb[n]->name,
48+ devb[n])) {
49+ printk(KERN_WARNING "%s: request_irq failed\n", devb[n]->name);
50+ }
51+ if (prism2_hw_config(devb[n], 1)) {
52+ printk(KERN_DEBUG "%s: hardware initialization failed\n", devb[n]->name)
53+;
54+ }
55+ printk(KERN_INFO "%s: Intersil Prism2.5 PCI: irq=%d\n", devb[n]->name, devb[n]->
56+irq);
57+ }
58+}
59+#endif
60+
61 static int __init init_prism2_pci(void)
62 {
63 printk(KERN_INFO "%s: %s\n", dev_info, version);
64
65 #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,10))
66- if (pci_register_driver(&prism2_pci_drv_id) <= 0) {
67+ int n;
68+ if ((n=pci_register_driver(&prism2_pci_drv_id)) <= 0) {
69 printk("hostap_pci: No devices found, driver not "
70 "installed.\n");
71 pci_unregister_driver(&prism2_pci_drv_id);
72 return -ENODEV;
73 }
74
75+#ifdef DEFERRED_IRQ_INITIALIZATION
76+ deferred_init(n);
77+#endif
78+
79 return 0;
80 #else
81 return pci_register_driver(&prism2_pci_drv_id);