diff options
Diffstat (limited to 'meta/packages/hal')
-rw-r--r-- | meta/packages/hal/files/hal-right-input-h.patch | 29 | ||||
-rw-r--r-- | meta/packages/hal/hal-0.5.11/fix-configure.diff | 22 | ||||
-rw-r--r-- | meta/packages/hal/hal-info.inc | 20 | ||||
-rw-r--r-- | meta/packages/hal/hal-info_20080508.bb | 1 | ||||
-rw-r--r-- | meta/packages/hal/hal.inc | 94 | ||||
-rw-r--r-- | meta/packages/hal/hal_0.5.11.bb | 16 |
6 files changed, 182 insertions, 0 deletions
diff --git a/meta/packages/hal/files/hal-right-input-h.patch b/meta/packages/hal/files/hal-right-input-h.patch new file mode 100644 index 0000000000..f820b7790a --- /dev/null +++ b/meta/packages/hal/files/hal-right-input-h.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | diff --git a/configure.in b/configure.in | ||
2 | index e76ff51..5e8cc21 100644 | ||
3 | --- a/configure.in | ||
4 | +++ b/configure.in | ||
5 | @@ -983,6 +983,11 @@ AC_ARG_WITH([linux-input-header], | ||
6 | [Use an given Linux input.h rather than that installed on the system (<linux/input.h>)])) | ||
7 | if test "x$with_linux_input_header" != "x"; then | ||
8 | AC_DEFINE_UNQUOTED(HAL_LINUX_INPUT_HEADER_H, "$with_linux_input_header", [If set, the header to use instead of <linux/input.h>]) | ||
9 | + LINUX_INPUT_H=$with_linux_input_header | ||
10 | + AC_SUBST(LINUX_INPUT_H) | ||
11 | +else | ||
12 | + LINUX_INPUT_H=/usr/include/linux/input.h | ||
13 | + AC_SUBST(LINUX_INPUT_H) | ||
14 | fi | ||
15 | |||
16 | dnl | ||
17 | diff --git a/tools/Makefile.am b/tools/Makefile.am | ||
18 | index ae03edd..7d1cbab 100644 | ||
19 | --- a/tools/Makefile.am | ||
20 | +++ b/tools/Makefile.am | ||
21 | @@ -79,7 +79,7 @@ endif | ||
22 | if BUILD_KEYMAPS | ||
23 | |||
24 | if HAVE_GPERF | ||
25 | -hal-setup-keymap-keys.txt: /usr/include/linux/input.h | ||
26 | +hal-setup-keymap-keys.txt: @LINUX_INPUT_H@ | ||
27 | awk '/^#define.*KEY_/ { if ($$2 != "KEY_MAX") { print substr($$2, 5) } }' < $< > $@ | ||
28 | |||
29 | hal-setup-keymap-hash-name.gperf: hal-setup-keymap-keys.txt | ||
diff --git a/meta/packages/hal/hal-0.5.11/fix-configure.diff b/meta/packages/hal/hal-0.5.11/fix-configure.diff new file mode 100644 index 0000000000..7d9d42d69f --- /dev/null +++ b/meta/packages/hal/hal-0.5.11/fix-configure.diff | |||
@@ -0,0 +1,22 @@ | |||
1 | From: Rémi Cardona <remi@gentoo.org> | ||
2 | Date: Sat, 9 Aug 2008 15:04:07 +0000 (+0200) | ||
3 | Subject: add libtool-2.2 support | ||
4 | X-Git-Url: http://gitweb.freedesktop.org/?p=hal.git;a=commitdiff;h=c8a1aedf87bbb200fc5daa0ec8559a2d84fbb61d | ||
5 | |||
6 | add libtool-2.2 support | ||
7 | |||
8 | Fix for aclocal to work properly with libtool 2.2 which no longer | ||
9 | checks for C++ automatically (this patch is of course backwards | ||
10 | compatible with libtool 1.5.x) | ||
11 | --- | ||
12 | |||
13 | --- a/configure.in | ||
14 | +++ b/configure.in | ||
15 | @@ -29,6 +29,7 @@ AC_SUBST(LT_AGE) | ||
16 | |||
17 | AC_ISC_POSIX | ||
18 | AC_PROG_CC | ||
19 | +AC_PROG_CXX | ||
20 | AM_PROG_CC_C_O | ||
21 | AC_HEADER_STDC | ||
22 | AC_PROG_LIBTOOL | ||
diff --git a/meta/packages/hal/hal-info.inc b/meta/packages/hal/hal-info.inc new file mode 100644 index 0000000000..635fd0aa41 --- /dev/null +++ b/meta/packages/hal/hal-info.inc | |||
@@ -0,0 +1,20 @@ | |||
1 | DESCRIPTION = "Hardware Abstraction Layer device information" | ||
2 | HOMEPAGE = "http://hal.freedesktop.org/" | ||
3 | SECTION = "unknown" | ||
4 | LICENSE = "GPL AFL" | ||
5 | |||
6 | SRC_URI = "http://hal.freedesktop.org/releases/${PN}-${PV}.tar.gz" | ||
7 | S = "${WORKDIR}/${PN}-${PV}" | ||
8 | |||
9 | inherit autotools pkgconfig | ||
10 | |||
11 | EXTRA_OECONF = "--disable-recall --disable-video" | ||
12 | |||
13 | do_configure() { | ||
14 | gnu-configize | ||
15 | libtoolize --force | ||
16 | oe_runconf | ||
17 | } | ||
18 | |||
19 | PACKAGE_ARCH = "all" | ||
20 | FILES_${PN} += "${datadir}/hal/" | ||
diff --git a/meta/packages/hal/hal-info_20080508.bb b/meta/packages/hal/hal-info_20080508.bb new file mode 100644 index 0000000000..e6d50e3981 --- /dev/null +++ b/meta/packages/hal/hal-info_20080508.bb | |||
@@ -0,0 +1 @@ | |||
require hal-info.inc | |||
diff --git a/meta/packages/hal/hal.inc b/meta/packages/hal/hal.inc new file mode 100644 index 0000000000..d0c74e84af --- /dev/null +++ b/meta/packages/hal/hal.inc | |||
@@ -0,0 +1,94 @@ | |||
1 | DESCRIPTION = "Hardware Abstraction Layer" | ||
2 | HOMEPAGE = "http://freedesktop.org/Software/hal" | ||
3 | SECTION = "unknown" | ||
4 | LICENSE = "GPL LGPL AFL" | ||
5 | |||
6 | SRC_URI = "http://hal.freedesktop.org/releases/hal-${PV}.tar.gz" | ||
7 | |||
8 | S = "${WORKDIR}/hal-${PV}" | ||
9 | |||
10 | inherit autotools pkgconfig | ||
11 | |||
12 | DEPENDS = "virtual/kernel dbus-glib udev intltool intltool-native expat libusb gperf-native" | ||
13 | RDEPENDS += "udev hal-info" | ||
14 | RRECOMMENDS = "udev-utils" | ||
15 | |||
16 | SRC_URI += "file://99_hal \ | ||
17 | file://20hal \ | ||
18 | " | ||
19 | |||
20 | LEAD_SONAME = "libhal.so" | ||
21 | |||
22 | # machines with pci and acpi get a machine dependant hal | ||
23 | EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \ | ||
24 | --with-expat=${STAGING_LIBDIR}/.. \ | ||
25 | --with-dbus-sys=${sysconfdir}/dbus-1/system.d \ | ||
26 | --with-hotplug=${sysconfdir}/hotplug.d \ | ||
27 | --disable-docbook-docs \ | ||
28 | --disable-policy-kit \ | ||
29 | --disable-pmu \ | ||
30 | --disable-pnp-ids \ | ||
31 | ${@base_contains('COMBINED_FEATURES', 'pci', '--enable-pci --enable-pci-ids', '--disable-pci --disable-pci-ids',d)} \ | ||
32 | ${@base_contains('MACHINE_FEATURES', 'acpi', '--enable-acpi', '--disable-acpi',d)} \ | ||
33 | " | ||
34 | |||
35 | MY_ARCH := "${PACKAGE_ARCH}" | ||
36 | PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'acpi', '${MACHINE_ARCH}', '${MY_ARCH}',d)}" | ||
37 | PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'pci', '${MACHINE_ARCH}', '${MY_ARCH}',d)}" | ||
38 | |||
39 | do_install_append() { | ||
40 | install -d ${D}/etc/default/volatiles | ||
41 | install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles | ||
42 | install -d ${D}/etc/dbus-1/event.d | ||
43 | install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d | ||
44 | } | ||
45 | |||
46 | do_stage() { | ||
47 | oe_libinstall -C libhal -a -so libhal ${STAGING_LIBDIR} | ||
48 | oe_libinstall -C libhal-storage -a -so libhal-storage ${STAGING_LIBDIR} | ||
49 | |||
50 | install -d ${STAGING_INCDIR}/hal | ||
51 | install -m 0644 libhal/libhal.h ${STAGING_INCDIR}/hal | ||
52 | install -m 0644 libhal-storage/libhal-storage.h ${STAGING_INCDIR}/hal | ||
53 | } | ||
54 | |||
55 | # At the time the postinst runs, dbus might not be setup so only restart if running | ||
56 | pkg_postinst_hal () { | ||
57 | # can't do this offline | ||
58 | if [ "x$D" != "x" ]; then | ||
59 | exit 1 | ||
60 | fi | ||
61 | |||
62 | grep haldaemon /etc/group || addgroup haldaemon | ||
63 | grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL | ||
64 | |||
65 | /etc/init.d/populate-volatile.sh update | ||
66 | |||
67 | DBUSPID=`pidof dbus-daemon` | ||
68 | |||
69 | if [ "x$DBUSPID" != "x" ]; then | ||
70 | /etc/init.d/dbus-1 force-reload | ||
71 | fi | ||
72 | } | ||
73 | |||
74 | pkg_postrm_hal () { | ||
75 | deluser haldaemon || true | ||
76 | delgroup haldaemon || true | ||
77 | } | ||
78 | |||
79 | FILES_${PN} = "${sysconfdir} \ | ||
80 | ${bindir}/lshal \ | ||
81 | ${bindir}/hal-find-by-capability \ | ||
82 | ${bindir}/hal-find-by-property \ | ||
83 | ${bindir}/hal-device \ | ||
84 | ${bindir}/hal-get-property \ | ||
85 | ${bindir}/hal-set-property \ | ||
86 | ${bindir}/hal-lock \ | ||
87 | ${bindir}/hal-is-caller-locked-out \ | ||
88 | ${sbindir} \ | ||
89 | ${libdir}/libhal.so.* \ | ||
90 | ${libdir}/libhal-storage.so.* \ | ||
91 | ${libdir}/hal \ | ||
92 | ${libexecdir} \ | ||
93 | ${datadir}/hal/fdi \ | ||
94 | ${datadir}/hal/scripts" | ||
diff --git a/meta/packages/hal/hal_0.5.11.bb b/meta/packages/hal/hal_0.5.11.bb new file mode 100644 index 0000000000..f13a3213ee --- /dev/null +++ b/meta/packages/hal/hal_0.5.11.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | require hal.inc | ||
2 | |||
3 | PR = "r1" | ||
4 | |||
5 | SRC_URI += " file://hal-right-input-h.patch;patch=1 \ | ||
6 | file://fix-configure.diff;patch=1" | ||
7 | |||
8 | EXTRA_OECONF += "--with-linux-input-header=${STAGING_INCDIR}/linux/input.h" | ||
9 | |||
10 | PACKAGES =+ "libhal libhal-storage" | ||
11 | |||
12 | FILES_libhal = "${libdir}/libhal.so.*" | ||
13 | FILES_libhal-storage = "${libdir}/libhal-storage.so.*" | ||
14 | |||
15 | FILES_${PN} =+ "${bindir}/hal-disable-polling \ | ||
16 | ${bindir}/hal-setup-keymap" | ||