summaryrefslogtreecommitdiffstats
path: root/meta/packages/hal/hal_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/hal/hal_git.bb')
-rw-r--r--meta/packages/hal/hal_git.bb76
1 files changed, 3 insertions, 73 deletions
diff --git a/meta/packages/hal/hal_git.bb b/meta/packages/hal/hal_git.bb
index 85bb777d5f..34ccfe9cf2 100644
--- a/meta/packages/hal/hal_git.bb
+++ b/meta/packages/hal/hal_git.bb
@@ -1,16 +1,7 @@
1DESCRIPTION = "Hardware Abstraction Layer" 1require hal.inc
2HOMEPAGE = "http://freedesktop.org/Software/hal"
3BUGTRACKER = "http://bugs.freedesktop.org/buglist.cgi?product=hal"
4SECTION = "unknown"
5
6LICENSE = "GPLv2+ | AFL"
7
8DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat libusb"
9RDEPENDS_${PN} += "udev hal-info"
10RRECOMMENDS_${PN} += "udev-utils"
11 2
12PV = "0.5.9.1+git${SRCDATE}" 3PV = "0.5.9.1+git${SRCDATE}"
13PR = "r4" 4PR = "r5"
14 5
15SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \ 6SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
16 file://20hal \ 7 file://20hal \
@@ -18,65 +9,4 @@ SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
18 9
19S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
20 11
21inherit autotools pkgconfig 12DEFAULT_PREFERENCE = "-1"
22
23EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
24 --with-expat=${STAGING_DIR_HOST}${prefix} \
25 --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
26 --with-hotplug=${sysconfdir}/hotplug.d \
27 --disable-docbook-docs \
28 --disable-policy-kit \
29 --disable-acpi --disable-acpi-acpid --disable-acpi-proc \
30 --disable-sonypic \
31 --disable-pmu --disable-pci \
32 --disable-pci-ids --disable-pnp-ids \
33 "
34
35do_install_append() {
36 install -d ${D}/etc/default/volatiles
37 install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
38 install -d ${D}/etc/dbus-1/event.d
39 install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
40}
41
42# At the time the postinst runs, dbus might not be setup so only restart if running
43pkg_postinst_hal () {
44 # can't do this offline
45 if [ "x$D" != "x" ]; then
46 exit 1
47 fi
48
49 /etc/init.d/populate-volatile.sh update
50
51 grep haldaemon /etc/group || addgroup haldaemon
52 grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
53
54 DBUSPID=`pidof dbus-daemon`
55
56 if [ "x$DBUSPID" != "x" ]; then
57 /etc/init.d/dbus-1 reload
58 fi
59}
60
61pkg_postrm_hal () {
62 deluser haldaemon || true
63 delgroup haldaemon || true
64}
65
66FILES_${PN} = "${sysconfdir} \
67 ${bindir}/lshal \
68 ${bindir}/hal-find-by-capability \
69 ${bindir}/hal-find-by-property \
70 ${bindir}/hal-device \
71 ${bindir}/hal-get-property \
72 ${bindir}/hal-set-property \
73 ${bindir}/hal-lock \
74 ${bindir}/hal-is-caller-locked-out \
75 ${bindir}/hal-disable-polling \
76 ${sbindir} \
77 ${libdir}/libhal.so.* \
78 ${libdir}/libhal-storage.so.* \
79 ${libdir}/hal \
80 ${libexecdir} \
81 ${datadir}/hal/fdi \
82 ${datadir}/hal/scripts"