summaryrefslogtreecommitdiffstats
path: root/meta/packages/gtk+/gtk+-2.6.7
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gtk+/gtk+-2.6.7')
-rw-r--r--meta/packages/gtk+/gtk+-2.6.7/automake-lossage.patch24
-rw-r--r--meta/packages/gtk+/gtk+-2.6.7/disable-tooltips.patch11
-rw-r--r--meta/packages/gtk+/gtk+-2.6.7/gtk+-handhelds.patch186
-rw-r--r--meta/packages/gtk+/gtk+-2.6.7/gtklabel-center.patch13
-rw-r--r--meta/packages/gtk+/gtk+-2.6.7/gtklabel-resize-patch10
-rw-r--r--meta/packages/gtk+/gtk+-2.6.7/hardcoded_libtool.patch29
-rw-r--r--meta/packages/gtk+/gtk+-2.6.7/menu-deactivate.patch50
-rw-r--r--meta/packages/gtk+/gtk+-2.6.7/no-demos.patch10
-rw-r--r--meta/packages/gtk+/gtk+-2.6.7/no-xwc.patch151
-rw-r--r--meta/packages/gtk+/gtk+-2.6.7/scroll-timings.patch15
-rw-r--r--meta/packages/gtk+/gtk+-2.6.7/single-click.patch54
-rw-r--r--meta/packages/gtk+/gtk+-2.6.7/small-gtkfilesel.patch267
-rw-r--r--meta/packages/gtk+/gtk+-2.6.7/spinbutton.patch128
13 files changed, 948 insertions, 0 deletions
diff --git a/meta/packages/gtk+/gtk+-2.6.7/automake-lossage.patch b/meta/packages/gtk+/gtk+-2.6.7/automake-lossage.patch
new file mode 100644
index 0000000000..0d423ddbb9
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.6.7/automake-lossage.patch
@@ -0,0 +1,24 @@
1--- gtk+-2.4.1/docs/tutorial/Makefile.am~ 2003-05-06 22:54:20.000000000 +0100
2+++ gtk+-2.4.1/docs/tutorial/Makefile.am 2004-05-08 12:31:41.000000000 +0100
3@@ -52,21 +52,5 @@
4
5 dist-hook: html
6 cp -Rp $(srcdir)/html $(distdir)
7-else
8-html:
9- echo "***"
10- echo "*** Warning: Tutorial not built"
11- echo "***"
12-
13-pdf:
14- echo "***"
15- echo "*** Warning: Tutorial not built"
16- echo "***"
17-
18-dist-hook:
19- echo "***"
20- echo "*** Warning: Tutorial not built"
21- echo "*** DISTRIBUTION IS INCOMPLETE"
22- echo "***"
23 endif
24
diff --git a/meta/packages/gtk+/gtk+-2.6.7/disable-tooltips.patch b/meta/packages/gtk+/gtk+-2.6.7/disable-tooltips.patch
new file mode 100644
index 0000000000..d71d839c3c
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.6.7/disable-tooltips.patch
@@ -0,0 +1,11 @@
1--- gtk+-2.4.3/gtk/gtktooltips.c.old 2004-07-04 18:52:04.000000000 +0100
2+++ gtk+-2.4.3/gtk/gtktooltips.c 2004-07-04 18:52:08.000000000 +0100
3@@ -118,7 +118,7 @@
4 tooltips->tips_data_list = NULL;
5
6 tooltips->delay = DEFAULT_DELAY;
7- tooltips->enabled = TRUE;
8+ tooltips->enabled = FALSE;
9 tooltips->timer_tag = 0;
10 tooltips->use_sticky_delay = FALSE;
11 tooltips->last_popdown.tv_sec = -1;
diff --git a/meta/packages/gtk+/gtk+-2.6.7/gtk+-handhelds.patch b/meta/packages/gtk+/gtk+-2.6.7/gtk+-handhelds.patch
new file mode 100644
index 0000000000..2c5fc39d23
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.6.7/gtk+-handhelds.patch
@@ -0,0 +1,186 @@
1--- gtk+-2.4.1/gtk/gtkcalendar.c 2004-03-06 14:37:26.000000000 +1100
2+++ gtk+-2.4.1/gtk/gtkcalendar.c 2004-05-26 14:58:57.000000000 +1000
3@@ -340,6 +340,9 @@
4 static void gtk_calendar_select_and_focus_day (GtkCalendar *calendar,
5 guint day);
6
7+static void gtk_calendar_do_select_day (GtkCalendar *calendar,
8+ guint day);
9+
10 static void gtk_calendar_paint_arrow (GtkWidget *widget,
11 guint arrow);
12 static void gtk_calendar_paint_day_num (GtkWidget *widget,
13@@ -861,13 +864,13 @@
14 if (month_len < calendar->selected_day)
15 {
16 calendar->selected_day = 0;
17- gtk_calendar_select_day (calendar, month_len);
18+ gtk_calendar_do_select_day (calendar, month_len);
19 }
20 else
21 {
22 if (calendar->selected_day < 0)
23 calendar->selected_day = calendar->selected_day + 1 + month_length[leap (calendar->year)][calendar->month + 1];
24- gtk_calendar_select_day (calendar, calendar->selected_day);
25+ gtk_calendar_do_select_day (calendar, calendar->selected_day);
26 }
27
28 gtk_widget_queue_draw (GTK_WIDGET (calendar));
29@@ -908,10 +911,10 @@
30 if (month_len < calendar->selected_day)
31 {
32 calendar->selected_day = 0;
33- gtk_calendar_select_day (calendar, month_len);
34+ gtk_calendar_do_select_day (calendar, month_len);
35 }
36 else
37- gtk_calendar_select_day (calendar, calendar->selected_day);
38+ gtk_calendar_do_select_day (calendar, calendar->selected_day);
39
40 gtk_widget_queue_draw (GTK_WIDGET (calendar));
41 gtk_calendar_thaw (calendar);
42@@ -939,10 +942,10 @@
43 if (month_len < calendar->selected_day)
44 {
45 calendar->selected_day = 0;
46- gtk_calendar_select_day (calendar, month_len);
47+ gtk_calendar_do_select_day (calendar, month_len);
48 }
49 else
50- gtk_calendar_select_day (calendar, calendar->selected_day);
51+ gtk_calendar_do_select_day (calendar, calendar->selected_day);
52
53 gtk_widget_queue_draw (GTK_WIDGET (calendar));
54 gtk_calendar_thaw (calendar);
55@@ -974,10 +977,10 @@
56 if (month_len < calendar->selected_day)
57 {
58 calendar->selected_day = 0;
59- gtk_calendar_select_day (calendar, month_len);
60+ gtk_calendar_do_select_day (calendar, month_len);
61 }
62 else
63- gtk_calendar_select_day (calendar, calendar->selected_day);
64+ gtk_calendar_do_select_day (calendar, calendar->selected_day);
65
66 gtk_widget_queue_draw (GTK_WIDGET (calendar));
67 gtk_calendar_thaw (calendar);
68@@ -2480,9 +2483,9 @@
69 return TRUE;
70 }
71
72-void
73-gtk_calendar_select_day (GtkCalendar *calendar,
74- guint day)
75+static void
76+gtk_calendar_do_select_day (GtkCalendar *calendar,
77+ guint day)
78 {
79 g_return_if_fail (GTK_IS_CALENDAR (calendar));
80 g_return_if_fail (day <= 31);
81@@ -2499,6 +2502,13 @@
82 if (GTK_WIDGET_DRAWABLE (GTK_WIDGET (calendar)))
83 gtk_calendar_paint_day_num (GTK_WIDGET (calendar), selected_day);
84 }
85+}
86+
87+void
88+gtk_calendar_select_day (GtkCalendar *calendar,
89+ guint day)
90+{
91+ gtk_calendar_do_select_day (calendar, day);
92
93 calendar->selected_day = day;
94
95--- gtk+-2.4.1/gtk/gtkentry.c 2004-04-22 08:08:08.000000000 +1000
96+++ gtk+-2.4.1/gtk/gtkentry.c 2004-05-26 14:52:17.000000000 +1000
97@@ -557,6 +557,15 @@
98 0.0,
99 G_PARAM_READABLE | G_PARAM_WRITABLE));
100
101+ gtk_widget_class_install_style_property (widget_class,
102+ g_param_spec_int ("min_width",
103+ _("Minimum width"),
104+ _("Minimum width of the entry field"),
105+ 0,
106+ G_MAXINT,
107+ MIN_ENTRY_WIDTH,
108+ G_PARAM_READABLE));
109+
110 signals[POPULATE_POPUP] =
111 g_signal_new ("populate_popup",
112 G_OBJECT_CLASS_TYPE (gobject_class),
113@@ -1124,7 +1133,7 @@
114 {
115 GtkEntry *entry = GTK_ENTRY (widget);
116 PangoFontMetrics *metrics;
117- gint xborder, yborder;
118+ gint xborder, yborder, min_width;
119 PangoContext *context;
120
121 gtk_widget_ensure_style (widget);
122@@ -1140,9 +1149,11 @@
123
124 xborder += INNER_BORDER;
125 yborder += INNER_BORDER;
126-
127+
128+ gtk_widget_style_get (widget, "min_width", &min_width, NULL);
129+
130 if (entry->width_chars < 0)
131- requisition->width = MIN_ENTRY_WIDTH + xborder * 2;
132+ requisition->width = min_width + xborder * 2;
133 else
134 {
135 gint char_width = pango_font_metrics_get_approximate_char_width (metrics);
136--- gtk+-2.4.1/gtk/gtkrange.c 2004-03-06 14:38:08.000000000 +1100
137+++ gtk+-2.4.1/gtk/gtkrange.c 2004-05-26 14:52:17.000000000 +1000
138@@ -180,6 +180,7 @@
139 static GtkWidgetClass *parent_class = NULL;
140 static guint signals[LAST_SIGNAL];
141
142+static GdkAtom recognize_protocols_atom, atom_atom;
143
144 GType
145 gtk_range_get_type (void)
146@@ -220,6 +221,9 @@
147 object_class = (GtkObjectClass*) class;
148 widget_class = (GtkWidgetClass*) class;
149
150+ recognize_protocols_atom = gdk_atom_intern ("RECOGNIZE_PROTOCOLS", FALSE);
151+ atom_atom = gdk_atom_intern ("ATOM", FALSE);
152+
153 parent_class = g_type_class_peek_parent (class);
154
155 gobject_class->set_property = gtk_range_set_property;
156@@ -815,6 +819,12 @@
157 &attributes, attributes_mask);
158 gdk_window_set_user_data (range->event_window, range);
159
160+ gdk_property_change (range->event_window,
161+ recognize_protocols_atom,
162+ atom_atom,
163+ 32, GDK_PROP_MODE_REPLACE,
164+ NULL, 0);
165+
166 widget->style = gtk_style_attach (widget->style, widget->window);
167 }
168
169@@ -1186,7 +1196,7 @@
170
171 /* ignore presses when we're already doing something else. */
172 if (range->layout->grab_location != MOUSE_OUTSIDE)
173- return FALSE;
174+ return TRUE;
175
176 range->layout->mouse_x = event->x;
177 range->layout->mouse_y = event->y;
178@@ -1364,7 +1374,7 @@
179 return TRUE;
180 }
181
182- return FALSE;
183+ return TRUE;
184 }
185
186 /**
diff --git a/meta/packages/gtk+/gtk+-2.6.7/gtklabel-center.patch b/meta/packages/gtk+/gtk+-2.6.7/gtklabel-center.patch
new file mode 100644
index 0000000000..b368cb4b7c
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.6.7/gtklabel-center.patch
@@ -0,0 +1,13 @@
1--- gtk+-2.6.7/gtk/gtklabel.c~ 2006-05-25 15:35:15.000000000 +0100
2+++ gtk+-2.6.7/gtk/gtklabel.c 2006-05-30 11:40:37.000000000 +0100
3@@ -2185,8 +2185,8 @@
4 req_width - misc->xpad);
5
6 y = floor (widget->allocation.y + (gint)misc->ypad
7- + MAX (((widget->allocation.height - widget->requisition.height) * misc->yalign)
8- + 0.5, 0));
9+ + ((widget->allocation.height - widget->requisition.height) * misc->yalign)
10+ + 0.5);
11
12 if (xp)
13 *xp = x;
diff --git a/meta/packages/gtk+/gtk+-2.6.7/gtklabel-resize-patch b/meta/packages/gtk+/gtk+-2.6.7/gtklabel-resize-patch
new file mode 100644
index 0000000000..df29656343
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.6.7/gtklabel-resize-patch
@@ -0,0 +1,10 @@
1--- gtk+-2.4.3/gtk/gtklabel.c~ 2004-06-11 13:50:34.000000000 +0100
2+++ gtk+-2.4.3/gtk/gtklabel.c 2004-07-05 13:33:57.000000000 +0100
3@@ -1623,6 +1623,7 @@
4
5 /* We have to clear the layout, fonts etc. may have changed */
6 gtk_label_clear_layout (label);
7+ gtk_widget_queue_resize (GTK_WIDGET (label));
8 }
9
10 static void
diff --git a/meta/packages/gtk+/gtk+-2.6.7/hardcoded_libtool.patch b/meta/packages/gtk+/gtk+-2.6.7/hardcoded_libtool.patch
new file mode 100644
index 0000000000..b2afddcc61
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.6.7/hardcoded_libtool.patch
@@ -0,0 +1,29 @@
1--- gtk+-2.6.0/configure.in.old 2005-01-01 16:23:45.000000000 +0000
2+++ gtk+-2.6.0/configure.in 2005-01-01 16:24:03.000000000 +0000
3@@ -360,7 +360,7 @@
4 AC_MSG_CHECKING([Whether to write dependencies into .pc files])
5 case $enable_explicit_deps in
6 auto)
7- deplib_check_method=`(./libtool --config; echo eval echo \\$deplib_check_method) | sh`
8+ deplib_check_method=`($host_alias-libtool --config; echo eval echo \\$deplib_check_method) | sh`
9 if test "X$deplib_check_method" = Xnone || test "x$enable_static" = xyes ; then
10 enable_explicit_deps=yes
11 else
12@@ -688,7 +688,7 @@
13 dnl Now we check to see if our libtool supports shared lib deps
14 dnl (in a rather ugly way even)
15 if $dynworks; then
16- pixbuf_libtool_config="${CONFIG_SHELL-/bin/sh} ./libtool --config"
17+ pixbuf_libtool_config="${CONFIG_SHELL-/bin/sh} $host_alias-libtool --config"
18 pixbuf_deplibs_check=`$pixbuf_libtool_config | \
19 grep '^[[a-z_]]*check[[a-z_]]*_method=[['\''"]]' | \
20 sed 's/.*[['\''"]]\(.*\)[['\''"]]$/\1/'`
21@@ -1512,7 +1512,7 @@
22 #
23 # We are using gmodule-no-export now, but I'm leaving the stripping
24 # code in place for now, since pango and atk still require gmodule.
25-export_dynamic=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
26+export_dynamic=`($host_alias-libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
27 if test -n "$export_dynamic"; then
28 GDK_PIXBUF_DEP_LIBS=`echo $GDK_PIXBUF_DEP_LIBS | sed -e "s/$export_dynamic//"`
29 GDK_PIXBUF_XLIB_DEP_LIBS=`echo $GDK_PIXBUF_XLIB_DEP_LIBS | sed -e "s/$export_dynamic//"`
diff --git a/meta/packages/gtk+/gtk+-2.6.7/menu-deactivate.patch b/meta/packages/gtk+/gtk+-2.6.7/menu-deactivate.patch
new file mode 100644
index 0000000000..29e665fbf3
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.6.7/menu-deactivate.patch
@@ -0,0 +1,50 @@
1--- gtk+-2.4.4/gtk/gtkmenushell.c.old Thu Aug 26 23:45:28 2004
2+++ gtk+-2.4.4/gtk/gtkmenushell.c Fri Aug 27 00:13:33 2004
3@@ -37,7 +37,7 @@
4 #include "gtktearoffmenuitem.h"
5 #include "gtkwindow.h"
6
7-#define MENU_SHELL_TIMEOUT 500
8+#define MENU_SHELL_TIMEOUT 2000
9
10 enum {
11 DEACTIVATE,
12@@ -156,6 +156,7 @@
13 static GtkContainerClass *parent_class = NULL;
14 static guint menu_shell_signals[LAST_SIGNAL] = { 0 };
15
16+static int last_crossing_time;
17
18 GType
19 gtk_menu_shell_get_type (void)
20@@ -418,6 +419,7 @@
21 gtk_grab_add (GTK_WIDGET (menu_shell));
22 menu_shell->have_grab = TRUE;
23 menu_shell->active = TRUE;
24+ last_crossing_time = 0;
25 }
26 }
27
28@@ -545,6 +547,13 @@
29 menu_shell->activate_time = 0;
30 deactivate = FALSE;
31 }
32+
33+ if (last_crossing_time != 0
34+ && ((event->time - last_crossing_time) < 500))
35+ {
36+ last_crossing_time = 0;
37+ deactivate = FALSE;
38+ }
39
40 if (deactivate)
41 {
42@@ -597,6 +606,8 @@
43 if (menu_shell->active)
44 {
45 menu_item = gtk_get_event_widget ((GdkEvent*) event);
46+
47+ last_crossing_time = event->time;
48
49 if (!menu_item ||
50 (GTK_IS_MENU_ITEM (menu_item) &&
diff --git a/meta/packages/gtk+/gtk+-2.6.7/no-demos.patch b/meta/packages/gtk+/gtk+-2.6.7/no-demos.patch
new file mode 100644
index 0000000000..2f10a30dda
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.6.7/no-demos.patch
@@ -0,0 +1,10 @@
1--- gtk+-2.4.1/Makefile.am~ 2004-01-17 22:15:56.000000000 +0000
2+++ gtk+-2.4.1/Makefile.am 2004-05-08 12:25:32.000000000 +0100
3@@ -1,6 +1,6 @@
4 ## Makefile.am for GTK+
5
6-SRC_SUBDIRS = gdk-pixbuf gdk gtk modules demos tests contrib
7+SRC_SUBDIRS = gdk-pixbuf gdk gtk modules tests contrib
8 SUBDIRS = po po-properties $(SRC_SUBDIRS) docs build m4macros
9
10 # require automake 1.4
diff --git a/meta/packages/gtk+/gtk+-2.6.7/no-xwc.patch b/meta/packages/gtk+/gtk+-2.6.7/no-xwc.patch
new file mode 100644
index 0000000000..affb4a303e
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.6.7/no-xwc.patch
@@ -0,0 +1,151 @@
1diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkdrawable-x11.c gtk+-2.6.0/gdk/x11/gdkdrawable-x11.c
2--- ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkdrawable-x11.c 2004-11-30 14:57:14 +00:00
3+++ gtk+-2.6.0/gdk/x11/gdkdrawable-x11.c 2005-01-02 15:38:06 +00:00
4@@ -576,12 +576,14 @@
5 GDK_GC_GET_XGC (gc), x, y, (XChar2b *) text, text_length / 2);
6 }
7 }
8+#ifdef HAVE_XWC
9 else if (font->type == GDK_FONT_FONTSET)
10 {
11 XFontSet fontset = (XFontSet) GDK_FONT_XFONT (font);
12 XmbDrawString (xdisplay, impl->xid,
13 fontset, GDK_GC_GET_XGC (gc), x, y, text, text_length);
14 }
15+#endif
16 else
17 g_error("undefined font type\n");
18 }
19@@ -613,6 +615,7 @@
20 GDK_GC_GET_XGC (gc), x, y, text_8bit, text_length);
21 g_free (text_8bit);
22 }
23+#ifdef HAVE_XWC
24 else if (font->type == GDK_FONT_FONTSET)
25 {
26 if (sizeof(GdkWChar) == sizeof(wchar_t))
27@@ -633,6 +636,7 @@
28 g_free (text_wchar);
29 }
30 }
31+#endif
32 else
33 g_error("undefined font type\n");
34 }
35diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkfont-x11.c gtk+-2.6.0/gdk/x11/gdkfont-x11.c
36--- ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkfont-x11.c 2004-08-26 01:23:46 +01:00
37+++ gtk+-2.6.0/gdk/x11/gdkfont-x11.c 2005-01-02 15:45:39 +00:00
38@@ -525,10 +525,12 @@
39 width = XTextWidth16 (xfont, (XChar2b *) text, text_length / 2);
40 }
41 break;
42+#ifdef HAVE_XWC
43 case GDK_FONT_FONTSET:
44 fontset = (XFontSet) private->xfont;
45 width = XmbTextEscapement (fontset, text, text_length);
46 break;
47+#endif
48 default:
49 width = 0;
50 }
51@@ -578,6 +580,7 @@
52 width = 0;
53 }
54 break;
55+#ifdef HAVE_XWC
56 case GDK_FONT_FONTSET:
57 if (sizeof(GdkWChar) == sizeof(wchar_t))
58 {
59@@ -595,6 +598,7 @@
60 g_free (text_wchar);
61 }
62 break;
63+#endif
64 default:
65 width = 0;
66 }
67@@ -667,6 +671,7 @@
68 if (descent)
69 *descent = overall.descent;
70 break;
71+#ifdef HAVE_XWC
72 case GDK_FONT_FONTSET:
73 fontset = (XFontSet) private->xfont;
74 XmbTextExtents (fontset, text, text_length, &ink, &logical);
75@@ -681,6 +686,7 @@
76 if (descent)
77 *descent = ink.y + ink.height;
78 break;
79+#endif
80 }
81
82 }
83@@ -753,6 +759,7 @@
84 *descent = overall.descent;
85 break;
86 }
87+#ifdef HAVE_XWC
88 case GDK_FONT_FONTSET:
89 fontset = (XFontSet) private->xfont;
90
91@@ -780,6 +787,7 @@
92 if (descent)
93 *descent = ink.y + ink.height;
94 break;
95+#endif
96 }
97
98 }
99diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkim-x11.c gtk+-2.6.0/gdk/x11/gdkim-x11.c
100--- ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkim-x11.c 2004-11-17 00:55:10 +00:00
101+++ gtk+-2.6.0/gdk/x11/gdkim-x11.c 2005-01-02 15:42:04 +00:00
102@@ -48,6 +48,7 @@
103 void
104 _gdk_x11_initialize_locale (void)
105 {
106+#ifdef HAVE_XWC
107 wchar_t result;
108 gchar *current_locale;
109 static char *last_locale = NULL;
110@@ -93,7 +94,8 @@
111 GDK_NOTE (XIM,
112 g_message ("%s multi-byte string functions.",
113 gdk_use_mb ? "Using" : "Not using"));
114-
115+#endif
116+
117 return;
118 }
119
120@@ -136,6 +138,7 @@
121 {
122 gchar *mbstr;
123
124+#ifdef HAVE_XWC
125 if (gdk_use_mb)
126 {
127 GdkDisplay *display = find_a_display ();
128@@ -178,6 +181,7 @@
129 XFree (tpr.value);
130 }
131 else
132+#endif
133 {
134 gint length = 0;
135 gint i;
136@@ -210,6 +214,7 @@
137 gint
138 gdk_mbstowcs (GdkWChar *dest, const gchar *src, gint dest_max)
139 {
140+#ifdef HAVE_XWC
141 if (gdk_use_mb)
142 {
143 GdkDisplay *display = find_a_display ();
144@@ -242,6 +247,7 @@
145 return len_cpy;
146 }
147 else
148+#endif
149 {
150 gint i;
151
diff --git a/meta/packages/gtk+/gtk+-2.6.7/scroll-timings.patch b/meta/packages/gtk+/gtk+-2.6.7/scroll-timings.patch
new file mode 100644
index 0000000000..a38b21dcc2
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.6.7/scroll-timings.patch
@@ -0,0 +1,15 @@
1--- gtk+-2.4.4/gtk/gtkrange.c~ 2004-08-23 01:50:22.000000000 +0100
2+++ gtk+-2.4.4/gtk/gtkrange.c 2004-08-27 15:48:49.000000000 +0100
3@@ -35,9 +35,9 @@
4 #include "gtkintl.h"
5 #include "gtkscrollbar.h"
6
7-#define SCROLL_INITIAL_DELAY 250 /* must hold button this long before ... */
8-#define SCROLL_LATER_DELAY 100 /* ... it starts repeating at this rate */
9-#define UPDATE_DELAY 300 /* Delay for queued update */
10+#define SCROLL_INITIAL_DELAY 500 /* must hold button this long before ... */
11+#define SCROLL_LATER_DELAY 200 /* ... it starts repeating at this rate */
12+#define UPDATE_DELAY 1000 /* Delay for queued update */
13
14 enum {
15 PROP_0,
diff --git a/meta/packages/gtk+/gtk+-2.6.7/single-click.patch b/meta/packages/gtk+/gtk+-2.6.7/single-click.patch
new file mode 100644
index 0000000000..3bb208d4d6
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.6.7/single-click.patch
@@ -0,0 +1,54 @@
1diff -urNd ../gtk+-2.6.3-r0.old/gtk+-2.6.3/gtk/gtkcalendar.c gtk+-2.6.3/gtk/gtkcalendar.c
2--- ../gtk+-2.6.3-r0.old/gtk+-2.6.3/gtk/gtkcalendar.c 2005-04-06 16:57:04 +01:00
3+++ gtk+-2.6.3/gtk/gtkcalendar.c 2005-04-06 20:05:18 +01:00
4@@ -1023,9 +1023,11 @@
5 }
6
7 gtk_calendar_select_and_focus_day (calendar, day);
8- }
9+
10+ // This change causes the calendar to disappear after choosing a day
11+/* }
12 else if (event->type == GDK_2BUTTON_PRESS)
13- {
14+ {*/
15 private_data->in_drag = 0;
16 if (day_month == MONTH_CURRENT)
17 g_signal_emit (calendar,
18diff -urNd ../gtk+-2.6.3-r0.old/gtk+-2.6.3/gtk/gtkfilesel.c gtk+-2.6.3/gtk/gtkfilesel.c
19--- ../gtk+-2.6.3-r0.old/gtk+-2.6.3/gtk/gtkfilesel.c 2005-04-06 16:57:07 +01:00
20+++ gtk+-2.6.3/gtk/gtkfilesel.c 2005-04-07 13:40:32 +01:00
21@@ -2468,6 +2468,33 @@
22 if (fs->last_selected != NULL)
23 g_free (fs->last_selected);
24
25+ // Single-click directory entry
26+ if (new_names->len == 1)
27+ {
28+ GtkTreeView *tree_view;
29+ GtkTreeModel *model;
30+ GtkTreePath *path;
31+ GtkTreeIter iter;
32+ gboolean is_file;
33+
34+ tree_view = gtk_tree_selection_get_tree_view (selection);
35+
36+ if (gtk_tree_selection_get_selected (selection, &model, &iter))
37+ {
38+ path = gtk_tree_model_get_path (model, &iter);
39+ gtk_tree_model_get (model, &iter, ISFILE_COLUMN, &is_file, -1);
40+
41+ if (!is_file)
42+ {
43+ gtk_file_selection_dir_activate (tree_view, path,
44+ gtk_tree_view_get_column (tree_view, DIR_COLUMN),
45+ user_data);
46+ }
47+
48+ gtk_tree_path_free (path);
49+ }
50+ }
51+
52 fs->last_selected = g_strdup (g_ptr_array_index (new_names, index));
53 filename = get_real_filename (fs->last_selected, FALSE);
54
diff --git a/meta/packages/gtk+/gtk+-2.6.7/small-gtkfilesel.patch b/meta/packages/gtk+/gtk+-2.6.7/small-gtkfilesel.patch
new file mode 100644
index 0000000000..20bf4cf366
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.6.7/small-gtkfilesel.patch
@@ -0,0 +1,267 @@
1diff -urNd ../gtk+-2.4.4-r5/gtk+-2.4.4/gtk/gtkfilesel.c gtk+-2.4.4/gtk/gtkfilesel.c
2--- ../gtk+-2.4.4-r5/gtk+-2.4.4/gtk/gtkfilesel.c 2004-07-10 05:02:10.000000000 +0100
3+++ gtk+-2.4.4/gtk/gtkfilesel.c 2004-09-13 13:40:09.000000000 +0100
4@@ -68,6 +68,7 @@
5 #include "gtkprivate.h"
6 #include "gtkscrolledwindow.h"
7 #include "gtkstock.h"
8+#include "gtksignal.h"
9 #include "gtktreeselection.h"
10 #include "gtktreeview.h"
11 #include "gtkvbox.h"
12@@ -77,6 +78,7 @@
13 #include "gtkmessagedialog.h"
14 #include "gtkdnd.h"
15 #include "gtkeventbox.h"
16+#include "gtkimage.h"
17
18 #undef GTK_DISABLE_DEPRECATED
19 #include "gtkoptionmenu.h"
20@@ -245,7 +247,8 @@
21 };
22
23 enum {
24- DIR_COLUMN
25+ DIR_COLUMN,
26+ ISFILE_COLUMN
27 };
28
29 enum {
30@@ -400,6 +403,12 @@
31 GtkTreePath *path,
32 GtkTreeViewColumn *column,
33 gpointer user_data);
34+
35+static void gtk_file_selection_activate (GtkTreeView *tree_view,
36+ GtkTreePath *path,
37+ GtkTreeViewColumn *column,
38+ gpointer user_data);
39+
40 static void gtk_file_selection_file_changed (GtkTreeSelection *selection,
41 gpointer user_data);
42 static void gtk_file_selection_dir_activate (GtkTreeView *tree_view,
43@@ -419,6 +428,7 @@
44 static void gtk_file_selection_create_dir (GtkWidget *widget, gpointer data);
45 static void gtk_file_selection_delete_file (GtkWidget *widget, gpointer data);
46 static void gtk_file_selection_rename_file (GtkWidget *widget, gpointer data);
47+static void gtk_file_selection_style_set (GtkWidget *widget, GtkStyle *prev_style);
48
49 static void free_selected_names (GPtrArray *names);
50
51@@ -578,6 +588,23 @@
52 G_PARAM_WRITABLE));
53 object_class->destroy = gtk_file_selection_destroy;
54 widget_class->map = gtk_file_selection_map;
55+ widget_class->style_set = gtk_file_selection_style_set;
56+
57+ gtk_widget_class_install_style_property (widget_class,
58+ g_param_spec_boolean ("show_fileops_default",
59+ _("Show fileop buttons by default"),
60+ _("Whether file operation buttons are shown by default"),
61+ TRUE,
62+ G_PARAM_READABLE));
63+
64+ gtk_widget_class_install_style_property (widget_class,
65+ g_param_spec_int ("border_width",
66+ _("Border width"),
67+ _("Width of border around the main dialog area"),
68+ 0,
69+ G_MAXINT,
70+ 10,
71+ G_PARAM_READABLE));
72 }
73
74 static void gtk_file_selection_set_property (GObject *object,
75@@ -649,7 +676,29 @@
76 gtk_widget_grab_default (widget);
77 return FALSE;
78 }
79-
80+
81+static void
82+gtk_file_selection_style_set (GtkWidget *filesel,
83+ GtkStyle *prev_style)
84+{
85+ gboolean show_fileops;
86+ gint border_width;
87+
88+ gtk_widget_style_get (filesel,
89+ "show_fileops_default",
90+ &show_fileops,
91+ "border_width",
92+ &border_width,
93+ NULL);
94+
95+ gtk_container_set_border_width (GTK_CONTAINER (filesel), border_width);
96+
97+ if (show_fileops)
98+ gtk_file_selection_show_fileop_buttons (GTK_FILE_SELECTION (filesel));
99+ else
100+ gtk_file_selection_hide_fileop_buttons (GTK_FILE_SELECTION (filesel));
101+}
102+
103 static void
104 gtk_file_selection_init (GtkFileSelection *filesel)
105 {
106@@ -674,17 +723,15 @@
107
108 /* The dialog-sized vertical box */
109 filesel->main_vbox = dialog->vbox;
110- gtk_container_set_border_width (GTK_CONTAINER (filesel), 10);
111
112 /* The horizontal box containing create, rename etc. buttons */
113 filesel->button_area = gtk_hbutton_box_new ();
114 gtk_button_box_set_layout (GTK_BUTTON_BOX (filesel->button_area), GTK_BUTTONBOX_START);
115- gtk_box_set_spacing (GTK_BOX (filesel->button_area), 0);
116 gtk_box_pack_start (GTK_BOX (filesel->main_vbox), filesel->button_area,
117 FALSE, FALSE, 0);
118 gtk_widget_show (filesel->button_area);
119
120- gtk_file_selection_show_fileop_buttons (filesel);
121+ gtk_file_selection_style_set (GTK_WIDGET (filesel), NULL);
122
123 /* hbox for pulldown menu */
124 pulldown_hbox = gtk_hbox_new (TRUE, 5);
125@@ -723,25 +770,32 @@
126
127 /* The directories list */
128
129- model = gtk_list_store_new (1, G_TYPE_STRING);
130+ model = gtk_list_store_new (2, G_TYPE_STRING, G_TYPE_BOOLEAN); /* MA */
131 filesel->dir_list = gtk_tree_view_new_with_model (GTK_TREE_MODEL (model));
132 g_object_unref (model);
133
134- column = gtk_tree_view_column_new_with_attributes (_("Folders"),
135+ column = gtk_tree_view_column_new_with_attributes (/*_("Folders")*/ NULL,
136 gtk_cell_renderer_text_new (),
137 "text", DIR_COLUMN,
138 NULL);
139 label = gtk_label_new_with_mnemonic (_("Fol_ders"));
140 gtk_label_set_mnemonic_widget (GTK_LABEL (label), filesel->dir_list);
141 gtk_widget_show (label);
142- gtk_tree_view_column_set_widget (column, label);
143+
144+ /* gtk_tree_view_column_set_widget (column, label); */
145+ gtk_tree_view_set_headers_visible (GTK_TREE_VIEW (filesel->dir_list), FALSE);
146+
147 gtk_tree_view_column_set_sizing (column, GTK_TREE_VIEW_COLUMN_AUTOSIZE);
148 gtk_tree_view_append_column (GTK_TREE_VIEW (filesel->dir_list), column);
149
150 gtk_widget_set_size_request (filesel->dir_list,
151 DIR_LIST_WIDTH, DIR_LIST_HEIGHT);
152 g_signal_connect (filesel->dir_list, "row_activated",
153- G_CALLBACK (gtk_file_selection_dir_activate), filesel);
154+ G_CALLBACK (gtk_file_selection_activate), filesel);
155+
156+ g_signal_connect (gtk_tree_view_get_selection (GTK_TREE_VIEW (filesel->dir_list)), "changed",
157+ G_CALLBACK (gtk_file_selection_file_changed), filesel);
158+
159
160 /* gtk_clist_column_titles_passive (GTK_CLIST (filesel->dir_list)); */
161
162@@ -758,41 +812,6 @@
163 gtk_widget_show (filesel->dir_list);
164 gtk_widget_show (scrolled_win);
165
166- /* The files list */
167- model = gtk_list_store_new (1, G_TYPE_STRING);
168- filesel->file_list = gtk_tree_view_new_with_model (GTK_TREE_MODEL (model));
169- g_object_unref (model);
170-
171- column = gtk_tree_view_column_new_with_attributes (_("Files"),
172- gtk_cell_renderer_text_new (),
173- "text", FILE_COLUMN,
174- NULL);
175- label = gtk_label_new_with_mnemonic (_("_Files"));
176- gtk_label_set_mnemonic_widget (GTK_LABEL (label), filesel->file_list);
177- gtk_widget_show (label);
178- gtk_tree_view_column_set_widget (column, label);
179- gtk_tree_view_column_set_sizing (column, GTK_TREE_VIEW_COLUMN_AUTOSIZE);
180- gtk_tree_view_append_column (GTK_TREE_VIEW (filesel->file_list), column);
181-
182- gtk_widget_set_size_request (filesel->file_list,
183- FILE_LIST_WIDTH, FILE_LIST_HEIGHT);
184- g_signal_connect (filesel->file_list, "row_activated",
185- G_CALLBACK (gtk_file_selection_file_activate), filesel);
186- g_signal_connect (gtk_tree_view_get_selection (GTK_TREE_VIEW (filesel->file_list)), "changed",
187- G_CALLBACK (gtk_file_selection_file_changed), filesel);
188-
189- /* gtk_clist_column_titles_passive (GTK_CLIST (filesel->file_list)); */
190-
191- scrolled_win = gtk_scrolled_window_new (NULL, NULL);
192- gtk_scrolled_window_set_shadow_type (GTK_SCROLLED_WINDOW (scrolled_win), GTK_SHADOW_IN);
193- gtk_container_add (GTK_CONTAINER (scrolled_win), filesel->file_list);
194- gtk_scrolled_window_set_policy (GTK_SCROLLED_WINDOW (scrolled_win),
195- GTK_POLICY_AUTOMATIC, GTK_POLICY_ALWAYS);
196- gtk_container_set_border_width (GTK_CONTAINER (scrolled_win), 0);
197- gtk_container_add (GTK_CONTAINER (list_container), scrolled_win);
198- gtk_widget_show (filesel->file_list);
199- gtk_widget_show (scrolled_win);
200-
201 /* action area for packing buttons into. */
202 filesel->action_area = gtk_hbox_new (TRUE, 0);
203 gtk_box_pack_start (GTK_BOX (filesel->main_vbox), filesel->action_area,
204@@ -2008,6 +2027,23 @@
205 }
206
207 static void
208+gtk_file_selection_activate (GtkTreeView *tree_view,
209+ GtkTreePath *path,
210+ GtkTreeViewColumn *column,
211+ gpointer user_data)
212+{
213+ GtkTreeModel *model = gtk_tree_view_get_model (tree_view);
214+ GtkTreeIter iter;
215+ gboolean is_file;
216+
217+ gtk_tree_model_get_iter (model, &iter, path);
218+ gtk_tree_model_get (model, &iter, ISFILE_COLUMN, &is_file, -1);
219+
220+ if (! is_file)
221+ gtk_file_selection_dir_activate (tree_view, path, column, user_data);
222+}
223+
224+static void
225 gtk_file_selection_file_activate (GtkTreeView *tree_view,
226 GtkTreePath *path,
227 GtkTreeViewColumn *column,
228@@ -2103,7 +2139,6 @@
229 PossibleCompletion* poss;
230 GtkTreeIter iter;
231 GtkListStore *dir_model;
232- GtkListStore *file_model;
233 gchar* filename;
234 gchar* rem_path = rel_path;
235 gchar* sel_text;
236@@ -2125,10 +2160,8 @@
237 g_assert (cmpl_state->reference_dir);
238
239 dir_model = GTK_LIST_STORE (gtk_tree_view_get_model (GTK_TREE_VIEW (fs->dir_list)));
240- file_model = GTK_LIST_STORE (gtk_tree_view_get_model (GTK_TREE_VIEW (fs->file_list)));
241
242 gtk_list_store_clear (dir_model);
243- gtk_list_store_clear (file_model);
244
245 /* Set the dir list to include ./ and ../ */
246 gtk_list_store_append (dir_model, &iter);
247@@ -2150,13 +2183,17 @@
248 strcmp (filename, ".." G_DIR_SEPARATOR_S) != 0)
249 {
250 gtk_list_store_append (dir_model, &iter);
251- gtk_list_store_set (dir_model, &iter, DIR_COLUMN, filename, -1);
252+ gtk_list_store_set (dir_model, &iter,
253+ DIR_COLUMN, filename,
254+ ISFILE_COLUMN, FALSE, -1);
255 }
256 }
257 else
258 {
259- gtk_list_store_append (file_model, &iter);
260- gtk_list_store_set (file_model, &iter, DIR_COLUMN, filename, -1);
261+ gtk_list_store_append (dir_model, &iter);
262+ gtk_list_store_set (dir_model, &iter,
263+ DIR_COLUMN, filename,
264+ ISFILE_COLUMN, TRUE, -1);
265 }
266 }
267
diff --git a/meta/packages/gtk+/gtk+-2.6.7/spinbutton.patch b/meta/packages/gtk+/gtk+-2.6.7/spinbutton.patch
new file mode 100644
index 0000000000..8ad7507af0
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.6.7/spinbutton.patch
@@ -0,0 +1,128 @@
1--- gtk+-2.4.3/gtk/gtkspinbutton.c.old 2004-04-22 14:49:27.000000000 +0100
2+++ gtk+-2.4.3/gtk/gtkspinbutton.c 2004-06-30 21:48:18.000000000 +0100
3@@ -733,7 +733,7 @@
4
5 spin = GTK_SPIN_BUTTON (widget);
6 arrow_size = spin_button_get_arrow_size (spin);
7- panel_width = arrow_size + 2 * widget->style->xthickness;
8+ panel_width = (2 * arrow_size) + 4 * widget->style->xthickness;
9
10 widget->allocation = *allocation;
11
12@@ -866,19 +866,16 @@
13 {
14 width = spin_button_get_arrow_size (spin_button) + 2 * widget->style->xthickness;
15
16+ y = widget->style->ythickness;
17+ height = widget->requisition.height - (2 * y);
18+
19 if (arrow_type == GTK_ARROW_UP)
20 {
21 x = 0;
22- y = 0;
23-
24- height = widget->requisition.height / 2;
25 }
26 else
27 {
28- x = 0;
29- y = widget->requisition.height / 2;
30-
31- height = (widget->requisition.height + 1) / 2;
32+ x = width;
33 }
34
35 if (spin_button_at_limit (spin_button, arrow_type))
36@@ -908,32 +905,17 @@
37 shadow_type = GTK_SHADOW_OUT;
38 }
39 }
40-
41+
42 gtk_paint_box (widget->style, spin_button->panel,
43 state_type, shadow_type,
44 NULL, widget,
45- (arrow_type == GTK_ARROW_UP)? "spinbutton_up" : "spinbutton_down",
46+ NULL,
47 x, y, width, height);
48
49 height = widget->requisition.height;
50
51- if (arrow_type == GTK_ARROW_DOWN)
52- {
53- y = height / 2;
54- height = height - y - 2;
55- }
56- else
57- {
58- y = 2;
59- height = height / 2 - 2;
60- }
61-
62 width -= 3;
63-
64- if (widget && gtk_widget_get_direction (widget) == GTK_TEXT_DIR_RTL)
65- x = 2;
66- else
67- x = 1;
68+ height -= 3;
69
70 w = width / 2;
71 w -= w % 2 - 1; /* force odd */
72@@ -1108,7 +1090,7 @@
73 if (GTK_ENTRY (widget)->editable)
74 gtk_spin_button_update (spin);
75
76- if (event->y <= widget->requisition.height / 2)
77+ if (event->x <= (spin_button_get_arrow_size (spin) + widget->style->xthickness))
78 {
79 if (event->button == 1)
80 start_spinning (spin, GTK_ARROW_UP, spin->adjustment->step_increment);
81@@ -1143,44 +1125,11 @@
82
83 arrow_size = spin_button_get_arrow_size (spin);
84
85- if (event->button == spin->button)
86- {
87- int click_child = spin->click_child;
88+ gtk_spin_button_stop_spinning (spin);
89
90- gtk_spin_button_stop_spinning (spin);
91-
92- if (event->button == 3)
93- {
94- if (event->y >= 0 && event->x >= 0 &&
95- event->y <= widget->requisition.height &&
96- event->x <= arrow_size + 2 * widget->style->xthickness)
97- {
98- if (click_child == GTK_ARROW_UP &&
99- event->y <= widget->requisition.height / 2)
100- {
101- gdouble diff;
102-
103- diff = spin->adjustment->upper - spin->adjustment->value;
104- if (diff > EPSILON)
105- gtk_spin_button_real_spin (spin, diff);
106- }
107- else if (click_child == GTK_ARROW_DOWN &&
108- event->y > widget->requisition.height / 2)
109- {
110- gdouble diff;
111-
112- diff = spin->adjustment->value - spin->adjustment->lower;
113- if (diff > EPSILON)
114- gtk_spin_button_real_spin (spin, -diff);
115- }
116- }
117- }
118- spin_button_redraw (spin);
119+ spin_button_redraw (spin);
120
121- return TRUE;
122- }
123- else
124- return GTK_WIDGET_CLASS (parent_class)->button_release_event (widget, event);
125+ return TRUE;
126 }
127
128 static gint