summaryrefslogtreecommitdiffstats
path: root/meta/packages/gtk+/gtk+-2.10.0/hardcoded_libtool.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gtk+/gtk+-2.10.0/hardcoded_libtool.patch')
-rw-r--r--meta/packages/gtk+/gtk+-2.10.0/hardcoded_libtool.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/packages/gtk+/gtk+-2.10.0/hardcoded_libtool.patch b/meta/packages/gtk+/gtk+-2.10.0/hardcoded_libtool.patch
new file mode 100644
index 0000000000..1a8e9294cf
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.10.0/hardcoded_libtool.patch
@@ -0,0 +1,29 @@
1--- gtk+-2.6.0/configure.in.old 2005-01-01 16:23:45.000000000 +0000
2+++ gtk+-2.6.0/configure.in 2005-01-01 16:24:03.000000000 +0000
3@@ -360,7 +360,7 @@
4 AC_MSG_CHECKING([Whether to write dependencies into .pc files])
5 case $enable_explicit_deps in
6 auto)
7- deplibs_check_method=`(./libtool --config; echo eval echo \\$deplibs_check_method) | sh`
8+ deplibs_check_method=`($host_alias-libtool --config; echo eval echo \\$deplibs_check_method) | sh`
9 if test "x$deplibs_check_method" '!=' xpass_all || test "x$enable_static" = xyes ; then
10 enable_explicit_deps=yes
11 else
12@@ -688,7 +688,7 @@
13 dnl Now we check to see if our libtool supports shared lib deps
14 dnl (in a rather ugly way even)
15 if $dynworks; then
16- pixbuf_libtool_config="${CONFIG_SHELL-/bin/sh} ./libtool --config"
17+ pixbuf_libtool_config="${CONFIG_SHELL-/bin/sh} $host_alias-libtool --config"
18 pixbuf_deplibs_check=`$pixbuf_libtool_config | \
19 grep '^[[a-z_]]*check[[a-z_]]*_method=[['\''"]]' | \
20 sed 's/.*[['\''"]]\(.*\)[['\''"]]$/\1/'`
21@@ -1512,7 +1512,7 @@
22 #
23 # We are using gmodule-no-export now, but I'm leaving the stripping
24 # code in place for now, since pango and atk still require gmodule.
25-export_dynamic=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
26+export_dynamic=`($host_alias-libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
27 if test -n "$export_dynamic"; then
28 GDK_PIXBUF_DEP_LIBS=`echo $GDK_PIXBUF_DEP_LIBS | sed -e "s/$export_dynamic//"`
29 GDK_PIXBUF_XLIB_DEP_LIBS=`echo $GDK_PIXBUF_XLIB_DEP_LIBS | sed -e "s/$export_dynamic//"`