diff options
Diffstat (limited to 'meta/packages/gstreamer')
-rw-r--r-- | meta/packages/gstreamer/gst-ffmpeg_0.10.1.bb | 32 | ||||
-rw-r--r-- | meta/packages/gstreamer/gst-meta-audio_0.10.bb | 5 | ||||
-rw-r--r-- | meta/packages/gstreamer/gst-meta-base_0.10.bb | 6 | ||||
-rw-r--r-- | meta/packages/gstreamer/gst-meta-video_0.10.bb | 6 | ||||
-rw-r--r-- | meta/packages/gstreamer/gst-plugins-bad_0.10.3.bb | 5 | ||||
-rw-r--r-- | meta/packages/gstreamer/gst-plugins-base_0.10.9.bb | 3 | ||||
-rw-r--r-- | meta/packages/gstreamer/gst-plugins-good_0.10.4.bb | 6 | ||||
-rw-r--r-- | meta/packages/gstreamer/gst-plugins-ugly_0.10.4.bb | 1 | ||||
-rw-r--r-- | meta/packages/gstreamer/gst-plugins.inc | 1 |
9 files changed, 60 insertions, 5 deletions
diff --git a/meta/packages/gstreamer/gst-ffmpeg_0.10.1.bb b/meta/packages/gstreamer/gst-ffmpeg_0.10.1.bb new file mode 100644 index 0000000000..d2123f4a57 --- /dev/null +++ b/meta/packages/gstreamer/gst-ffmpeg_0.10.1.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | DESCRIPTION = "FFmpeg-based GStreamer plug-in" | ||
2 | SECTION = "multimedia" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "LGPL" | ||
5 | HOMEPAGE = "http://www.gstreamer.net/" | ||
6 | MAINTAINER = "Chris Lord <chris@openedhand.com>" | ||
7 | DEPENDS = "gstreamer zlib" | ||
8 | |||
9 | inherit autotools pkgconfig | ||
10 | |||
11 | SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2" | ||
12 | |||
13 | FILES_${PN} += "${libdir}/gstreamer-0.10" | ||
14 | |||
15 | EXTRA_OECONF = "--disable-sdltest --disable-ffplay --disable-freetypetest \ | ||
16 | --disable-vorbis --disable-vorbistest --disable-encoders \ | ||
17 | --disable-v4l --disable-audio-oss --disable-dv1394 \ | ||
18 | --disable-vhook --disable-ffmpeg --disable-ffserver \ | ||
19 | --enable-pp --disable-decoder-vorbis" | ||
20 | |||
21 | # We do this because the install program is called with -s which causes it to | ||
22 | # call "strip" and it then mangles cross compiled stuff.. | ||
23 | PATH_prepend="${CROSS_DIR}/${TARGET_SYS}/bin:" | ||
24 | |||
25 | # Hack to get STAGING_LIBDIR into the linker path when building ffmpeg | ||
26 | CC = "${CCACHE} ${HOST_PREFIX}gcc -L${STAGING_LIBDIR}" | ||
27 | |||
28 | do_configure () { | ||
29 | cd ${S} | ||
30 | oe_runconf | ||
31 | } | ||
32 | |||
diff --git a/meta/packages/gstreamer/gst-meta-audio_0.10.bb b/meta/packages/gstreamer/gst-meta-audio_0.10.bb new file mode 100644 index 0000000000..be0ec10f78 --- /dev/null +++ b/meta/packages/gstreamer/gst-meta-audio_0.10.bb | |||
@@ -0,0 +1,5 @@ | |||
1 | DEPENDS = "gst-meta-base gst-plugins-good" | ||
2 | RDEPENDS = "gst-meta-base gst-plugins-good gst-plugin-vorbis gst-plugin-ogg \ | ||
3 | gst-plugin-flac gst-plugin-speex" | ||
4 | |||
5 | ALLOW_EMPTY = "1" | ||
diff --git a/meta/packages/gstreamer/gst-meta-base_0.10.bb b/meta/packages/gstreamer/gst-meta-base_0.10.bb new file mode 100644 index 0000000000..8179952f45 --- /dev/null +++ b/meta/packages/gstreamer/gst-meta-base_0.10.bb | |||
@@ -0,0 +1,6 @@ | |||
1 | DEPENDS = "gstreamer gst-plugins-base" | ||
2 | RDEPENDS = "gstreamer gst-plugins-base gst-plugin-playbin \ | ||
3 | gst-plugin-decodebin gst-plugin-gnomevfs gst-plugin-alsa \ | ||
4 | gst-plugin-volume gst-plugin-ximagesink" | ||
5 | |||
6 | ALLOW_EMPTY = "1" | ||
diff --git a/meta/packages/gstreamer/gst-meta-video_0.10.bb b/meta/packages/gstreamer/gst-meta-video_0.10.bb new file mode 100644 index 0000000000..c085582801 --- /dev/null +++ b/meta/packages/gstreamer/gst-meta-video_0.10.bb | |||
@@ -0,0 +1,6 @@ | |||
1 | DEPENDS = "gst-meta-base gst-plugins-good gst-plugins-bad gst-ffmpeg" | ||
2 | RDEPENDS = "gst-meta-base gst-plugins-good gst-plugins-bad gst-plugin-avi \ | ||
3 | gst-plugin-matroska gst-plugin-ogg gst-ffmpeg" | ||
4 | RRECOMMENDS = "gst-meta-audio" | ||
5 | |||
6 | ALLOW_EMPTY = "1" | ||
diff --git a/meta/packages/gstreamer/gst-plugins-bad_0.10.3.bb b/meta/packages/gstreamer/gst-plugins-bad_0.10.3.bb index 75dc20170f..cc3fde3e29 100644 --- a/meta/packages/gstreamer/gst-plugins-bad_0.10.3.bb +++ b/meta/packages/gstreamer/gst-plugins-bad_0.10.3.bb | |||
@@ -1,6 +1,7 @@ | |||
1 | require gst-plugins.inc | 1 | require gst-plugins.inc |
2 | DEPENDS += "gst-plugins-base" | 2 | DEPENDS += "gst-plugins-base libmusicbrainz" |
3 | PR = "r1" | ||
3 | 4 | ||
4 | EXTRA_OECONF += "--disable-examples --disable-experimental --disable-sdl \ | 5 | EXTRA_OECONF += "--disable-examples --disable-experimental --disable-sdl \ |
5 | --with-plugins=divx,libmms,musicbrainz,swfdec,xvid,wavpack" | 6 | --with-plugins=musicbrainz,wavpack" |
6 | 7 | ||
diff --git a/meta/packages/gstreamer/gst-plugins-base_0.10.9.bb b/meta/packages/gstreamer/gst-plugins-base_0.10.9.bb index 88f3a31577..973327e146 100644 --- a/meta/packages/gstreamer/gst-plugins-base_0.10.9.bb +++ b/meta/packages/gstreamer/gst-plugins-base_0.10.9.bb | |||
@@ -1,6 +1,9 @@ | |||
1 | require gst-plugins.inc | 1 | require gst-plugins.inc |
2 | DEPENDS += "libx11 alsa-lib freetype gnome-vfs liboil libogg libvorbis tremor" | 2 | DEPENDS += "libx11 alsa-lib freetype gnome-vfs liboil libogg libvorbis tremor" |
3 | RDEPENDS += "gnome-vfs-plugin-file gnome-vfs-plugin-http gnome-vfs-plugin-ftp \ | ||
4 | gnome-vfs-plugin-sftp" | ||
3 | PROVIDES_${PN} += "gst-plugins" | 5 | PROVIDES_${PN} += "gst-plugins" |
6 | PR = "r1" | ||
4 | 7 | ||
5 | EXTRA_OECONF += "--with-plugins=ximagesink,alsa,gnomevfs,ogg,vorbis \ | 8 | EXTRA_OECONF += "--with-plugins=ximagesink,alsa,gnomevfs,ogg,vorbis \ |
6 | --disable-freetypetest --disable-pango --disable-theora" | 9 | --disable-freetypetest --disable-pango --disable-theora" |
diff --git a/meta/packages/gstreamer/gst-plugins-good_0.10.4.bb b/meta/packages/gstreamer/gst-plugins-good_0.10.4.bb index cb0a818ebf..836923b146 100644 --- a/meta/packages/gstreamer/gst-plugins-good_0.10.4.bb +++ b/meta/packages/gstreamer/gst-plugins-good_0.10.4.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | require gst-plugins.inc | 1 | require gst-plugins.inc |
2 | DEPENDS += "gst-plugins-base gconf cairo jpeg libpng gtk+ zlib libid3tag flac \ | 2 | DEPENDS += "gst-plugins-base gconf cairo jpeg libpng gtk+ zlib libid3tag flac \ |
3 | speex" | 3 | speex" |
4 | PR = "r1" | ||
5 | |||
6 | EXTRA_OECONF += " --with-plugins=ximagesrc,cairo,flac,gconfelements,gdkpixbuf,jpeg,png,speex,taglib,avi,matroska,videofilter --disable-aalib --disable-esd --disable-shout2" | ||
4 | 7 | ||
5 | EXTRA_OECONF += " --with-plugins=ximagesrc,cairo,flac,gconfelements,gdkpixbuf,\ | ||
6 | jpeg,png,speex,taglib \ | ||
7 | --disable-aalib --disable-esd --disable-shout2" | ||
diff --git a/meta/packages/gstreamer/gst-plugins-ugly_0.10.4.bb b/meta/packages/gstreamer/gst-plugins-ugly_0.10.4.bb index ad287d90ae..022a0abcec 100644 --- a/meta/packages/gstreamer/gst-plugins-ugly_0.10.4.bb +++ b/meta/packages/gstreamer/gst-plugins-ugly_0.10.4.bb | |||
@@ -1,5 +1,6 @@ | |||
1 | require gst-plugins.inc | 1 | require gst-plugins.inc |
2 | DEPENDS += "gst-plugins-base libid3tag libmad mpeg2dec liba52 lame" | 2 | DEPENDS += "gst-plugins-base libid3tag libmad mpeg2dec liba52 lame" |
3 | PR = "r1" | ||
3 | 4 | ||
4 | SRC_URI += " file://lame-autoconf.patch;patch=1" | 5 | SRC_URI += " file://lame-autoconf.patch;patch=1" |
5 | EXTRA_OECONF += "--with-plugins=a52dec,lame,id3tag,mad,mpeg2dec" | 6 | EXTRA_OECONF += "--with-plugins=a52dec,lame,id3tag,mad,mpeg2dec" |
diff --git a/meta/packages/gstreamer/gst-plugins.inc b/meta/packages/gstreamer/gst-plugins.inc index 1ce7ef8d91..f5e60edb4c 100644 --- a/meta/packages/gstreamer/gst-plugins.inc +++ b/meta/packages/gstreamer/gst-plugins.inc | |||
@@ -13,6 +13,7 @@ EXTRA_OECONF = "--disable-valgrind --disable-debug --disable-examples " | |||
13 | acpaths = "-I ${S}/common/m4 -I ${S}/m4" | 13 | acpaths = "-I ${S}/common/m4 -I ${S}/m4" |
14 | 14 | ||
15 | LIBV = "0.10" | 15 | LIBV = "0.10" |
16 | PACKAGES_DYNAMIC = "gst-plugin-*" | ||
16 | 17 | ||
17 | python populate_packages_prepend () { | 18 | python populate_packages_prepend () { |
18 | gst_libdir = bb.data.expand('${libdir}/gstreamer-${LIBV}', d) | 19 | gst_libdir = bb.data.expand('${libdir}/gstreamer-${LIBV}', d) |