summaryrefslogtreecommitdiffstats
path: root/meta/packages/gstreamer/gstreamer_0.10.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gstreamer/gstreamer_0.10.22.bb')
-rw-r--r--meta/packages/gstreamer/gstreamer_0.10.22.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/packages/gstreamer/gstreamer_0.10.22.bb b/meta/packages/gstreamer/gstreamer_0.10.22.bb
new file mode 100644
index 0000000000..a96e9759f2
--- /dev/null
+++ b/meta/packages/gstreamer/gstreamer_0.10.22.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
2It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
3SECTION = "multimedia"
4PRIORITY = "optional"
5LICENSE = "LGPL"
6HOMEPAGE = "http://www.gstreamer.net/"
7DEPENDS = "glib-2.0 gettext-native libxml2 bison-native flex-native"
8PR = "r1"
9
10inherit autotools_stage pkgconfig
11
12SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2 \
13 file://check_fix.patch;patch=1 \
14 file://gst-inspect-check-error.patch;patch=1"
15EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=no --disable-examples --disable-tests --disable-valgrind --disable-debug"
16
17do_configure_prepend() {
18 # This m4 file contains nastiness which conflicts with libtool 2.2.2
19 rm -f ${S}/common/m4/lib-link.m4 || true
20}
21
22#do_compile_prepend () {
23# mv ${WORKDIR}/gstregistrybinary.[ch] ${S}/gst/
24#}
25
26PARALLEL_MAKE = ""
27
28FILES_${PN} += " ${libdir}/gstreamer-0.10/*.so"
29FILES_${PN}-dev += " ${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"
30FILES_${PN}-dbg += " ${libdir}/gstreamer-0.10/.debug/"