summaryrefslogtreecommitdiffstats
path: root/meta/packages/gstreamer/gstreamer-0.10.9/gstreamer-0.9-binary-registry.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gstreamer/gstreamer-0.10.9/gstreamer-0.9-binary-registry.patch')
-rw-r--r--meta/packages/gstreamer/gstreamer-0.10.9/gstreamer-0.9-binary-registry.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/packages/gstreamer/gstreamer-0.10.9/gstreamer-0.9-binary-registry.patch b/meta/packages/gstreamer/gstreamer-0.10.9/gstreamer-0.9-binary-registry.patch
new file mode 100644
index 0000000000..e166fc37ee
--- /dev/null
+++ b/meta/packages/gstreamer/gstreamer-0.10.9/gstreamer-0.9-binary-registry.patch
@@ -0,0 +1,65 @@
1diff -urNd ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gst.c gstreamer-0.10.9/gst/gst.c
2--- ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gst.c 2006-07-11 21:16:04.000000000 +0100
3+++ gstreamer-0.10.9/gst/gst.c 2006-09-01 12:30:36.000000000 +0100
4@@ -553,7 +553,7 @@
5 GList *l;
6
7 GST_DEBUG ("reading registry cache: %s", registry_file);
8- gst_registry_xml_read_cache (default_registry, registry_file);
9+ gst_registry_binary_read_cache (default_registry, registry_file);
10
11 /* scan paths specified via --gst-plugin-path */
12 GST_DEBUG ("scanning paths added via --gst-plugin-path");
13@@ -624,7 +624,7 @@
14 }
15
16 GST_DEBUG ("writing registry cache");
17- if (!gst_registry_xml_write_cache (default_registry, registry_file)) {
18+ if (!gst_registry_binary_write_cache (default_registry, registry_file)) {
19 g_warning ("Problem writing registry cache to %s: %s", registry_file,
20 g_strerror (errno));
21 return FALSE;
22@@ -700,7 +700,7 @@
23
24 if (WEXITSTATUS (status) == EXIT_SUCCESS) {
25 GST_DEBUG ("parent reading registry cache");
26- gst_registry_xml_read_cache (default_registry, registry_file);
27+ gst_registry_binary_read_cache (default_registry, registry_file);
28 } else {
29 GST_DEBUG ("parent re-scanning registry");
30 scan_and_update_registry (default_registry, registry_file, FALSE);
31@@ -722,7 +722,7 @@
32 registry_file = g_strdup (g_getenv ("GST_REGISTRY"));
33 if (registry_file == NULL) {
34 registry_file = g_build_filename (g_get_home_dir (),
35- ".gstreamer-" GST_MAJORMINOR, "registry." HOST_CPU ".xml", NULL);
36+ ".gstreamer-" GST_MAJORMINOR, "registry." HOST_CPU ".bin", NULL);
37 }
38 #ifdef HAVE_FORK
39 if (g_getenv ("GST_REGISTRY_FORK") == NULL
40diff -urNd ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gstregistry.h gstreamer-0.10.9/gst/gstregistry.h
41--- ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gstregistry.h 2006-07-11 21:16:04.000000000 +0100
42+++ gstreamer-0.10.9/gst/gstregistry.h 2006-09-01 12:30:36.000000000 +0100
43@@ -105,8 +105,8 @@
44 GstPlugin * gst_registry_lookup (GstRegistry *registry, const char *filename);
45 GstPluginFeature * gst_registry_lookup_feature (GstRegistry *registry, const char *name);
46
47-gboolean gst_registry_xml_read_cache (GstRegistry * registry, const char *location);
48-gboolean gst_registry_xml_write_cache (GstRegistry * registry, const char *location);
49+gboolean gst_registry_binary_read_cache (GstRegistry * registry, const char *location);
50+gboolean gst_registry_binary_write_cache (GstRegistry * registry, const char *location);
51
52 void _gst_registry_remove_cache_plugins (GstRegistry *registry);
53
54diff -urNd ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/Makefile.am gstreamer-0.10.9/gst/Makefile.am
55--- ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/Makefile.am 2006-07-13 16:31:47.000000000 +0100
56+++ gstreamer-0.10.9/gst/Makefile.am 2006-09-01 12:30:36.000000000 +0100
57@@ -9,7 +9,7 @@
58 if GST_DISABLE_REGISTRY
59 GST_REGISTRY_SRC =
60 else
61-GST_REGISTRY_SRC = gstregistryxml.c
62+GST_REGISTRY_SRC = gstregistrybinary.c
63 endif
64
65 if GST_DISABLE_PARSE