diff options
Diffstat (limited to 'meta/packages/gperf')
-rw-r--r-- | meta/packages/gperf/files/autoreconf.patch | 435 | ||||
-rw-r--r-- | meta/packages/gperf/gperf-native_3.0.3.bb | 10 | ||||
-rw-r--r-- | meta/packages/gperf/gperf_3.0.3.bb | 8 |
3 files changed, 453 insertions, 0 deletions
diff --git a/meta/packages/gperf/files/autoreconf.patch b/meta/packages/gperf/files/autoreconf.patch new file mode 100644 index 0000000000..432023067b --- /dev/null +++ b/meta/packages/gperf/files/autoreconf.patch | |||
@@ -0,0 +1,435 @@ | |||
1 | Index: gperf-3.0.3/configure.ac | ||
2 | =================================================================== | ||
3 | --- gperf-3.0.3.orig/configure.ac 2007-05-10 18:34:15.000000000 +0200 | ||
4 | +++ gperf-3.0.3/configure.ac 2007-05-10 18:34:26.000000000 +0200 | ||
5 | @@ -21,7 +21,7 @@ | ||
6 | dnl If not, write to the Free Software Foundation, Inc., | ||
7 | dnl 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. | ||
8 | |||
9 | -AC_PREREQ([2.60]) | ||
10 | +AC_PREREQ([2.59]) | ||
11 | AC_INIT(doc/gperf.1) | ||
12 | AC_PROG_MAKE_SET | ||
13 | AC_OBJEXT | ||
14 | Index: gperf-3.0.3/doc/configure.ac | ||
15 | =================================================================== | ||
16 | --- gperf-3.0.3.orig/doc/configure.ac 2007-05-10 18:34:30.000000000 +0200 | ||
17 | +++ gperf-3.0.3/doc/configure.ac 2007-05-10 18:34:37.000000000 +0200 | ||
18 | @@ -21,7 +21,7 @@ | ||
19 | dnl If not, write to the Free Software Foundation, Inc., | ||
20 | dnl 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. */ | ||
21 | |||
22 | -AC_PREREQ([2.60]) | ||
23 | +AC_PREREQ([2.59]) | ||
24 | AC_INIT(gperf.1) | ||
25 | PACKAGE=gperf | ||
26 | AC_SUBST(PACKAGE) | ||
27 | Index: gperf-3.0.3/lib/configure.ac | ||
28 | =================================================================== | ||
29 | --- gperf-3.0.3.orig/lib/configure.ac 2007-05-10 18:34:41.000000000 +0200 | ||
30 | +++ gperf-3.0.3/lib/configure.ac 2007-05-10 18:34:46.000000000 +0200 | ||
31 | @@ -21,7 +21,7 @@ | ||
32 | dnl If not, write to the Free Software Foundation, Inc., | ||
33 | dnl 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. */ | ||
34 | |||
35 | -AC_PREREQ([2.60]) | ||
36 | +AC_PREREQ([2.59]) | ||
37 | AC_INIT(hash.cc) | ||
38 | AC_PROG_MAKE_SET | ||
39 | dnl | ||
40 | Index: gperf-3.0.3/src/configure.ac | ||
41 | =================================================================== | ||
42 | --- gperf-3.0.3.orig/src/configure.ac 2007-05-10 18:34:53.000000000 +0200 | ||
43 | +++ gperf-3.0.3/src/configure.ac 2007-05-10 18:34:58.000000000 +0200 | ||
44 | @@ -21,7 +21,7 @@ | ||
45 | dnl If not, write to the Free Software Foundation, Inc., | ||
46 | dnl 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. | ||
47 | |||
48 | -AC_PREREQ([2.60]) | ||
49 | +AC_PREREQ([2.59]) | ||
50 | AC_INIT(main.cc) | ||
51 | AC_CONFIG_HEADER(config.h) | ||
52 | AC_PROG_MAKE_SET | ||
53 | Index: gperf-3.0.3/tests/configure.ac | ||
54 | =================================================================== | ||
55 | --- gperf-3.0.3.orig/tests/configure.ac 2007-05-10 18:35:03.000000000 +0200 | ||
56 | +++ gperf-3.0.3/tests/configure.ac 2007-05-10 18:35:08.000000000 +0200 | ||
57 | @@ -21,7 +21,7 @@ | ||
58 | dnl If not, write to the Free Software Foundation, Inc., | ||
59 | dnl 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. | ||
60 | |||
61 | -AC_PREREQ([2.60]) | ||
62 | +AC_PREREQ([2.59]) | ||
63 | AC_INIT(c-parse.gperf) | ||
64 | AC_PROG_MAKE_SET | ||
65 | dnl | ||
66 | Index: gperf-3.0.3/acinclude.m4 | ||
67 | =================================================================== | ||
68 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
69 | +++ gperf-3.0.3/acinclude.m4 2007-05-10 18:36:09.000000000 +0200 | ||
70 | @@ -0,0 +1,69 @@ | ||
71 | +AC_PREREQ(2.12) | ||
72 | + | ||
73 | +AC_DEFUN(CL_PROG_INSTALL, | ||
74 | +[dnl This is mostly copied from AC_PROG_INSTALL. | ||
75 | +# Find a good install program. We prefer a C program (faster), | ||
76 | +# so one script is as good as another. But avoid the broken or | ||
77 | +# incompatible versions: | ||
78 | +# SysV /etc/install, /usr/sbin/install | ||
79 | +# SunOS /usr/etc/install | ||
80 | +# IRIX /sbin/install | ||
81 | +# AIX /bin/install | ||
82 | +# AFS /usr/afsws/bin/install, which mishandles nonexistent args | ||
83 | +# SVR4 /usr/ucb/install, which tries to use the nonexistent group "staff" | ||
84 | +# ./install, which can be erroneously created by make from ./install.sh. | ||
85 | +AC_MSG_CHECKING(for a BSD compatible install) | ||
86 | +if test -z "$INSTALL"; then | ||
87 | +AC_CACHE_VAL(cl_cv_path_install, | ||
88 | +[ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:" | ||
89 | + for ac_dir in $PATH; do | ||
90 | + # Account for people who put trailing slashes in PATH elements. | ||
91 | + case "$ac_dir/" in | ||
92 | + /|./|.//|/etc/*|/usr/sbin/*|/usr/etc/*|/sbin/*|/usr/afsws/bin/*|/usr/ucb/*) ;; | ||
93 | + *) | ||
94 | + # OSF1 and SCO ODT 3.0 have their own names for install. | ||
95 | + for ac_prog in ginstall installbsd scoinst install; do | ||
96 | + if test -f $ac_dir/$ac_prog; then | ||
97 | + if test $ac_prog = install && | ||
98 | + grep dspmsg $ac_dir/$ac_prog >/dev/null 2>&1; then | ||
99 | + # AIX install. It has an incompatible calling convention. | ||
100 | + # OSF/1 installbsd also uses dspmsg, but is usable. | ||
101 | + : | ||
102 | + else | ||
103 | + if test $ac_prog = installbsd && | ||
104 | + grep src/bos $ac_dir/$ac_prog >/dev/null 2>&1; then | ||
105 | + # AIX installbsd doesn't work without option "-g". | ||
106 | + : | ||
107 | + else | ||
108 | + cl_cv_path_install="$ac_dir/$ac_prog -c" | ||
109 | + break 2 | ||
110 | + fi | ||
111 | + fi | ||
112 | + fi | ||
113 | + done | ||
114 | + ;; | ||
115 | + esac | ||
116 | + done | ||
117 | + IFS="$ac_save_ifs" | ||
118 | + # As a last resort, use cp. | ||
119 | + test -z "$cl_cv_path_install" && cl_cv_path_install="cp" | ||
120 | +])dnl | ||
121 | + INSTALL="$cl_cv_path_install" | ||
122 | +fi | ||
123 | +dnl We do special magic for INSTALL instead of AC_SUBST, to get | ||
124 | +dnl relative paths right. | ||
125 | +AC_MSG_RESULT($INSTALL) | ||
126 | +AC_SUBST(INSTALL)dnl | ||
127 | +# Use test -z because SunOS4 sh mishandles braces in ${var-val}. | ||
128 | +# It thinks the first close brace ends the variable substitution. | ||
129 | +test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='$(INSTALL)' | ||
130 | +AC_SUBST(INSTALL_PROGRAM)dnl | ||
131 | +if test -z "$INSTALL_DATA"; then | ||
132 | + case "$INSTALL" in | ||
133 | + cp | */cp ) INSTALL_DATA='$(INSTALL)' ;; | ||
134 | + * ) INSTALL_DATA='$(INSTALL) -m 644' ;; | ||
135 | + esac | ||
136 | +fi | ||
137 | +AC_SUBST(INSTALL_DATA)dnl | ||
138 | +]) | ||
139 | + | ||
140 | Index: gperf-3.0.3/doc/acinclude.m4 | ||
141 | =================================================================== | ||
142 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
143 | +++ gperf-3.0.3/doc/acinclude.m4 2007-05-10 18:36:11.000000000 +0200 | ||
144 | @@ -0,0 +1,69 @@ | ||
145 | +AC_PREREQ(2.12) | ||
146 | + | ||
147 | +AC_DEFUN(CL_PROG_INSTALL, | ||
148 | +[dnl This is mostly copied from AC_PROG_INSTALL. | ||
149 | +# Find a good install program. We prefer a C program (faster), | ||
150 | +# so one script is as good as another. But avoid the broken or | ||
151 | +# incompatible versions: | ||
152 | +# SysV /etc/install, /usr/sbin/install | ||
153 | +# SunOS /usr/etc/install | ||
154 | +# IRIX /sbin/install | ||
155 | +# AIX /bin/install | ||
156 | +# AFS /usr/afsws/bin/install, which mishandles nonexistent args | ||
157 | +# SVR4 /usr/ucb/install, which tries to use the nonexistent group "staff" | ||
158 | +# ./install, which can be erroneously created by make from ./install.sh. | ||
159 | +AC_MSG_CHECKING(for a BSD compatible install) | ||
160 | +if test -z "$INSTALL"; then | ||
161 | +AC_CACHE_VAL(cl_cv_path_install, | ||
162 | +[ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:" | ||
163 | + for ac_dir in $PATH; do | ||
164 | + # Account for people who put trailing slashes in PATH elements. | ||
165 | + case "$ac_dir/" in | ||
166 | + /|./|.//|/etc/*|/usr/sbin/*|/usr/etc/*|/sbin/*|/usr/afsws/bin/*|/usr/ucb/*) ;; | ||
167 | + *) | ||
168 | + # OSF1 and SCO ODT 3.0 have their own names for install. | ||
169 | + for ac_prog in ginstall installbsd scoinst install; do | ||
170 | + if test -f $ac_dir/$ac_prog; then | ||
171 | + if test $ac_prog = install && | ||
172 | + grep dspmsg $ac_dir/$ac_prog >/dev/null 2>&1; then | ||
173 | + # AIX install. It has an incompatible calling convention. | ||
174 | + # OSF/1 installbsd also uses dspmsg, but is usable. | ||
175 | + : | ||
176 | + else | ||
177 | + if test $ac_prog = installbsd && | ||
178 | + grep src/bos $ac_dir/$ac_prog >/dev/null 2>&1; then | ||
179 | + # AIX installbsd doesn't work without option "-g". | ||
180 | + : | ||
181 | + else | ||
182 | + cl_cv_path_install="$ac_dir/$ac_prog -c" | ||
183 | + break 2 | ||
184 | + fi | ||
185 | + fi | ||
186 | + fi | ||
187 | + done | ||
188 | + ;; | ||
189 | + esac | ||
190 | + done | ||
191 | + IFS="$ac_save_ifs" | ||
192 | + # As a last resort, use cp. | ||
193 | + test -z "$cl_cv_path_install" && cl_cv_path_install="cp" | ||
194 | +])dnl | ||
195 | + INSTALL="$cl_cv_path_install" | ||
196 | +fi | ||
197 | +dnl We do special magic for INSTALL instead of AC_SUBST, to get | ||
198 | +dnl relative paths right. | ||
199 | +AC_MSG_RESULT($INSTALL) | ||
200 | +AC_SUBST(INSTALL)dnl | ||
201 | +# Use test -z because SunOS4 sh mishandles braces in ${var-val}. | ||
202 | +# It thinks the first close brace ends the variable substitution. | ||
203 | +test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='$(INSTALL)' | ||
204 | +AC_SUBST(INSTALL_PROGRAM)dnl | ||
205 | +if test -z "$INSTALL_DATA"; then | ||
206 | + case "$INSTALL" in | ||
207 | + cp | */cp ) INSTALL_DATA='$(INSTALL)' ;; | ||
208 | + * ) INSTALL_DATA='$(INSTALL) -m 644' ;; | ||
209 | + esac | ||
210 | +fi | ||
211 | +AC_SUBST(INSTALL_DATA)dnl | ||
212 | +]) | ||
213 | + | ||
214 | Index: gperf-3.0.3/lib/acinclude.m4 | ||
215 | =================================================================== | ||
216 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
217 | +++ gperf-3.0.3/lib/acinclude.m4 2007-05-10 18:36:14.000000000 +0200 | ||
218 | @@ -0,0 +1,69 @@ | ||
219 | +AC_PREREQ(2.12) | ||
220 | + | ||
221 | +AC_DEFUN(CL_PROG_INSTALL, | ||
222 | +[dnl This is mostly copied from AC_PROG_INSTALL. | ||
223 | +# Find a good install program. We prefer a C program (faster), | ||
224 | +# so one script is as good as another. But avoid the broken or | ||
225 | +# incompatible versions: | ||
226 | +# SysV /etc/install, /usr/sbin/install | ||
227 | +# SunOS /usr/etc/install | ||
228 | +# IRIX /sbin/install | ||
229 | +# AIX /bin/install | ||
230 | +# AFS /usr/afsws/bin/install, which mishandles nonexistent args | ||
231 | +# SVR4 /usr/ucb/install, which tries to use the nonexistent group "staff" | ||
232 | +# ./install, which can be erroneously created by make from ./install.sh. | ||
233 | +AC_MSG_CHECKING(for a BSD compatible install) | ||
234 | +if test -z "$INSTALL"; then | ||
235 | +AC_CACHE_VAL(cl_cv_path_install, | ||
236 | +[ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:" | ||
237 | + for ac_dir in $PATH; do | ||
238 | + # Account for people who put trailing slashes in PATH elements. | ||
239 | + case "$ac_dir/" in | ||
240 | + /|./|.//|/etc/*|/usr/sbin/*|/usr/etc/*|/sbin/*|/usr/afsws/bin/*|/usr/ucb/*) ;; | ||
241 | + *) | ||
242 | + # OSF1 and SCO ODT 3.0 have their own names for install. | ||
243 | + for ac_prog in ginstall installbsd scoinst install; do | ||
244 | + if test -f $ac_dir/$ac_prog; then | ||
245 | + if test $ac_prog = install && | ||
246 | + grep dspmsg $ac_dir/$ac_prog >/dev/null 2>&1; then | ||
247 | + # AIX install. It has an incompatible calling convention. | ||
248 | + # OSF/1 installbsd also uses dspmsg, but is usable. | ||
249 | + : | ||
250 | + else | ||
251 | + if test $ac_prog = installbsd && | ||
252 | + grep src/bos $ac_dir/$ac_prog >/dev/null 2>&1; then | ||
253 | + # AIX installbsd doesn't work without option "-g". | ||
254 | + : | ||
255 | + else | ||
256 | + cl_cv_path_install="$ac_dir/$ac_prog -c" | ||
257 | + break 2 | ||
258 | + fi | ||
259 | + fi | ||
260 | + fi | ||
261 | + done | ||
262 | + ;; | ||
263 | + esac | ||
264 | + done | ||
265 | + IFS="$ac_save_ifs" | ||
266 | + # As a last resort, use cp. | ||
267 | + test -z "$cl_cv_path_install" && cl_cv_path_install="cp" | ||
268 | +])dnl | ||
269 | + INSTALL="$cl_cv_path_install" | ||
270 | +fi | ||
271 | +dnl We do special magic for INSTALL instead of AC_SUBST, to get | ||
272 | +dnl relative paths right. | ||
273 | +AC_MSG_RESULT($INSTALL) | ||
274 | +AC_SUBST(INSTALL)dnl | ||
275 | +# Use test -z because SunOS4 sh mishandles braces in ${var-val}. | ||
276 | +# It thinks the first close brace ends the variable substitution. | ||
277 | +test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='$(INSTALL)' | ||
278 | +AC_SUBST(INSTALL_PROGRAM)dnl | ||
279 | +if test -z "$INSTALL_DATA"; then | ||
280 | + case "$INSTALL" in | ||
281 | + cp | */cp ) INSTALL_DATA='$(INSTALL)' ;; | ||
282 | + * ) INSTALL_DATA='$(INSTALL) -m 644' ;; | ||
283 | + esac | ||
284 | +fi | ||
285 | +AC_SUBST(INSTALL_DATA)dnl | ||
286 | +]) | ||
287 | + | ||
288 | Index: gperf-3.0.3/src/acinclude.m4 | ||
289 | =================================================================== | ||
290 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
291 | +++ gperf-3.0.3/src/acinclude.m4 2007-05-10 18:36:12.000000000 +0200 | ||
292 | @@ -0,0 +1,69 @@ | ||
293 | +AC_PREREQ(2.12) | ||
294 | + | ||
295 | +AC_DEFUN(CL_PROG_INSTALL, | ||
296 | +[dnl This is mostly copied from AC_PROG_INSTALL. | ||
297 | +# Find a good install program. We prefer a C program (faster), | ||
298 | +# so one script is as good as another. But avoid the broken or | ||
299 | +# incompatible versions: | ||
300 | +# SysV /etc/install, /usr/sbin/install | ||
301 | +# SunOS /usr/etc/install | ||
302 | +# IRIX /sbin/install | ||
303 | +# AIX /bin/install | ||
304 | +# AFS /usr/afsws/bin/install, which mishandles nonexistent args | ||
305 | +# SVR4 /usr/ucb/install, which tries to use the nonexistent group "staff" | ||
306 | +# ./install, which can be erroneously created by make from ./install.sh. | ||
307 | +AC_MSG_CHECKING(for a BSD compatible install) | ||
308 | +if test -z "$INSTALL"; then | ||
309 | +AC_CACHE_VAL(cl_cv_path_install, | ||
310 | +[ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:" | ||
311 | + for ac_dir in $PATH; do | ||
312 | + # Account for people who put trailing slashes in PATH elements. | ||
313 | + case "$ac_dir/" in | ||
314 | + /|./|.//|/etc/*|/usr/sbin/*|/usr/etc/*|/sbin/*|/usr/afsws/bin/*|/usr/ucb/*) ;; | ||
315 | + *) | ||
316 | + # OSF1 and SCO ODT 3.0 have their own names for install. | ||
317 | + for ac_prog in ginstall installbsd scoinst install; do | ||
318 | + if test -f $ac_dir/$ac_prog; then | ||
319 | + if test $ac_prog = install && | ||
320 | + grep dspmsg $ac_dir/$ac_prog >/dev/null 2>&1; then | ||
321 | + # AIX install. It has an incompatible calling convention. | ||
322 | + # OSF/1 installbsd also uses dspmsg, but is usable. | ||
323 | + : | ||
324 | + else | ||
325 | + if test $ac_prog = installbsd && | ||
326 | + grep src/bos $ac_dir/$ac_prog >/dev/null 2>&1; then | ||
327 | + # AIX installbsd doesn't work without option "-g". | ||
328 | + : | ||
329 | + else | ||
330 | + cl_cv_path_install="$ac_dir/$ac_prog -c" | ||
331 | + break 2 | ||
332 | + fi | ||
333 | + fi | ||
334 | + fi | ||
335 | + done | ||
336 | + ;; | ||
337 | + esac | ||
338 | + done | ||
339 | + IFS="$ac_save_ifs" | ||
340 | + # As a last resort, use cp. | ||
341 | + test -z "$cl_cv_path_install" && cl_cv_path_install="cp" | ||
342 | +])dnl | ||
343 | + INSTALL="$cl_cv_path_install" | ||
344 | +fi | ||
345 | +dnl We do special magic for INSTALL instead of AC_SUBST, to get | ||
346 | +dnl relative paths right. | ||
347 | +AC_MSG_RESULT($INSTALL) | ||
348 | +AC_SUBST(INSTALL)dnl | ||
349 | +# Use test -z because SunOS4 sh mishandles braces in ${var-val}. | ||
350 | +# It thinks the first close brace ends the variable substitution. | ||
351 | +test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='$(INSTALL)' | ||
352 | +AC_SUBST(INSTALL_PROGRAM)dnl | ||
353 | +if test -z "$INSTALL_DATA"; then | ||
354 | + case "$INSTALL" in | ||
355 | + cp | */cp ) INSTALL_DATA='$(INSTALL)' ;; | ||
356 | + * ) INSTALL_DATA='$(INSTALL) -m 644' ;; | ||
357 | + esac | ||
358 | +fi | ||
359 | +AC_SUBST(INSTALL_DATA)dnl | ||
360 | +]) | ||
361 | + | ||
362 | Index: gperf-3.0.3/tests/acinclude.m4 | ||
363 | =================================================================== | ||
364 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
365 | +++ gperf-3.0.3/tests/acinclude.m4 2007-05-10 18:36:16.000000000 +0200 | ||
366 | @@ -0,0 +1,69 @@ | ||
367 | +AC_PREREQ(2.12) | ||
368 | + | ||
369 | +AC_DEFUN(CL_PROG_INSTALL, | ||
370 | +[dnl This is mostly copied from AC_PROG_INSTALL. | ||
371 | +# Find a good install program. We prefer a C program (faster), | ||
372 | +# so one script is as good as another. But avoid the broken or | ||
373 | +# incompatible versions: | ||
374 | +# SysV /etc/install, /usr/sbin/install | ||
375 | +# SunOS /usr/etc/install | ||
376 | +# IRIX /sbin/install | ||
377 | +# AIX /bin/install | ||
378 | +# AFS /usr/afsws/bin/install, which mishandles nonexistent args | ||
379 | +# SVR4 /usr/ucb/install, which tries to use the nonexistent group "staff" | ||
380 | +# ./install, which can be erroneously created by make from ./install.sh. | ||
381 | +AC_MSG_CHECKING(for a BSD compatible install) | ||
382 | +if test -z "$INSTALL"; then | ||
383 | +AC_CACHE_VAL(cl_cv_path_install, | ||
384 | +[ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:" | ||
385 | + for ac_dir in $PATH; do | ||
386 | + # Account for people who put trailing slashes in PATH elements. | ||
387 | + case "$ac_dir/" in | ||
388 | + /|./|.//|/etc/*|/usr/sbin/*|/usr/etc/*|/sbin/*|/usr/afsws/bin/*|/usr/ucb/*) ;; | ||
389 | + *) | ||
390 | + # OSF1 and SCO ODT 3.0 have their own names for install. | ||
391 | + for ac_prog in ginstall installbsd scoinst install; do | ||
392 | + if test -f $ac_dir/$ac_prog; then | ||
393 | + if test $ac_prog = install && | ||
394 | + grep dspmsg $ac_dir/$ac_prog >/dev/null 2>&1; then | ||
395 | + # AIX install. It has an incompatible calling convention. | ||
396 | + # OSF/1 installbsd also uses dspmsg, but is usable. | ||
397 | + : | ||
398 | + else | ||
399 | + if test $ac_prog = installbsd && | ||
400 | + grep src/bos $ac_dir/$ac_prog >/dev/null 2>&1; then | ||
401 | + # AIX installbsd doesn't work without option "-g". | ||
402 | + : | ||
403 | + else | ||
404 | + cl_cv_path_install="$ac_dir/$ac_prog -c" | ||
405 | + break 2 | ||
406 | + fi | ||
407 | + fi | ||
408 | + fi | ||
409 | + done | ||
410 | + ;; | ||
411 | + esac | ||
412 | + done | ||
413 | + IFS="$ac_save_ifs" | ||
414 | + # As a last resort, use cp. | ||
415 | + test -z "$cl_cv_path_install" && cl_cv_path_install="cp" | ||
416 | +])dnl | ||
417 | + INSTALL="$cl_cv_path_install" | ||
418 | +fi | ||
419 | +dnl We do special magic for INSTALL instead of AC_SUBST, to get | ||
420 | +dnl relative paths right. | ||
421 | +AC_MSG_RESULT($INSTALL) | ||
422 | +AC_SUBST(INSTALL)dnl | ||
423 | +# Use test -z because SunOS4 sh mishandles braces in ${var-val}. | ||
424 | +# It thinks the first close brace ends the variable substitution. | ||
425 | +test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='$(INSTALL)' | ||
426 | +AC_SUBST(INSTALL_PROGRAM)dnl | ||
427 | +if test -z "$INSTALL_DATA"; then | ||
428 | + case "$INSTALL" in | ||
429 | + cp | */cp ) INSTALL_DATA='$(INSTALL)' ;; | ||
430 | + * ) INSTALL_DATA='$(INSTALL) -m 644' ;; | ||
431 | + esac | ||
432 | +fi | ||
433 | +AC_SUBST(INSTALL_DATA)dnl | ||
434 | +]) | ||
435 | + | ||
diff --git a/meta/packages/gperf/gperf-native_3.0.3.bb b/meta/packages/gperf/gperf-native_3.0.3.bb new file mode 100644 index 0000000000..103d1aa3c2 --- /dev/null +++ b/meta/packages/gperf/gperf-native_3.0.3.bb | |||
@@ -0,0 +1,10 @@ | |||
1 | require gperf_${PV}.bb | ||
2 | |||
3 | S = "${WORKDIR}/gperf-${PV}" | ||
4 | |||
5 | inherit native | ||
6 | |||
7 | do_stage() { | ||
8 | install -d ${STAGING_BINDIR_NATIVE} | ||
9 | install ${S}/src/gperf ${STAGING_BINDIR_NATIVE} | ||
10 | } | ||
diff --git a/meta/packages/gperf/gperf_3.0.3.bb b/meta/packages/gperf/gperf_3.0.3.bb new file mode 100644 index 0000000000..7abfb8fbfb --- /dev/null +++ b/meta/packages/gperf/gperf_3.0.3.bb | |||
@@ -0,0 +1,8 @@ | |||
1 | HOMEPAGE = "http://www.gnu.org/software/gperf" | ||
2 | LICENSE = "GPL" | ||
3 | SUMMARY = "Generate a perfect hash function from a set of keywords" | ||
4 | |||
5 | SRC_URI = "${GNU_MIRROR}/gperf/gperf-${PV}.tar.gz \ | ||
6 | file://autoreconf.patch;patch=1" | ||
7 | |||
8 | inherit autotools | ||